Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 25th April 2012, 01:19
rafael-ec rafael-ec is offline
Member
 
Join Date: Jul 2007
Posts: 57
Thanks: 15
Thanked 6 Times in 4 Posts
Default

nothing. .
Reply With Quote
Sponsored Links
  #12  
Old 25th April 2012, 14:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

That's good - I was thinking that you have a system user with that name, but that's not the case.

Do prueba@cayambelibre.com and/or prueba@cayambecalidad.org exist in your ISPConfig database?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #13  
Old 25th April 2012, 16:26
rafael-ec rafael-ec is offline
Member
 
Join Date: Jul 2007
Posts: 57
Thanks: 15
Thanked 6 Times in 4 Posts
Default

In the table mail_mailinglist I have the values:

domain: listas.cayambelibre.com
listname: prueba


regards,

Rafael
Reply With Quote
  #14  
Old 26th April 2012, 16:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

But the email accounts prueba@cayambelibre.com and/or prueba@cayambecalidad.org do not exist?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #15  
Old 26th April 2012, 17:41
rafael-ec rafael-ec is offline
Member
 
Join Date: Jul 2007
Posts: 57
Thanks: 15
Thanked 6 Times in 4 Posts
Default

No I don't. However I have in another server the domain @cayambelibre.com that is planned to be migrated to ispconfig soon. The domain @listas.cayambelibre.com is hosted in the ispconfig server and the dns are working ok.

regards,

Rafael
Reply With Quote
  #16  
Old 27th April 2012, 13:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Do the accounts exist on the other server, and do the MX records for both domains point to the other server?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #17  
Old 27th April 2012, 16:15
rafael-ec rafael-ec is offline
Member
 
Join Date: Jul 2007
Posts: 57
Thanks: 15
Thanked 6 Times in 4 Posts
Default

cayambelibre.com in one server and listas.cayambelibre.com is in ISP config server. Both MX are configured correctly and the mailing list was working on the same server before I installed ISPconfig.

Just to refresh on of the previous post in this thread. I use to have mailman for testing on this same server before using ISPconfig and it was working ok. Then I insatlled ISP config, I purged mailman and installed again. I suspect something was left on and maybe it was not completly purged. How can I uninstall completly mailman and then configure it with ispconfig. I see no one else is having this issue so maybe it was something left between this to installs.

Regards,

Rafael
Reply With Quote
  #18  
Old 27th April 2012, 17:59
rafael-ec rafael-ec is offline
Member
 
Join Date: Jul 2007
Posts: 57
Thanks: 15
Thanked 6 Times in 4 Posts
Default

BTW, I do have the need to run the main mail server on one server that I don't manage and mailman in my server with a subdomain like lists.domain.com. Have don that before, but now with ISP config.

Thanks for your help Falko.

Regards,

Rafael
Reply With Quote
  #19  
Old 28th April 2012, 09:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by rafael-ec View Post
How can I uninstall completly mailman and then configure it with ispconfig.
Run
Code:
apt-get purge mailman
Then
Code:
apt-get install mailman
and update ISPConfig - download the latest ISPConfig, unpack it, go to the install folder and run
Code:
php update.php
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #20  
Old 8th May 2012, 18:33
rafael-ec rafael-ec is offline
Member
 
Join Date: Jul 2007
Posts: 57
Thanks: 15
Thanked 6 Times in 4 Posts
 
Unhappy

Sorry for the delay. After purgin mailman I got this message:

Code:
apt-get purge mailman
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following package was automatically installed and is no longer required:
  pwgen
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  mailman*
0 upgraded, 0 newly installed, 1 to remove and 68 not upgraded.
After this operation, 45.0 MB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 42089 files and directories currently installed.)
Removing mailman ...
Stopping Mailman master qrunner: mailmanctl.
Purging configuration files for mailman ...
insserv: warning: script 'K01jailkit' missing LSB tags and overrides
insserv: warning: script 'jailkit' missing LSB tags and overrides
Purging files from ucf database ............................................... done.
dpkg: warning: while removing mailman, directory '/var/lib/mailman/data' not empty so not removed.
dpkg: warning: while removing mailman, directory '/var/lib/mailman/qfiles' not empty so not removed.
dpkg: warning: while removing mailman, directory '/var/lib/mailman/archives/private' not empty so not removed.
dpkg: warning: while removing mailman, directory '/var/lib/mailman/archives/public' not empty so not removed.
dpkg: warning: while removing mailman, directory '/var/lib/mailman/archives' not empty so not removed.
dpkg: warning: while removing mailman, directory '/var/lib/mailman/lists' not empty so not removed.
dpkg: warning: while removing mailman, directory '/var/lib/mailman' not empty so not removed.
Processing triggers for man-db ...
So without fear
Code:
rm -rf /var/lib/mailman
So as far I know bye now I have no mailman in my server. Now lets install it.
Code:
 apt-get install mailman
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
  lynx listadmin
The following NEW packages will be installed:
  mailman
0 upgraded, 1 newly installed, 0 to remove and 68 not upgraded.
Need to get 0 B/9,657 kB of archives.
After this operation, 45.0 MB of additional disk space will be used.
Preconfiguring packages ...
Selecting previously deselected package mailman.
(Reading database ... 38198 files and directories currently installed.)
Unpacking mailman (from .../mailman_1%3a2.1.13-5_i386.deb) ...
Processing triggers for man-db ...
Setting up mailman (1:2.1.13-5) ...
Looking for enabled languages (this may take some time) ... done.
Installing site language en ............................................ done.
Configuring mailman for domain cayambelibre.com ...
Upgrading from version 0x0 to 0x2010df0
getting rid of old source files
insserv: warning: script 'K01jailkit' missing LSB tags and overrides
insserv: warning: script 'jailkit' missing LSB tags and overrides
Site list for mailman missing (looking for list named 'mailman'). ... (warning).
Please create it; until then, mailman will refuse to start. ... (warning).
Not sure about those warnings related to jailkit.

I already had the latest version of ispconfig installed. So I run the update sript to reconfigure the services:
Code:
 apt-get install mailman
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
  lynx listadmin
The following NEW packages will be installed:
  mailman
0 upgraded, 1 newly installed, 0 to remove and 68 not upgraded.
Need to get 0 B/9,657 kB of archives.
After this operation, 45.0 MB of additional disk space will be used.
Preconfiguring packages ...
Selecting previously deselected package mailman.
(Reading database ... 38198 files and directories currently installed.)
Unpacking mailman (from .../mailman_1%3a2.1.13-5_i386.deb) ...
Processing triggers for man-db ...
Setting up mailman (1:2.1.13-5) ...
Looking for enabled languages (this may take some time) ... done.
Installing site language en ............................................ done.
Configuring mailman for domain cayambelibre.com ...
Upgrading from version 0x0 to 0x2010df0
getting rid of old source files
insserv: warning: script 'K01jailkit' missing LSB tags and overrides
insserv: warning: script 'jailkit' missing LSB tags and overrides
Site list for mailman missing (looking for list named 'mailman'). ... (warning).
Please create it; until then, mailman will refuse to start. ... (warning).
Mailman does not start
Code:
/etc/init.d/mailman restart
Restarting Mailman master qrunner: mailmanctlPID unreadable in: /var/run/mailman/mailman.pid
[Errno 2] No such file or directory: '/var/run/mailman/mailman.pid'
Is qrunner even running?
Site list is missing: mailman
 failed!
So I repeat the prosudre, purge mailman, delete /var/lib/mailman and install it again. This time I created the mailman list:
Code:
newlist mailman
Enter the email of the person running the list: rafael@bonifaz.ec
Initial mailman password: 
To finish creating your mailing list, you must edit your /etc/aliases (or
equivalent) file by adding the following lines, and possibly running the
`newaliases' program:

## mailman mailing list
mailman:              "|/var/lib/mailman/mail/mailman post mailman"
mailman-admin:        "|/var/lib/mailman/mail/mailman admin mailman"
mailman-bounces:      "|/var/lib/mailman/mail/mailman bounces mailman"
mailman-confirm:      "|/var/lib/mailman/mail/mailman confirm mailman"
mailman-join:         "|/var/lib/mailman/mail/mailman join mailman"
mailman-leave:        "|/var/lib/mailman/mail/mailman leave mailman"
mailman-owner:        "|/var/lib/mailman/mail/mailman owner mailman"
mailman-request:      "|/var/lib/mailman/mail/mailman request mailman"
mailman-subscribe:    "|/var/lib/mailman/mail/mailman subscribe mailman"
mailman-unsubscribe:  "|/var/lib/mailman/mail/mailman unsubscribe mailman"

Hit enter to notify mailman owner...
I am not going to edit the alias, because as far as I know ispconfig does that job. So I run update.php again.

Now I only get some warnings related to apache:

Code:
PID unreadable in: /var/run/mailman/mailman.pid
[Errno 2] No such file or directory: '/var/run/mailman/mailman.pid'
Is qrunner even running?
Restarting Mailman master qrunner: mailmanctl.
[Tue May 08 11:26:51 2012] [warn] The ScriptAlias directive in /etc/apache2/sites-enabled/mailman.conf at line 4 will probably never match because it overlaps an earlier ScriptAlias.
[Tue May 08 11:26:51 2012] [warn] The Alias directive in /etc/apache2/sites-enabled/mailman.conf at line 6 will probably never match because it overlaps an earlier Alias.
[Tue May 08 11:26:51 2012] [warn] The Alias directive in /etc/apache2/sites-enabled/mailman.conf at line 8 will probably never match because it overlaps an earlier Alias.
[Tue May 08 11:26:52 2012] [warn] The ScriptAlias directive in /etc/apache2/sites-enabled/mailman.conf at line 4 will probably never match because it overlaps an earlier ScriptAlias.
[Tue May 08 11:26:52 2012] [warn] The Alias directive in /etc/apache2/sites-enabled/mailman.conf at line 6 will probably never match because it overlaps an earlier Alias.
[Tue May 08 11:26:52 2012] [warn] The Alias directive in /etc/apache2/sites-enabled/mailman.conf at line 8 will probably never match because it overlaps an earlier Alias.
Restarting web server: apache2 ... waiting .
Restarting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -D -b -u 1000 -Y 1 -O clf:/var/log/pure-ftpd/transfer.log -E -A -8 UTF-8 -H -B
Update finished.
Now I can start mailman. Time to test. I create the same mailing list as before and add some mails. Send the first mail and I get the mail bounce again . What could I possible be doing wrong?

Quote:
This is the mail system at host hosting.cayambelibre.com.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

<pruebas@cayambelibre.com> (expanded from <pruebas@listas.cayambelibre.com>):
host mail.cayambelibre.com[173.230.147.82] said: 550 5.1.1
<pruebas@cayambelibre.com>: Recipient address rejected: User unknown in
virtual mailbox table (in reply to RCPT TO command)



Reporting-MTA: dns; hosting.cayambelibre.com
X-Postfix-Queue-ID: 3A63D2B357
X-Postfix-Sender: rfc822; rafael@bonifaz.ec
Arrival-Date: Tue, 8 May 2012 11:30:32 -0500 (ECT)

Final-Recipient: rfc822; pruebas@cayambelibre.com
Original-Recipient: rfc822;pruebas@listas.cayambelibre.com
Action: failed
Status: 5.1.1
Remote-MTA: dns; mail.cayambelibre.com
Diagnostic-Code: smtp; 550 5.1.1 <pruebas@cayambelibre.com>: Recipient address
rejected: User unknown in virtual mailbox table
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 15:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.