Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th January 2014, 13:05
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default Aliases Domain do not work as well

Hi guys, good year!
I am trying to create an alias domain but ISPConfig doesn't change the virtualhost file. I am using a debian distro and a multiserver setup of ISPConfig.

I can see the cron task executed but nothing change.

what is the problem?

thanks
Reply With Quote
Sponsored Links
  #2  
Old 7th January 2014, 13:45
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,986
Thanks: 840
Thanked 5,647 Times in 4,457 Posts
Default

Please see here:

http://www.howtoforge.com/forums/showthread.php?t=58408
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 7th January 2014, 14:11
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default

Hi again,

here the result of the debug task:

Code:
## /usr/local/ispconfig/server/server.sh
07.01.2014-12:04 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
07.01.2014-12:04 - DEBUG - Found 2 changes, starting update process.
07.01.2014-12:04 - DEBUG - Calling function 'ssl' from plugin 'apache2_plugin' raised by event 'web_domain_insert'.
07.01.2014-12:04 - DEBUG - Calling function 'insert' from plugin 'apache2_plugin' raised by event 'web_domain_insert'.
setquota: Not setting block grace time on /dev/disk/by-uuid/5376739d-9145-48f8-bf8a-f583671aea20 because softlimit is not exceeded.
setquota: Not setting inode grace time on /dev/disk/by-uuid/5376739d-9145-48f8-bf8a-f583671aea20 because softlimit is not exceeded.
07.01.2014-12:04 - DEBUG - exec: usermod --groups sshusers web4057 2>/dev/null
07.01.2014-12:04 - DEBUG - Add server alias: mydomain.es
07.01.2014-12:04 - DEBUG - Add server alias: mydomain.fr
07.01.2014-12:04 - DEBUG - Add server alias: de.mydomain.com
07.01.2014-12:04 - DEBUG - Creating fastcgi starter script: /var/www/php-fcgi-scripts/web4057/.php-fcgi-starter
07.01.2014-12:04 - DEBUG - Writing the vhost file: /etc/apache2/sites-available/mydomain.com.vhost
PHP Warning:  symlink(): File exists in /usr/local/ispconfig/server/plugins-available/apache2_plugin.inc.php on line 1421
07.01.2014-12:04 - DEBUG - Creating symlink: /etc/apache2/sites-enabled/100-mydomain.com.vhost->/etc/apache2/sites-available/mydomain.com.vhost
07.01.2014-12:04 - DEBUG - Apache status is: running
07.01.2014-12:04 - DEBUG - Calling function 'restartHttpd' from module 'web_module'.
07.01.2014-12:04 - DEBUG - Apache restart return value is: 0
07.01.2014-12:04 - DEBUG - Apache online status after restart is: running
07.01.2014-12:04 - DEBUG - Processed datalog_id 15532
07.01.2014-12:04 - DEBUG - Calling function 'ssl' from plugin 'apache2_plugin' raised by event 'web_domain_update'.
07.01.2014-12:04 - DEBUG - Calling function 'update' from plugin 'apache2_plugin' raised by event 'web_domain_update'.
setquota: Not setting block grace time on /dev/disk/by-uuid/5376739d-9145-48f8-bf8a-f583671aea20 because softlimit is not exceeded.
setquota: Not setting inode grace time on /dev/disk/by-uuid/5376739d-9145-48f8-bf8a-f583671aea20 because softlimit is not exceeded.
07.01.2014-12:04 - DEBUG - exec: usermod --groups sshusers web4057 2>/dev/null
07.01.2014-12:04 - DEBUG - Add server alias: mydomain.es
07.01.2014-12:04 - DEBUG - Add server alias: mydomain.fr
07.01.2014-12:04 - DEBUG - Add server alias: de.mydomain.com
07.01.2014-12:04 - DEBUG - Creating fastcgi starter script: /var/www/php-fcgi-scripts/web4057/.php-fcgi-starter
07.01.2014-12:04 - DEBUG - Writing the vhost file: /etc/apache2/sites-available/mydomain.com.vhost
PHP Warning:  symlink(): File exists in /usr/local/ispconfig/server/plugins-available/apache2_plugin.inc.php on line 1421
07.01.2014-12:04 - DEBUG - Creating symlink: /etc/apache2/sites-enabled/100-mydomain.com.vhost->/etc/apache2/sites-available/mydomain.com.vhost
07.01.2014-12:04 - DEBUG - Apache status is: running
07.01.2014-12:04 - DEBUG - Calling function 'restartHttpd' from module 'web_module'.
07.01.2014-12:04 - DEBUG - Apache restart return value is: 0
07.01.2014-12:04 - DEBUG - Apache online status after restart is: running
07.01.2014-12:04 - DEBUG - Processed datalog_id 15533
07.01.2014-12:04 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
finished.

Last edited by vaio1; 7th January 2014 at 14:15.
Reply With Quote
  #4  
Old 7th January 2014, 14:13
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,986
Thanks: 840
Thanked 5,647 Times in 4,457 Posts
Default

Is the alias that you miss listed here?

07.01.2014-12:04 - DEBUG - Add server alias: sportlet.es
07.01.2014-12:04 - DEBUG - Add server alias: sportlet.fr
07.01.2014-12:04 - DEBUG - Add server alias: de.mydomain.com

if yes, open the file:

/etc/apache2/sites-enabled/100-mydomain.com.vhost

and check if the alias is listed there as well.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 7th January 2014, 14:15
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default

Yes they are listed there but there is not any alias in the Vhost file
Reply With Quote
  #6  
Old 7th January 2014, 16:07
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default

any idea about the issue?
Reply With Quote
  #7  
Old 7th January 2014, 16:29
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,986
Thanks: 840
Thanked 5,647 Times in 4,457 Posts
Default

Please post the output of:

ls -la /etc/apache2/sites-available/mydomain.com*

and

ls -la /usr/local/ispconfig/server/conf-custom

and the content of the file:

/etc/apache2/sites-available/mydomain.com.vhost
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 7th January 2014, 16:50
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default

here we go:

Code:
# ls -la /etc/apache2/sites-available/mydomain.com.*
-rw-r--r-- 1 root root 2875 Jan  7 13:04 /etc/apache2/sites-available/mydomain.com.vhost
Code:
#  ls -la /usr/local/ispconfig/server/conf-custom
total 24
drwxr-s---  6 ispconfig ispconfig 4096 Aug 11 16:52 .
drwxr-s--- 15 ispconfig ispconfig 4096 Feb 27  2013 ..
drwxr-s---  2 ispconfig ispconfig 4096 Feb 16  2011 error
drwxr-s---  2 ispconfig ispconfig 4096 Feb 16  2011 index
drwxr-s---  2 ispconfig ispconfig 4096 Aug 11 16:52 install
drwxr-s---  2 ispconfig ispconfig 4096 Nov  6  2011 mail
Code:
<Directory /var/www/mydomain.com>
		AllowOverride None
		Order Deny,Allow
		Deny from all
</Directory>

<VirtualHost *:80>
					DocumentRoot /var/www/mydomain.com/web
			
		ServerName mydomain.com
		ServerAlias www.mydomain.com
		ServerAdmin webmaster@mydomain.com

		ErrorLog /var/log/ispconfig/httpd/mydomain.com/error.log

		Alias /error/ "/var/www/mydomain.com/web/error/"
		ErrorDocument 400 /error/400.html
		ErrorDocument 401 /error/401.html
		ErrorDocument 403 /error/403.html
		ErrorDocument 404 /error/404.html
		ErrorDocument 405 /error/405.html
		ErrorDocument 500 /error/500.html
		ErrorDocument 502 /error/502.html
		ErrorDocument 503 /error/503.html

		<IfModule mod_ssl.c>
		</IfModule>

		<Directory /var/www/mydomain.com/web>
				Options FollowSymLinks
				AllowOverride All
				Order allow,deny
				Allow from all
		</Directory>
		<Directory /var/www/clients/client234/web4036/web>
				Options FollowSymLinks
				AllowOverride All
				Order allow,deny
				Allow from all
		</Directory>




		# suexec enabled
		<IfModule mod_suexec.c>
			SuexecUserGroup web4036 client234
		</IfModule>
		# Clear PHP settings of this website
		<FilesMatch "\.ph(p3?|tml)$">
				SetHandler None
		</FilesMatch>
		# php as fast-cgi enabled
	# For config options see: http://httpd.apache.org/mod_fcgid/mod/mod_fcgid.html
		<IfModule mod_fcgid.c>
				IdleTimeout 300
				ProcessLifeTime 3600
				# MaxProcessCount 1000
				DefaultMinClassProcessCount 0
				DefaultMaxClassProcessCount 100
				IPCConnectTimeout 3
				IPCCommTimeout 360
				BusyTimeout 300
		</IfModule>
		<Directory /var/www/mydomain.com/web>
				AddHandler fcgid-script .php .php3 .php4 .php5
				FCGIWrapper /var/www/php-fcgi-scripts/web4036/.php-fcgi-starter .php
				Options +ExecCGI
				AllowOverride All
				Order allow,deny
				Allow from all
		</Directory>
		<Directory /var/www/clients/client234/web4036/web>
				AddHandler fcgid-script .php .php3 .php4 .php5
				FCGIWrapper /var/www/php-fcgi-scripts/web4036/.php-fcgi-starter .php
				Options +ExecCGI
				AllowOverride All
				Order allow,deny
				Allow from all
		</Directory>


		# add support for apache mpm_itk
		<IfModule mpm_itk_module>
			AssignUserId web4036 client234
		</IfModule>

		<IfModule mod_dav_fs.c>
		# Do not execute PHP files in webdav directory
			<Directory /var/www/clients/client234/web4036/webdav>
				<ifModule mod_security2.c>
					SecRuleRemoveById 960015
					SecRuleRemoveById 960032
				</ifModule>
				<FilesMatch "\.ph(p3?|tml)$">
					SetHandler None
				</FilesMatch>
			</Directory>
			DavLockDB /var/www/clients/client234/web4036/tmp/DavLock
			# DO NOT REMOVE THE COMMENTS!
			# IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
      # WEBDAV BEGIN
			# WEBDAV END
		</IfModule>

RLimitCPU 600
</VirtualHost>
Reply With Quote
  #9  
Old 8th January 2014, 10:14
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default

Good morning Till,

any news? or hint?

thanks
Reply With Quote
  #10  
Old 9th January 2014, 13:34
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
 
Default

Hi Till I have solved the issue debugging the code by the /usr/local/ispconfig/server/server.sh script. Now I can see the ServerAlias row in the mydomain.com.vhost file.

When I try to open the new alias I am not redirected to the correct domain, the default ISPConfig page is shown.

I have restarted the Apache everytime I made an edit.

regards
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix queue problem? murunix Server Operation 7 2nd May 2011 02:55
Domain aliases dont reject unknown users edispah Installation/Configuration 1 10th February 2011 00:36
email domain aliases Wojtek1 General 2 15th October 2010 21:35
work on site before domain name resolves Steen General 4 7th September 2008 01:59
Pure domain DNS doesn't work SyRenity Installation/Configuration 7 12th December 2006 13:12


All times are GMT +2. The time now is 03:13.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.