Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th April 2012, 14:02
ollea ollea is offline
Junior Member
 
Join Date: Sep 2011
Location: Switzerland
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation vhost.conf.master does not generate any virtual host

Hello,

I am experiencing a problem with the /usr/local/ispconfig/server/conf/vhost.conf.master file.
When I create or modify a website it generates the following Apache config file :

<Directory /var/www/mydomain.com>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

It looks like it does not loop in the <tmpl_loop name="vhosts">.

This was working before I updated to 3.0.4.4.

If anybody can help me ? Thank you !
Reply With Quote
Sponsored Links
  #2  
Old 17th April 2012, 14:25
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,792
Thanks: 821
Thanked 5,338 Times in 4,188 Posts
Default

Please post the output of:

ls -la /usr/local/ispconfig/server/conf-custom/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 17th April 2012, 14:51
ollea ollea is offline
Junior Member
 
Join Date: Sep 2011
Location: Switzerland
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here it is :

host:~# ls -laR /usr/local/ispconfig/server/conf-custom/
/usr/local/ispconfig/server/conf-custom/:
total 20
drwxr-s--- 5 ispconfig ispconfig 4096 2012-04-10 23:30 .
drwxr-s--- 13 ispconfig ispconfig 4096 2012-04-10 23:37 ..
drwxr-s--- 2 ispconfig ispconfig 4096 2009-03-26 00:40 error
drwxr-s--- 2 ispconfig ispconfig 4096 2012-04-10 23:37 index
drwxr-s--- 2 ispconfig ispconfig 4096 2012-04-10 23:30 mail

/usr/local/ispconfig/server/conf-custom/error:
total 8
drwxr-s--- 2 ispconfig ispconfig 4096 2009-03-26 00:40 .
drwxr-s--- 5 ispconfig ispconfig 4096 2012-04-10 23:30 ..

/usr/local/ispconfig/server/conf-custom/index:
total 16
drwxr-s--- 2 ispconfig ispconfig 4096 2012-04-10 23:37 .
drwxr-s--- 5 ispconfig ispconfig 4096 2012-04-10 23:30 ..
-rwxr-x--- 1 ispconfig ispconfig 1406 2009-11-26 15:11 favicon.ico
-rwxr-x--- 1 ispconfig ispconfig 1937 2012-04-10 23:37 standard_index.html

/usr/local/ispconfig/server/conf-custom/mail:
total 8
drwxr-s--- 2 ispconfig ispconfig 4096 2012-04-10 23:30 .
drwxr-s--- 5 ispconfig ispconfig 4096 2012-04-10 23:30 ..

I also tried to replace the /usr/local/ispconfig/server/conf/vhost.conf.master file by the package one but I get same result.
Reply With Quote
  #4  
Old 18th April 2012, 06:36
ollea ollea is offline
Junior Member
 
Join Date: Sep 2011
Location: Switzerland
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Question

Any ideas would be more than welcome, thanks !
Reply With Quote
  #5  
Old 18th April 2012, 08:42
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,792
Thanks: 821
Thanked 5,338 Times in 4,188 Posts
Default

The above output is fine.

Please try this procedure and post the output that you get on the shell:

http://www.faqforge.com/linux/debugg...-of-a-failure/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 18th April 2012, 10:45
ollea ollea is offline
Junior Member
 
Join Date: Sep 2011
Location: Switzerland
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

"Unfortunately" no problem, the script returns only this line : "finished."
Reply With Quote
  #7  
Old 18th April 2012, 11:56
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,792
Thanks: 821
Thanked 5,338 Times in 4,188 Posts
Default

Then debugging is not enabled. Please check again that you enabled loglevel debug for this server under System > server config
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 18th April 2012, 14:09
ollea ollea is offline
Junior Member
 
Join Date: Sep 2011
Location: Switzerland
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sorry, I hadn't enabled debugging, now it's more verbose :

18.04.2012-12:01 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
18.04.2012-12:01 - DEBUG - Found 1 changes, starting update process.
18.04.2012-12:01 - DEBUG - Unable to register function 'insert' from plugin 'mailman_plugin' for event 'mail_mailinglist_insert'
18.04.2012-12:01 - DEBUG - Unable to register function 'update' from plugin 'mailman_plugin' for event 'mail_mailinglist_update'
18.04.2012-12:01 - DEBUG - Unable to register function 'delete' from plugin 'mailman_plugin' for event 'mail_mailinglist_delete'
18.04.2012-12:01 - DEBUG - Calling function 'ssl' from plugin 'apache2_plugin' raised by event 'web_domain_update'.
18.04.2012-12:01 - DEBUG - Calling function 'update' from plugin 'apache2_plugin' raised by event 'web_domain_update'.
18.04.2012-12:01 - DEBUG - exec: chmod 755 /var/www/clients/client91/web305/
18.04.2012-12:01 - DEBUG - exec: chmod 755 /var/www/clients/client91/web305/\*
chmod: cannot access `/var/www/clients/client91/web305/*': No such file or directory
18.04.2012-12:01 - DEBUG - exec: chown root:root /var/www/clients/client91/web305/
18.04.2012-12:01 - DEBUG - exec: chmod 777 /var/www/clients/client91/web305/tmp
18.04.2012-12:01 - DEBUG - exec: chown web305:client91 /var/www/clients/client91/web305/log/error.log
18.04.2012-12:01 - DEBUG - Disable SSL for:
18.04.2012-12:01 - DEBUG - Writing the vhost file: /etc/apache2/sites-available/mydomain.ch.vhost
18.04.2012-12:01 - DEBUG - Apache status is: 1
18.04.2012-12:01 - DEBUG - Calling function 'restartHttpd' from module 'web_module'.
18.04.2012-12:01 - DEBUG - Apache online status after restart is: 1
18.04.2012-12:01 - DEBUG - Processed datalog_id 7108
18.04.2012-12:01 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock

Apparently there are a few errors with mailman_plugin and chmod but nothing with vhost ?!
Reply With Quote
  #9  
Old 18th April 2012, 14:11
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,792
Thanks: 821
Thanked 5,338 Times in 4,188 Posts
Default

Your system seems to be not updated correctly.Please redo the update by following the manual update instructions:

http://www.howtoforge.com/forums/showthread.php?t=56854

and choose to reconfigure services during update. You should also check the security level of the website, it should be set to high under system > server config > web
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 18th April 2012, 15:25
ollea ollea is offline
Junior Member
 
Join Date: Sep 2011
Location: Switzerland
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Thanks for the instructions. I did the update again like this :

Code:
host:~/downloads/ispconfig3_install/install# php -q update.php 


--------------------------------------------------------------------------------
 _____ ___________   _____              __ _         ____
|_   _/  ___| ___ \ /  __ \            / _(_)       /__  \
  | | \ `--.| |_/ / | /  \/ ___  _ __ | |_ _  __ _    _/ /
  | |  `--. \  __/  | |    / _ \| '_ \|  _| |/ _` |  |_ |
 _| |_/\__/ / |     | \__/\ (_) | | | | | | | (_| | ___\ \
 \___/\____/\_|      \____/\___/|_| |_|_| |_|\__, | \____/
                                              __/ |
                                             |___/ 
--------------------------------------------------------------------------------


>> Update  

Operating System: Debian Lenny or compatible

This application will update ISPConfig 3 on your server.

Shall the script create a ISPConfig backup in /var/backup/ now? (yes,no) [yes]: 

PHP Warning:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2.0/DST' instead in /root/downloads/ispconfig3_install/install/update.php on line 131
Creating backup of "/usr/local/ispconfig" directory...
Creating backup of "/etc" directory...
Checking ISPConfig database .. OK
Starting incremental database update.
Reconfigure Permissions in master database? (yes,no) [no]: 

Reconfigure Services? (yes,no) [yes]: 

Configuring Postfix
Configuring Mailman
Configuring Jailkit
Configuring SASL
Configuring PAM
Configuring Courier
Configuring Spamassassin
Configuring Amavisd
Configuring Getmail
Configuring Pureftpd
Configuring MyDNS
Configuring Apache
Configuring vlogger
Configuring Apps vhost
Configuring Database
Updating ISPConfig
ISPConfig Port [8888]: 

Create new ISPConfig SSL certificate (yes,no) [no]: 

Reconfigure Crontab? (yes,no) [yes]: 

Updating Crontab
Restarting services ...
Stopping MySQL database server: mysqld.
Starting MySQL database server: mysqld.
Checking for corrupt, not cleanly closed and upgrade needing tables..
Stopping Postfix Mail Transport Agent: postfix.
Starting Postfix Mail Transport Agent: postfix.
Stopping SASL Authentication Daemon: saslauthd.
Starting SASL Authentication Daemon: saslauthd.
Stopping amavisd: amavisd-new.
Starting amavisd: amavisd-new.
Stopping ClamAV daemon: clamd.
Starting ClamAV daemon: clamd .
Stopping Courier authentication services: authdaemond.
Starting Courier authentication services: authdaemond.
Stopping Courier IMAP server: imapd.
Starting Courier IMAP server: imapd.
Stopping Courier IMAP-SSL server: imapd-ssl.
Starting Courier IMAP-SSL server: imapd-ssl.
Stopping Courier POP3 server: pop3d.
Starting Courier POP3 server: pop3d.
Stopping Courier POP3-SSL server: pop3d-ssl.
Starting Courier POP3-SSL server: pop3d-ssl.
Restarting web server: apache2 ... waiting .
Restarting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -u 1000 -E -A -b -O clf:/var/log/pure-ftpd/transfer.log -H -D -B
Update finished.
I regenerated the vhost files but still the same result. Please find attached my new /usr/local/ispconfig/server/conf/vhost.conf.master file (after the update).

Note that I'm running 32-bit Debian lenny.
Attached Files
File Type: txt vhost.conf.master.txt (8.0 KB, 111 views)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My Server Is Sending Spam. How Do I Block This? LordJ Server Operation 1 7th July 2011 19:34
Postfix queue problem? murunix Server Operation 7 2nd May 2011 01:55
smtp is error!!! fhawk Installation/Configuration 2 7th April 2009 13:17
Postfix problem: lost connection after CONNECT from unknown fernando_torrez Server Operation 5 30th November 2007 14:17
This is %#@*&^$# embarrassing! domino Smalltalk 34 5th February 2007 21:57


All times are GMT +2. The time now is 23:21.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.