Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 3rd July 2012, 14:09
ArtDanilov ArtDanilov is offline
Junior Member
 
Join Date: Jul 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Problems with domain floders crating

Hello.
I'm using ISPConfig 3.0.2.2. Using for about 1,5 years. There were no ploblems or bugs. But today found one big problem - when i create a new domain, ispconfig creates its .vhost file in apache folders, but it doesn't create any folder like /client*/web*/* and it doesn't create any user web* .

I searched ispconfig's php scripts for folder creating commands references but not found them.

I read about jobqueue file, but i don't now where it is.

Can you please help me to find out a problem or point me to the way how to find out where the problem's root is?

Thank you.
Reply With Quote
Sponsored Links
  #2  
Old 3rd July 2012, 14:19
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,452
Thanks: 813
Thanked 5,222 Times in 4,092 Posts
Default

See FAQ:

http://www.faqforge.com/linux/debugg...-of-a-failure/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 3rd July 2012, 14:38
ArtDanilov ArtDanilov is offline
Junior Member
 
Join Date: Jul 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy

Quote:
Originally Posted by till View Post
Thank you, Till.
That's what the ispconfig's log file contains when i try to create a domain:
03.07.2012-16:26 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
03.07.2012-16:26 - DEBUG - Found 2 changes, starting update process.
03.07.2012-16:26 - DEBUG - Call function 'update' in plugin 'apps_vhost_plugin' raised by event 'server_update'.
03.07.2012-16:26 - DEBUG - Call function 'update' in plugin 'network_settings_plugin' raised by event 'server_update'.
03.07.2012-16:26 - DEBUG - Changed Network settings
03.07.2012-16:26 - DEBUG - Call function 'update' in plugin 'postfix_server_plugin' raised by event 'server_update'.
03.07.2012-16:26 - DEBUG - Processed datalog_id 4040
03.07.2012-16:26 - DEBUG - Call function 'update' in plugin 'apps_vhost_plugin' raised by event 'server_update'.
03.07.2012-16:26 - DEBUG - Call function 'update' in plugin 'network_settings_plugin' raised by event 'server_update'.
03.07.2012-16:26 - DEBUG - Changed Network settings
03.07.2012-16:26 - DEBUG - Call function 'update' in plugin 'postfix_server_plugin' raised by event 'server_update'.
03.07.2012-16:26 - DEBUG - Processed datalog_id 4041
03.07.2012-16:26 - DEBUG - Call function 'restartHttpd' in module 'web_module'.
03.07.2012-16:26 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
03.07.2012-16:27 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
03.07.2012-16:27 - DEBUG - Found 1 changes, starting update process.
03.07.2012-16:27 - DEBUG - Call function 'ssl' in plugin 'apache2_plugin' raised by event 'web_domain_insert'.
03.07.2012-16:27 - DEBUG - Call function 'insert' in plugin 'apache2_plugin' raised by event 'web_domain_insert'.
03.07.2012-16:27 - DEBUG - Creating Symlink: ln -s /var/log/ispconfig/httpd/12312312312.com /var/www/clients/client1/web242/log
03.07.2012-16:27 - DEBUG - Creating Symlink: ln -s /var/www/clients/client1/web242/ /var/www/12312312312.com
03.07.2012-16:27 - DEBUG - Creating Symlink: ln -s /var/www/clients/client1/web242/ /var/www/clients/client1/12312312312.com
03.07.2012-16:27 - DEBUG - Adding the user: web242
03.07.2012-16:27 - DEBUG - exec: chown -R web242:client1 /var/www/clients/client1/web242
03.07.2012-16:27 - DEBUG - exec: chown web242:client1 /var/www/clients/client1/web242
03.07.2012-16:27 - DEBUG - exec: chmod 751 /var/www/clients/client1/web242/
03.07.2012-16:27 - DEBUG - exec: chmod 751 /var/www/clients/client1/web242/*
03.07.2012-16:27 - DEBUG - exec: chmod 710 /var/www/clients/client1/web242/web
03.07.2012-16:27 - DEBUG - exec: chmod 777 /var/www/clients/client1/web242/tmp
03.07.2012-16:27 - DEBUG - exec: usermod --groups sshusers web242
03.07.2012-16:27 - DEBUG - exec: chown web242:client1 /var/www/clients/client1/web242
03.07.2012-16:27 - DEBUG - exec: chown web242:client1 /var/www/clients/client1/web242/log/error.log
03.07.2012-16:27 - DEBUG - Disable SSL for:
03.07.2012-16:27 - DEBUG - Creating fastcgi starter script directory: /var/www/php-fcgi-scripts/web242/
03.07.2012-16:27 - DEBUG - Creating fastcgi starter script: /var/www/php-fcgi-scripts/web242/.php-fcgi-starter
03.07.2012-16:27 - DEBUG - Writing the vhost file: /etc/apache2/sites-available/12312312312.com.vhost
03.07.2012-16:27 - DEBUG - Creating the symlink: /etc/apache2/sites-enabled/12312312312.com.vhost => /etc/apache2/sites-available/12312312312.com.vhost
03.07.2012-16:27 - DEBUG - Processed datalog_id 4042
03.07.2012-16:27 - DEBUG - Call function 'restartHttpd' in module 'web_module'.

Directory /var/www/clients/client1/web242/ was not created, user web242 was not created, so all the the upper commands were not executed successfully. By the way - fastcgi starter script also was not created.

What is the problem could be?
Reply With Quote
  #4  
Old 3rd July 2012, 14:44
ArtDanilov ArtDanilov is offline
Junior Member
 
Join Date: Jul 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default problem eliminated

That was security misunderstanding - system function were disabled in cli's php.ini .

Thank you.
Reply With Quote
  #5  
Old 3rd July 2012, 14:58
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,452
Thanks: 813
Thanked 5,222 Times in 4,092 Posts
 
Default

You can sfely disable system and exec in the cgi and pache2 php.ini files but in the cli php.ini file it must be enabled. Disabling shell functions for shell scripts does not make much sense anyway.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Issues with Baruwa - The Perfect Spamsnake Ubuntu 10.10 neofire HOWTO-Related Questions 44 31st May 2011 15:09
Postfix queue problem? murunix Server Operation 7 2nd May 2011 01:55
Domain name server - problems ... causes ? Amorphous Installation/Configuration 5 14th April 2011 23:28
Postfix not forwarding for some domains flappy Installation/Configuration 3 21st November 2010 17:57
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 16:59


All times are GMT +2. The time now is 15:34.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.