#1  
Old 10th April 2012, 14:10
Christovampaynes Christovampaynes is offline
Member
 
Join Date: Jan 2012
Posts: 41
Thanks: 1
Thanked 0 Times in 0 Posts
Default Permission Denied

hello,
I'm not cnosegui these errors and identify the problem. someone has gone through this?
this error is appearing in almost all domains.


ls -la /var/vmail
total 80
drwxr-xr-x 16 vmail vmail 4096 2012-01-19 10:23 .
drwxr-xr-x 20 root root 4096 2012-03-12 16:36 ..
drwxrwxr-x 4 vmail vmail 4096 2012-03-19 14:40 mydomain.com.br

ls -la /usr/bin/maildrop
-rwxr-sr-x 1 root mail 175488 2010-02-02 04:43 /usr/bin/maildrop



Apr 10 08:32:34 server postfix/pipe[28969]: EDF52521CFC: to=<web32@mydomain.com.br>, relay=maildrop, delay=76185, delays=76185/0.01/0/0.02, dsn=4.3.0, status=deferred (temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to create a dot-lock at /var/vmail/mydomain.com.br/web32/28973.0.server.mydomain.com.br. )
Apr 10 08:32:34 server postfix/pipe[28969]: E1187521FD3: to=<web34@mydomain.com.br>, relay=maildrop, delay=76195, delays=76195/0.03/0/0.02, dsn=4.3.0, status=deferred (temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to create a dot-lock at /var/vmail/mydomain.com.br/web34/28985.0.server.mydomain.com.br. )
Apr 10 08:32:34 server postfix/pipe[28936]: 9D0E952005A: to=<root@mydomain.com.br>, relay=maildrop, delay=353219, delays=353219/0.02/0/0.03, dsn=4.3.0, status=deferred (temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to open mailbox. )
Apr 10 08:32:34 server postfix/pipe[28969]: 15F85521CDF: to=<web34@mydomain.com.br>, relay=maildrop, delay=76191, delays=76191/0.05/0/0.01, dsn=4.3.0, status=deferred (temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to create a dot-lock at /var/vmail/mydomain.com.br/web34/28993.0.server.mydomain.com.br. )
Apr 10 08:32:34 server postfix/pipe[28936]: 9B7E4521BAC: to=<root@mydomain.com.br>, relay=maildrop, delay=160502, delays=160502/0.05/0/0.01, dsn=4.3.0, status=deferred (temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to open mailbox. )
Apr 10 08:32:34 server postfix/pipe[28969]: 14942521F76: to=<web32@mydomain.com.br>, relay=maildrop, delay=76194, delays=76194/0.06/0/0.01, dsn=4.3.0, status=deferred (temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to create a dot-lock at /var/vmail/mydomain.com.br/web32/29002.0.server.mydomain.com.br. )
Apr 10 08:32:34 server postfix/pipe[28936]: DAF86521B29: to=<root@mydomain.com.br>, relay=maildrop, delay=236103, delays=236103/0.06/0/0.02, dsn=4.3.0, status=deferred (temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to open mailbox. )
Apr 10 08:32:34 server postfix/pipe[28969]: D6334521F98: to=<root@mydomain.com.br>, relay=maildrop, delay=179402, delays=179402/0.08/0/0.01, dsn=4.3.0, status=deferred (temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to open mailbox. )


Thanks.
Reply With Quote
Sponsored Links
  #2  
Old 10th April 2012, 22:19
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,715
Thanks: 819
Thanked 5,321 Times in 4,174 Posts
Default

I guess the path settings for email are wrong. Which pahs are set on the mail tab of the server config in ispconfig an which ispconfig version do you use?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 10th April 2012, 23:10
Christovampaynes Christovampaynes is offline
Member
 
Join Date: Jan 2012
Posts: 41
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
I guess the path settings for email are wrong. Which pahs are set on the mail tab of the server config in ispconfig an which ispconfig version do you use?
I will send a picture of the configuration

ISPConfig Version: 3.0.4.3
Attached Images
 
Reply With Quote
  #4  
Old 11th April 2012, 07:42
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,715
Thanks: 819
Thanked 5,321 Times in 4,174 Posts
Default

Thats ok. Which path do you see in the mail_user table of the ispconfig database for tha affected account?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 11th April 2012, 13:48
Christovampaynes Christovampaynes is offline
Member
 
Join Date: Jan 2012
Posts: 41
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
Thats ok. Which path do you see in the mail_user table of the ispconfig database for tha affected account?
Hello,
so that:

5000 5000 /var/vmail/mydomain.com.br/user1 0 /var/vmail n 0000-00-00 00:00:00 0000-00-00 00:00:00 NULL n NULL y n n n n n n n 69 1 10 riud riud 1 user1@mydomain.com.br user1@mydomain.com.br $1$yZmODBep$c5zUm9P0noqSR19df7e9p. User user1.

5000 5000 /var/vmail/mydomain.com.br/user2 0 /var/vmail n 0000-00-00 00:00:00 0000-00-00 00:00:00 NULL n NULL y n n n n n n n
70 1 10 riud riud 1 user2@mydomain.com.br ruser@mydomain.com.br $1$2Rlxf2zb$ES8oJVtdfNhbC2XrKDBsR. user2 Interno.




I realized that this directory does not exist error "/ var/vmail/mydomain.com.br/web32"
need to create it manually?

Thanks
Reply With Quote
  #6  
Old 11th April 2012, 14:06
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,715
Thanks: 819
Thanked 5,321 Times in 4,174 Posts
Default

Quote:
I realized that this directory does not exist error "/ var/vmail/mydomain.com.br/web32"
need to create it manually?
No. There should not be such a directory, thats why I asked you to search for it to verify that it really does not exist. So the first error messahe id not the reason for your problem.

Which Linux distribution do you use?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 11th April 2012, 14:24
Christovampaynes Christovampaynes is offline
Member
 
Join Date: Jan 2012
Posts: 41
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
No. There should not be such a directory, thats why I asked you to search for it to verify that it really does not exist. So the first error messahe id not the reason for your problem.

Which Linux distribution do you use?

This WEB34 and WEB32 not exist in the table mail_user, and I've never made this account. tell me what of these messages?

I'm using ubuntu 11.04.
Reply With Quote
  #8  
Old 11th April 2012, 14:38
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,715
Thanks: 819
Thanked 5,321 Times in 4,174 Posts
Default

Quote:
This WEB34 and WEB32 not exist in the table mail_user, and I've never made this account. tell me what of these messages?
Thats all ok and not related to your problem. the messages are system message bounces.

Most likely a permission of the maildrop socket is wrong. I recommend that you update to ispconfig 3.0.4.4 and choose to reconfigure services so that the configuration of the mail system gets rewritten.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 11th April 2012, 15:31
Christovampaynes Christovampaynes is offline
Member
 
Join Date: Jan 2012
Posts: 41
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by till View Post
Thats all ok and not related to your problem. the messages are system message bounces.

Most likely a permission of the maildrop socket is wrong. I recommend that you update to ispconfig 3.0.4.4 and choose to reconfigure services so that the configuration of the mail system gets rewritten.


ok, now I understand.

I'll look how to do and plan to make this update.
thanks
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix doesn't have Nolan Installation/Configuration 5 13th April 2011 05:00
SugarCRM Install on ISPConfig3 w/ SuPHP clucena Installation/Configuration 1 9th February 2010 09:29
Forbidden 403; Samba access; config of maildeamon fawkes Installation/Configuration 4 14th January 2010 18:16
ISP Config hesitation when opening web pages frankb Installation/Configuration 7 15th December 2008 13:06
Questions in regards to ISP-Server Setup - Ubuntu 5.10 "Breezy Badger" rbrantley HOWTO-Related Questions 16 10th April 2006 18:26


All times are GMT +2. The time now is 13:58.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.