Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th April 2012, 23:30
AzaraT AzaraT is offline
Junior Member
 
Join Date: Dec 2008
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default ispconfig3+nginx+wordpress+perm urls

Hi,

I'm currently having a problem with Wordpress on a CentOS 5.8, ISPConfig3, Nginx with php-fpm setup and getting perm links to work (I've pretty much followed the guide to setting this up on CentOS that is here on the site).

What happends when I load the website is that I get "No input configured".

I've done the following steps to make it work:

1. create a vhost: /etc/nginx/sites-available/www.mysite.com.vhost
with the following:
Code:
server {
       listen 80;
       server_name www.mysite.com mysite.com;
       root /var/www/clients/client1/web1/web;

       if ($http_host != "www.mysite.com") {
                 rewrite ^ http://www.mysite.com$request_uri permanent;
       }

       index index.php index.html;

       location = /favicon.ico {
                log_not_found off;
                access_log off;
       }

       location = /robots.txt {
                allow all;
                log_not_found off;
                access_log off;
       }

       # Deny all attempts to access hidden files such as .htaccess, .htpasswd, .DS_Store (Mac).
       location ~ /\. {
                deny all;
                access_log off;
                log_not_found off;
       }

       location / {
                try_files $uri $uri/ /index.php?$args;
       }

       # Add trailing slash to */wp-admin requests.
       rewrite /wp-admin$ $scheme://$host$uri/ permanent;

       location ~*  \.(jpg|jpeg|png|gif|css|js|ico)$ {
                expires max;
                log_not_found off;
       }

       location ~ \.php$ {
                include /etc/nginx/fastcgi_params;
                fastcgi_pass 127.0.0.1:9000;
                fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
       }
}
2. Created a symlink:
Code:
cd /etc/nginx/sites-enabled/
ln -s /etc/nginx/sites-available/www.mysite.com.vhost www.mysite.com.vhost
And then reloading nginx (also tried rebooting the whole system).

When trying to access any site I just get:
No input configured

I appreciate any help, thanks!
Reply With Quote
Sponsored Links
  #2  
Old 12th April 2012, 08:37
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,778
Thanks: 821
Thanked 5,333 Times in 4,184 Posts
Default

Do not create any vhost files manually, instead create a new website in ispconfig. ispconfig takes care on creating all required config files for this site. If you craete a config file manually then this will conflict with the configuration of ispconfig and the site will not work.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 12th April 2012, 13:33
AzaraT AzaraT is offline
Junior Member
 
Join Date: Dec 2008
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks,

Should perm urls work out of the box then? Or would further configuration be required, if so, any guide to what?

Edit: After deleting the vhost and reloading nginx the site wont load at all, I just get "Welcome to Nginx" screen
edit2: I delete and re-added my website in ISPConfig 3 and the site now loads, however I still get 404s on any permalinks?

Edit 3: Finally got it working. After readding the website in ISPConfig I went to the vhost configured by ISPConfig 3 for the site and added the following:
Code:
       location / {
                try_files $uri $uri/ /index.php?$args;
       }
Which seems to be working

Last edited by AzaraT; 12th April 2012 at 15:57.
Reply With Quote
  #4  
Old 12th April 2012, 22:38
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

Just create a normal web site through ISPConfig and enable PHP. Then go to the options tab and add your additional directives in the nginx Directives field. For example, this is what I use:

Code:
location / {
                try_files $uri $uri/ /index.php?$args;
       }

       # Add trailing slash to */wp-admin requests.
       rewrite /wp-admin$ $scheme://$host$uri/ permanent;

       location ~*  \.(jpg|jpeg|png|gif|css|js|ico)$ {
                expires max;
                log_not_found off;
       }
Also check out this tutorial: http://www.howtoforge.com/running-wo...e-ubuntu-11.04
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem Updating and Uploading to Wordpress website on ISPConfig3 - Fedora 13 MrCompTech Tips/Tricks/Mods 8 25th August 2014 14:18
Wordpress Error 500 on ISPConfig3.0.4.3 NGINX tested0002 Installation/Configuration 15 9th November 2012 12:17
How setup nginx as frontend to apache with full support for nginx ISPConfig3? beliashou Installation/Configuration 8 30th November 2011 12:14
Problem with wordpress installatinon on new server with Debian Lenny ISPConfig3 Grollaz Installation/Configuration 7 17th June 2010 17:37
amavis rejects all inbound emails aclhkaclhk Installation/Configuration 5 28th February 2010 04:24


All times are GMT +2. The time now is 02:22.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.