#1  
Old 12th April 2012, 16:28
ilsymo ilsymo is offline
Junior Member
 
Join Date: Apr 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Apache issue?

Hello everyone! Following this tutorial The perfect server - CentOS 6.2 I have installed ISPConfig 3 and configured 3 websites, but after a few hours websites are no more visible. The only way to make them visible again is to restart httpd.

My vps is running with 1Gb ram. System is using almost all ram, swap is working correctly.

I'm a little bit frustrated about this situation. Hope anyone can help.

Thanks in advance.
Reply With Quote
Sponsored Links
  #2  
Old 12th April 2012, 16:53
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,990
Thanks: 825
Thanked 5,373 Times in 4,220 Posts
Default

Please check the apache error.log for errors, especially if there are any errors from vlogger.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 12th April 2012, 17:35
ilsymo ilsymo is offline
Junior Member
 
Join Date: Apr 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Many thanks for your reply, here is what I can see in the error log:
Code:
BEGIN failed--compilation aborted at /usr/local/ispconfig/server/scripts/vlogger line 148.
piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
Can't locate Date/Format.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5) at /usr/local/ispconfig/server/scripts/vlogger line 148.
BEGIN failed--compilation aborted at /usr/local/ispconfig/server/scripts/vlogger line 148.
piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
Can't locate Date/Format.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5) at /usr/local/ispconfig/server/scripts/vlogger line 148.
BEGIN failed--compilation aborted at /usr/local/ispconfig/server/scripts/vlogger line 148.
piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
Can't locate Date/Format.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5) at /usr/local/ispconfig/server/scripts/vlogger line 148.
BEGIN failed--compilation aborted at /usr/local/ispconfig/server/scripts/vlogger line 148.
I appreciate so much your help.

Last edited by ilsymo; 12th April 2012 at 17:38.
Reply With Quote
  #4  
Old 12th April 2012, 17:53
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,990
Thanks: 825
Thanked 5,373 Times in 4,220 Posts
Default

Please run this command:

Code:
yum install webalizer awstats perl-DateTime-Format-HTTP perl-DateTime-Format-Builder
and then restart apache.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 12th April 2012, 18:24
ilsymo ilsymo is offline
Junior Member
 
Join Date: Apr 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Packages already installed:

Code:
Setting up Install Process
Package webalizer-2.21_02-3.3.el6.x86_64 already installed and latest version
Package awstats-7.0-2.el6.noarch already installed and latest version
Package perl-DateTime-Format-HTTP-0.38-3.el6.noarch already installed and latest version
Package perl-DateTime-Format-Builder-0.8000-2.el6.noarch already installed and latest version
Nothing to do
Reply With Quote
  #6  
Old 13th April 2012, 10:01
ilsymo ilsymo is offline
Junior Member
 
Join Date: Apr 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I tried with
Code:
yum install perl-TimeDate.noarch
and a new empty Apache error_log file.

I'll keep you informed.

Thanks
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sessions not being saved gavimobile General 6 15th January 2012 15:05
trying to install roundcubemail ressel Installation/Configuration 13 24th December 2009 20:13
problems with suexec gobokster Installation/Configuration 7 7th May 2009 13:33
CENTOS 5 Ping Problem gAnDo Server Operation 11 28th March 2008 20:58
Problem with the installation of Dokeos (LMS) in ISPConfig jofranco General 4 28th April 2006 00:45


All times are GMT +2. The time now is 14:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.