Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 3rd April 2012, 05:01
Gaddam Gaddam is offline
Junior Member
 
Join Date: Apr 2012
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default Perfect Server Ubuntu 11.10 ISPConfig3 - FTP Issue

Greetings,

I just finished the entire setup followed in the tutorial.

The system services is showing FTP is offline, yet I'm able to connect to it using filezilla for my UNIX user/pass combo over SSH.

When I try to connect with the client ftp user I created I get an error:
Code:
Command:	Trust new Hostkey: Once
Command:	Pass: ***********
Error:	Authentication failed.
Error:	Critical error
Error:	Could not connect to server
I can't view the system log I get this error: Unable to read /var/log/messages

Thank You for the assistance.
Reply With Quote
Sponsored Links
  #2  
Old 3rd April 2012, 07:32
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,665
Thanks: 819
Thanked 5,316 Times in 4,169 Posts
Default

Please post the output of:

netstat -tap | grep ftp

Is this a vserver?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 3rd April 2012, 15:46
Gaddam Gaddam is offline
Junior Member
 
Join Date: Apr 2012
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

It is not a vserver, and I used netstat -tap | grep ftp and nothing appeared.

I restarted and verified I did everything in the tutorial The perfect server Ubuntu 11.10 and then followed the guide for using an ssl key.

Code:
/etc/init.d/pure-ftpd-mysql restart
Restarting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -A -D -O clf:/var/log/pure-ftpd/transfer.log -E -Y 1 -u 1000 -H -8 UTF-8 -b -B
I viewed the system log via ssh, I found that it was complaining about pure-ftpd.pem not bieng found. I had to edit the pem file, when it's created it just appends it but not on a new line so I had to break the portion that -----BEGINS...----- onto a new line. Now when I run the above command I get this output:

Code:
tcp        0      0 *:ftp                   *:*                     LISTEN      16391/pure-ftpd (SE
tcp6       0      0 [::]:ftp                [::]:*                  LISTEN      16391/pure-ftpd (SE

Last edited by Gaddam; 3rd April 2012 at 16:15.
Reply With Quote
  #4  
Old 3rd April 2012, 16:21
Gaddam Gaddam is offline
Junior Member
 
Join Date: Apr 2012
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ISPConfig3 reports that all services are running, but I still am unable to connect with a client that I created for my domain. I am able to connect using the linux/password for a system user.

So I still have to resolve why ISPConfig3 is unable to read the system log, and mail warn log. FTP connection from the client that should be able to connect over sftp using the ssl signed cert.

Thanks for your help and patience.

EDIT: syslog shows:

Apr 3 12:30:02 mail pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
Apr 3 12:30:02 mail pure-ftpd: (?@127.0.0.1) [INFO] Logout.

Last edited by Gaddam; 3rd April 2012 at 18:46.
Reply With Quote
  #5  
Old 4th April 2012, 00:47
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
 
Default

Quote:
Originally Posted by Gaddam View Post
but I still am unable to connect with a client that I created for my domain.
Clients cannot use FTP. You must create an FTP user in ISPConfig.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig3 mail doesn't work Marr General 6 1st September 2010 09:32
amavis rejects all inbound emails aclhkaclhk Installation/Configuration 5 28th February 2010 04:24
ISPConfig3 Mail Warn Errors reason8 General 3 25th November 2009 13:58
Question about Virtual Hosting With Proftpd And MySQL (Incl. Quota) On Debian Etch ikkem HOWTO-Related Questions 30 26th February 2008 19:38
Problem with keeping Apache alive bobeq Server Operation 3 29th November 2007 16:11


All times are GMT +2. The time now is 07:22.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.