#1  
Old 25th January 2014, 00:44
dontbanme dontbanme is offline
Junior Member
 
Join Date: Jan 2014
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Primary DNS server issues

I Have run single system ISPConfig3 server for about a year without issue. I have recently set up a 3 server system. Primary host (host.domain.tld), and Primary and Secondary DNS Servers (NS1, and NS2. domain.tld) The second of which is at a separate location on a separate subdomain.

The installations of all seemed to go fine. I followed these two guides respectively as a guideline since I haven't done the multiple servers before.

I used this guide for my basic package installations on centos
http://www.howtoforge.com/perfect-se...ot-ispconfig-3

And this guide I used for settings specific to multiple system setup.
http://www.howtoforge.com/installing...th-ispconfig-3

After the installations I connected to the primary ispconfig server via IP no problems. It listed all three servers and I was able to adjust what services each was running. Host responsible for all but DNS, then NS1 as DNS and NS2 as DNS with mirroring enabled.

However when I went to add DNS information I noticed the the massage at the top about changes taking up to a minute to propagate wasn't going away.

I checked the job queue and noticed everything for ns1 was still sitting in the job queue. I tried manually running server.sh and nothing changed. After this I also noticed that ns1 was not displaying all information that ns2 was displaying on the monitor section. I will be attaching images of these screens.

I also ran the common issues script on NS1 and here is that output
Code:
##### SERVER #####
IP-address (as per hostname): ***.***.***.***
IP-address(es) (as per ifconfig): ***.***.***.***
[WARN] ip addresses from hostname differ from ifconfig output. Please check your ip settings.
[INFO] ISPConfig is installed.

##### ISPCONFIG #####
ISPConfig version is 3.0.5.3


##### VERSION CHECK #####

[INFO] php (cli) version is 5.3.3

##### PORT CHECK #####

[WARN] Port 8080 (ISPConfig) seems NOT to be listening
[WARN] Port 8081 (ISPConfig Apps) seems NOT to be listening
[WARN] Port 80 (Webserver) seems NOT to be listening
[WARN] Port 443 (Webserver SSL) seems NOT to be listening
[WARN] Port 143 (IMAP server) seems NOT to be listening
[WARN] Port 993 (IMAP server SSL) seems NOT to be listening
[WARN] Port 110 (POP3 server) seems NOT to be listening
[WARN] Port 995 (POP3 server SSL) seems NOT to be listening
[WARN] Port 465 (SMTP server SSL) seems NOT to be listening
[WARN] Port 21 (FTP server) seems NOT to be listening

##### MAIL SERVER CHECK #####

[WARN] I found no "submission" entry in your postfix master.cf
[INFO] this is not critical, but if you want to offer port 587 for smtp connections you have to enable this.
[WARN] I found no "smtps" entry in your postfix master.cf
[INFO] this is not critical, but if you want to offer SSL for smtp (not TLS) connections you have to enable this.

##### RUNNING SERVER PROCESSES #####

[WARN] I could not determine which web server is running.
[INFO] I found the following mail server(s):
	Postfix (PID 8178)
[WARN] I could not determine which pop3 server is running.
[WARN] I could not determine which imap server is running.
[WARN] I could not determine which ftp server is running.

##### LISTENING PORTS #####
(only		()
Local		(Address)
[localhost]:3310		(7949/clamd)
[anywhere]:111		(1184/rpcbind)
***.***.***.***:53		(20295/named)
[localhost]:53		(20295/named)
[anywhere]:22		(7941/sshd)
[localhost]:631		(7810/cupsd)
[localhost]:953		(20295/named)
[localhost]:25		(8178/master)
[anywhere]:3306		(8086/mysqld)
[anywhere]:55210		(1202/rpc.statd)
[localhost]11		(1184/rpcbind)
*:*:*:*::*:53		(20295/named)
*:*:*:*::*:22		(7941/sshd)
*:*:*:*::*:631		(7810/cupsd)
*:*:*:*::*:953		(20295/named)
*:*:*:*::*:25		(8178/master)
*:*:*:*::*:54236		(1202/rpc.statd)




##### IPTABLES #####
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination
I also enabled debugging one the main server in server config and manually ran the server.sh. Results as follows:
Code:
[root@host ~]# /usr/local/ispconfig/server/server.sh
24.01.2014-15:59 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
24.01.2014-15:59 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
finished.
I can try enablying the setting for the ns1 server. I however assume those settings would not apply just as the firewall nor dns settings are propagating.

Attached are screen caps of Server status for each server and services status for each server.

And after all that noise the question. Did something get totally messed on my install on the ns1 server? Should I just reinstall completely or is there something that can be easily fixed. I feel like it is something as simple as a sql problem but I don't know what it could be. Not quite that good yet :-P

Any help would be appreciated.
Attached Images
     
Reply With Quote
Sponsored Links
  #2  
Old 25th January 2014, 00:45
dontbanme dontbanme is offline
Junior Member
 
Join Date: Jan 2014
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default ns2 services

Screen of ns2 services
Attached Images
 
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sending email issue lezelf Installation/Configuration 15 9th August 2011 12:20
Can't receive mails baicunko Server Operation 12 3rd August 2011 23:02
Google Apps dayjahone General 19 29th March 2008 18:25
Dns question Mahir Installation/Configuration 48 14th November 2006 11:19
Webmail Relay Error palkat General 17 23rd April 2006 19:12


All times are GMT +2. The time now is 14:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.