Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th March 2012, 11:50
chief chief is offline
Member
 
Join Date: Nov 2008
Location: Barry. UK
Posts: 58
Thanks: 3
Thanked 2 Times in 2 Posts
Default upgrade fedora - how bad could it get

Hi,

I have ispconfig 2 running on fedora 10 with 20 websites running and a mail server all working nicely

Is it possible to run a fedora upgrade from 10 through to fedora 16 without absolutely breaking everything everything....

I take daily backups of all mysql databases, i take ssh nightely snapshots of all contents in /var/www/*

I have downloaded backup of ispconfig

how wrong could it get, or is better to build a new server and move 1 site at a time to new server then do a rebuild of old server and move sites back?

cheers
dave
Reply With Quote
Sponsored Links
  #2  
Old 17th March 2012, 11:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

I think you must upgrade from 10 to 11, then from 11 to 12 and so on. But I'd take backups of all relevant data because I wouldn't rule out that you end with a messed up system...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
chief (20th March 2012)
  #3  
Old 20th March 2012, 13:39
chief chief is offline
Member
 
Join Date: Nov 2008
Location: Barry. UK
Posts: 58
Thanks: 3
Thanked 2 Times in 2 Posts
Default

I tried the upgrade process and it wouldnt work, kept pulling fedora 15 images. 11, 12 same. started to work on 13 so it says, but rpms came in as fc15.rpms.

Anway, scrapped that process. I am going for a complete rebuild on fedora 15 with ispconfig 3.
Incidently, i completed it yesturday. tried logging in https://ipaddress's:8080 and got to the login. used admin and password admin as the default ready to change and move sites there.
But it states admin user/password wrong. hmm

before i uninstall and change domain name any advice on what could be the matter


dave
Reply With Quote
  #4  
Old 20th March 2012, 14:31
chief chief is offline
Member
 
Join Date: Nov 2008
Location: Barry. UK
Posts: 58
Thanks: 3
Thanked 2 Times in 2 Posts
Default

falko,

the instructions on the how-to and the manual are wrong.
I found that if i followed it to the letter i couldnt log in

Quote:
cd /tmp
wget http://www.ispconfig.org/downloads/I...-stable.tar.gz
tar xfz ISPConfig-3-stable.tar.gz
cd ispconfig3_install/install/
This is the section, i couldnt login as admin..
so i uninstalled it
Quote:
php /tmp/ispconfig3_install/install/uninstall.php
downloaded from http://prdownloads.sourceforge.net/i...3.0.4.3.tar.gz
and re-ran the installer, this time i can login as admin and change the password
so far so good

cheers
dave
Reply With Quote
  #5  
Old 20th March 2012, 16:06
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

The file is the same on both URL's, so falko's instructions are fine and the different download url is not the reason that it worked the second time.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 20th March 2012, 16:44
chief chief is offline
Member
 
Join Date: Nov 2008
Location: Barry. UK
Posts: 58
Thanks: 3
Thanked 2 Times in 2 Posts
 
Default

Thanks till for reply,

I dont understand why admin wouldnt login first time, i then downloaded from download section again and it worked second time..

thanks anyway

dave
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't receive mails baicunko Server Operation 12 3rd August 2011 22:02
Intel 82815 Video Card & Ubuntu 8.10 harvey527 Kernel Questions 8 5th November 2010 14:51
Squirrelmail login failure Cracklefish Installation/Configuration 9 30th June 2010 20:38
Upgrade from Fedora 4 to Fedora 5 adamluz Installation/Configuration 4 16th June 2006 03:00
Mail Sent and Received but failure notice delivered badbandit83 General 7 2nd February 2006 21:50


All times are GMT +2. The time now is 08:47.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.