Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th March 2012, 11:20
mickburkejnr mickburkejnr is offline
Junior Member
 
Join Date: Mar 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Unable to send or receive emails

Hi everyone,

I've installed ISPConfig 3 on my VPS using the brilliant tutorial here: http://www.howtoforge.com/forums/showthread.php?t=56541

However, if I go to send an email to an account I've set up on the server I get the following error:

Quote:
Delivery to the following recipient failed permanently:
michael@gravex.co.uk

Technical details of permanent failure:
DNS Error: DNS server returned answer with no data
I've checked my DNS records for that domain, and they are as follows:
HTML Code:
setanta	A		80.xx.xx.xx	
mail.gravex.co.uk	MX	10	80.xx.xx.xx
NS		ns1.6sync.net.	
NS		ns2.6sync.net.	
NS		ns3.6sync.net.	
ftp	A		80.xx.xx.xx
mail	A		80.xx.xx.xx
dail	A		80.xx.xx.xx
www	A		80.xx.xx.xx
.	A		80.xx.xx.xx
I've also tried to send an email from squirrelmail. I've had no errors come back but I've not had the e-mail come through either.

I'm not sure what's going on, as I thought adding mail.gravex.co.uk as an MX record would work, but I don't think it has. What do I need to do to make it work?

Cheers!
Reply With Quote
Sponsored Links
  #2  
Old 16th March 2012, 13:17
mickburkejnr mickburkejnr is offline
Junior Member
 
Join Date: Mar 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I deleted all the DNS records held by ISPConfig 3 and transferred them to the VPS providers nameservers. Now when I send email I don't get the DNS error.

However, I don't get any bounce bank emails and I still can't send emails. I have checked the long and I get the following error:

Code:
Mar 16 07:55:23 setanta postfix/smtp[17339]: 64F235F83: to=<myemailaddress@gmail.com>, relay=none, delay=0.07, delays=0.07/0.01/0/0, dsn=4.4.1, status=deferred (connect to
127.0.0.1[127.0.0.1]:10024: Connection refused)
I have changed the following in the Postfix config file:

Code:
inet_interfaces = all
inet_interfaces = $myhostname
inet_interfaces = $myhostname, localhost
inet_interfaces = all
So that only one of the lines is used at any one time. However, no matter what I use and no matter how many times I restart Postfix I still get that error!

Any ideas?
Reply With Quote
  #3  
Old 16th March 2012, 15:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

Quote:
mail.gravex.co.uk MX 10 80.xx.xx.xx
Your MX record was totally wrong. First, it must point to an A record, not an IP, and second, it should have read
gravex.co.uk. (with a dot at the end), so the full MX record should have been something like:

Code:
gravex.co.uk.	MX	10	mail
Quote:
Mar 16 07:55:23 setanta postfix/smtp[17339]: 64F235F83: to=<myemailaddress@gmail.com>, relay=none, delay=0.07, delays=0.07/0.01/0/0, dsn=4.4.1, status=deferred (connect to
127.0.0.1[127.0.0.1]:10024: Connection refused)
Please restart amavisd and check that is running afterwards in the output of
Code:
netstat -tap
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Tags
dns, email

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ubuntu and nginx delgado2061 Installation/Configuration 0 27th November 2011 23:36
Forbidden 403; Samba access; config of maildeamon fawkes Installation/Configuration 4 14th January 2010 18:16
Unable send receive emails vassilis3 Installation/Configuration 15 19th May 2007 14:34
HotSaNIC domino Tips/Tricks/Mods 23 6th November 2006 05:19
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29


All times are GMT +2. The time now is 21:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.