Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th March 2012, 00:50
n0fx n0fx is offline
Member
 
Join Date: Apr 2006
Posts: 36
Thanks: 3
Thanked 0 Times in 0 Posts
Default Auto forward https:// requests to http:// site (SSL to non SSL)

I have ISPconfig 2 setup but no SSL on my site and no certificate installed on my server. There is only one site on the server but I need to forward all HTTPS requests to the HTTP site.

I read another thread on using mod_rewrite to do it but I was wondering how to do I use mod_rewrite to do it? Do I need to modify the .htaccess file in the root to do this?

Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 13th March 2012, 10:14
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,814
Thanks: 821
Thanked 5,340 Times in 4,189 Posts
Default

Please see ISPConfig FAQ:

http://www.faqforge.com/linux/contro...che-webserver/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 13th March 2012, 18:02
n0fx n0fx is offline
Member
 
Join Date: Apr 2006
Posts: 36
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
That's for http -> https. I'm trying to do https -> http. For the webserver that I setup, the users want the site forwarded from https requests to the regular http site. SSL hasn't been setup on the server for the default site. There is only one site on the ISPconfig server right now.
Reply With Quote
  #4  
Old 14th March 2012, 19:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Try
Code:
RewriteEngine On
RewriteCond %{HTTPS} on
RewriteRule (.*) http://%{HTTP_HOST}%{REQUEST_URI}
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 14th March 2012, 23:12
n0fx n0fx is offline
Member
 
Join Date: Apr 2006
Posts: 36
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
Try
Code:
RewriteEngine On
RewriteCond %{HTTPS} on
RewriteRule (.*) http://%{HTTP_HOST}%{REQUEST_URI}
Thanks, do I need to enable SSL and get a certificate before I can do the mod_rewrite? I tried the other code I posted before but it doesn't work, so I had a feeling I needed to enable SSL and get a certificate before I can forward requests to the http:// part of the site?
Reply With Quote
  #6  
Old 15th March 2012, 18:50
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Apache cannot handle SSL requests if you don't enable SSL, so yes, you must enable it.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 15th March 2012, 18:51
n0fx n0fx is offline
Member
 
Join Date: Apr 2006
Posts: 36
Thanks: 3
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by falko View Post
Apache cannot handle SSL requests if you don't enable SSL, so yes, you must enable it.
That's what I thought but had to double check, thanks
Reply With Quote
Reply

Bookmarks

Tags
ssl http https redirect

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SSL for virtual hosts on one certificate rbartz Tips/Tricks/Mods 8 20th November 2007 17:59
SSL Issue - Unable to connect to any site Menzor Installation/Configuration 4 27th May 2007 04:03
SSL not working for individual site. FeraTechInc General 4 1st March 2007 20:26
SSL Only site (disable HTTP access) letic General 3 20th July 2006 12:17
Installing ISPConfig ssl installation certificate to a site? lyndros Installation/Configuration 6 20th March 2006 03:54


All times are GMT +2. The time now is 23:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.