Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th February 2012, 02:43
mtutaj mtutaj is offline
Junior Member
 
Join Date: Sep 2009
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default wierd email issue

ok, I have ispconfig 3 installed. Had initial domain setup (domain 1) can receive email for that domain no problem. Have 3 users set up. Recently set up another domain (domain 2), set up email for 3 users, and they cannot send or receive email from the outside world. Domain 1 can send mail to domain 2 and vise versus. Been searching the forums for a few days, and have checked quite a few things, but no answer.

The dig mx domain_name.com shows all the right info

did a dig mx mail.domain_name.com. that is correct.

attached is the netstat -tap


root@server1:~# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 localhost:10024 *:* LISTEN 1415/amavisd (maste
tcp 0 0 localhost:10025 *:* LISTEN 21873/master
tcp 0 0 *:mysql *:* LISTEN 1735/mysqld
tcp 0 0 *op3 *:* LISTEN 2269/dovecot
tcp 0 0 *:58126 *:* LISTEN 920/rpc.statd
tcp 0 0 *:imap2 *:* LISTEN 2269/dovecot
tcp 0 0 *:sunrpc *:* LISTEN 908/portmap
tcp 0 0 *:ftp *:* LISTEN 1948/pure-ftpd (SER
tcp 0 0 server1.monkybro:domain *:* LISTEN 1324/named
tcp 0 0 localhost:domain *:* LISTEN 1324/named
tcp 0 0 *:ssh *:* LISTEN 1826/sshd
tcp 0 0 *:smtp *:* LISTEN 21873/master
tcp 0 0 localhost:953 *:* LISTEN 1324/named
tcp 0 0 *:imaps *:* LISTEN 2269/dovecot
tcp 0 0 *op3s *:* LISTEN 2269/dovecot
tcp 0 1 server1.monkybros:40543 vx-in-f27.1e100.ne:smtp SYN_SENT 21880/smtp
tcp 0 0 localhost:43524 localhost:mysql ESTABLISHED 29424/amavisd (ch7-
tcp 0 0 localhost:mysql localhost:44348 ESTABLISHED 1735/mysqld
tcp 0 0 localhost:44350 localhost:mysql ESTABLISHED 21876/trivial-rewri
tcp 0 0 localhost:43471 localhost:mysql ESTABLISHED 29075/amavisd (ch8-
tcp 0 0 localhost:imap2 localhost:44418 TIME_WAIT -
tcp 0 0 localhost:imap2 localhost:44423 TIME_WAIT -
tcp 0 0 localhost:imap2 localhost:44419 TIME_WAIT -
tcp 0 0 localhost:mysql localhost:44350 ESTABLISHED 1735/mysqld
tcp 0 0 localhost:44349 localhost:mysql ESTABLISHED 21877/proxymap
tcp 0 1 server1.monkybros:53678 vx-in-f26.1e100.ne:smtp SYN_SENT 21879/smtp
tcp 0 0 localhost:mysql localhost:43471 ESTABLISHED 1735/mysqld
tcp 0 0 localhost:44347 localhost:mysql TIME_WAIT -
tcp 0 0 localhost:44345 localhost:mysql TIME_WAIT -
tcp 0 0 localhost:mysql localhost:43524 ESTABLISHED 1735/mysqld
tcp 0 0 server1.monkybros.c:ssh 192.168.254.112:55981 ESTABLISHED 21009/1
tcp 0 1 server1.monkybros:53679 vx-in-f26.1e100.ne:smtp SYN_SENT 21882/smtp
tcp 0 0 localhost:44348 localhost:mysql ESTABLISHED 21877/proxymap
tcp 0 1 server1.monkybros:53677 vx-in-f26.1e100.ne:smtp SYN_SENT 21878/smtp
tcp 0 0 localhost:imap2 localhost:44420 TIME_WAIT -
tcp 0 1 server1.monkybros:40544 vx-in-f27.1e100.ne:smtp SYN_SENT 21881/smtp
tcp 0 0 localhost:imap2 localhost:44421 TIME_WAIT -
tcp 0 0 server1.monkybros.c:ssh 192.168.254.112:54507 ESTABLISHED 16077/0
tcp 0 0 localhost:imap2 localhost:44422 TIME_WAIT -
tcp 0 0 localhost:44346 localhost:mysql TIME_WAIT -
tcp 0 0 localhost:mysql localhost:44349 ESTABLISHED 1735/mysqld
tcp 0 0 localhost:imap2 localhost:44414 TIME_WAIT -
tcp6 0 0 [::]:http-alt [::]:* LISTEN 2431/apache2
tcp6 0 0 [::]:www [::]:* LISTEN 2431/apache2
tcp6 0 0 [::]:tproxy [::]:* LISTEN 2431/apache2
tcp6 0 0 [::]:ftp [::]:* LISTEN 1948/pure-ftpd (SER
tcp6 0 0 [::]:domain [::]:* LISTEN 1324/named
tcp6 0 0 [::]:ssh [::]:* LISTEN 1826/sshd
tcp6 0 0 ip6-localhost:953 [::]:* LISTEN 1324/named
tcp6 0 0 [::]:https [::]:* LISTEN 2431/apache2
tcp6 0 0 server1.monkybros.c:www 99-39-165-154.lig:56535 TIME_WAIT -

thanks,

Mike
Reply With Quote
Sponsored Links
  #2  
Old 26th February 2012, 05:40
mtutaj mtutaj is offline
Junior Member
 
Join Date: Sep 2009
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok, not sure what really changed, but I now have incoming email working with interally and externally sent emails. Now I just need to figure out why I cant get outgoing externally email working. I don't have any ports blacklisted or blocked.. What else do I need to check?

Thanks,

Mike
Reply With Quote
  #3  
Old 26th February 2012, 20:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Are there any errors in your mail log (in the /var/log/ directory)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 1st March 2012, 03:41
mtutaj mtutaj is offline
Junior Member
 
Join Date: Sep 2009
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

on my emails to gmail, i get a connection timed out error.
Reply With Quote
  #5  
Old 1st March 2012, 20:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

What's in your mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 1st March 2012, 21:49
mtutaj mtutaj is offline
Junior Member
 
Join Date: Sep 2009
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Mar 1 14:40:18 server1 dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
Mar 1 14:40:18 server1 dovecot: IMAP(beardie@domain.com): Disconnected: Logged out bytes=399/1757
Mar 1 14:40:18 server1 dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
Mar 1 14:40:18 server1 dovecot: IMAP(beardie@domain.com): Disconnected: Logged out bytes=299/6664
Mar 1 14:40:48 server1 postfix/smtpd[2772]: connect from localhost[127.0.0.1]
Mar 1 14:40:48 server1 postfix/smtpd[2772]: DC14C1616395: client=localhost[127.0.0.1]
Mar 1 14:40:48 server1 postfix/cleanup[2858]: DC14C1616395: message-id=<44c863ea272a6b50a9e7b6b00f67977d.squirrel@www. domain.com>
Mar 1 14:40:48 server1 postfix/qmgr[30589]: DC14C1616395: from=, size=771, nrcpt=1 (queue active)
Mar 1 14:40:48 server1 postfix/smtpd[2772]: disconnect from localhost[127.0.0.1]
Mar 1 14:40:48 server1 dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
Mar 1 14:40:49 server1 dovecot: IMAP(beardie@domain.com): Disconnected: Logged out bytes=636/460
Mar 1 14:40:49 server1 dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
Mar 1 14:40:49 server1 dovecot: IMAP(beardie@domain.com): Disconnected: Logged out bytes=299/6664
Mar 1 14:40:59 server1 postfix/smtpd[2866]: connect from localhost[127.0.0.1]
Mar 1 14:40:59 server1 postfix/smtpd[2866]: 54ECD16163A3: client=localhost[127.0.0.1]
Mar 1 14:40:59 server1 postfix/cleanup[2858]: 54ECD16163A3: message-id=<44c863ea272a6b50a9e7b6b00f67977d.squirrel@www. domain.com>
Mar 1 14:40:59 server1 postfix/qmgr[30589]: 54ECD16163A3: from=, size=1263, nrcpt=1 (queue active)
Mar 1 14:40:59 server1 postfix/smtpd[2866]: disconnect from localhost[127.0.0.1]
Mar 1 14:40:59 server1 amavis[1286]: (01286-08) Passed CLEAN, LOCAL [127.0.0.1] [75.57.156.108] -> , Message-ID: <44c863ea272a6b50a9e7b6b00f67977d.squirrel@www.dom ain.com>, mail_id: 39VOuMu7Rr5m, Hits: -1, size: 771, queued_as: 54ECD16163A3, 10398 ms
Mar 1 14:40:59 server1 postfix/smtp[2859]: DC14C1616395: to=, relay=127.0.0.1[127.0.0.1]:10024, delay=10, delays=0.07/0.02/0/10, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=01286-08, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 54ECD16163A3)
Mar 1 14:40:59 server1 postfix/qmgr[30589]: DC14C1616395: removed
Mar 1 14:41:20 server1 postfix/smtp[2867]: connect to gmail-smtp-in.l.google.com[209.85.225.27]:25: Connection timed out
Mar 1 14:41:41 server1 postfix/smtp[2867]: connect to alt1.gmail-smtp-in.l.google.com[74.125.113.26]:25: Connection timed out
Mar 1 14:42:02 server1 postfix/smtp[2867]: connect to alt2.gmail-smtp-in.l.google.com[173.194.67.27]:25: Connection timed out
Mar 1 14:42:23 server1 postfix/smtp[2867]: connect to alt3.gmail-smtp-in.l.google.com[74.125.79.26]:25: Connection timed out
Mar 1 14:42:44 server1 postfix/smtp[2867]: connect to alt4.gmail-smtp-in.l.google.com[209.85.173.27]:25: Connection timed out
Mar 1 14:42:44 server1 postfix/smtp[2867]: 54ECD16163A3: to=, relay=none, delay=105, delays=0.01/0.03/105/0, dsn=4.4.1, status=deferred (connect to alt4.gmail-smtp-in.l.google.com[209.85.173.27]:25: Connection timed out)
Mar 1 14:45:01 server1 dovecot: pop3-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
Mar 1 14:45:01 server1 dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured

Last edited by mtutaj; 2nd March 2012 at 03:13.
Reply With Quote
  #7  
Old 3rd March 2012, 00:15
mtutaj mtutaj is offline
Junior Member
 
Join Date: Sep 2009
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

any ideas?

Thanks,

Mike
Reply With Quote
  #8  
Old 3rd March 2012, 04:25
mtutaj mtutaj is offline
Junior Member
 
Join Date: Sep 2009
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I dont either, but I know I have a dynamic ip address, even though it hasnt changed in over a year. I tried the relay tutorial using my providers email address and info. and still no dice. thinking I might have to use a relay provider.

Any other ideas? I really need to get this up and running this weekend.

Thanks for your help.

Mike
Reply With Quote
  #9  
Old 3rd March 2012, 05:53
mtutaj mtutaj is offline
Junior Member
 
Join Date: Sep 2009
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

after i set up the relay using my isp email account. I get this now..

Mar 2 22:47:32 server1 postfix/error[26364]: A89121616397: to=, relay=none, delay=131952, delays=131951/0.03/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to outbound.att.net[68.142.198.51]:25: Connection timed out)
Reply With Quote
  #10  
Old 3rd March 2012, 10:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Please check if your server is blacklisted: http://mxtoolbox.com/blacklists.aspx

Did you set up relaying using this guide? http://www.howtoforge.com/postfix_re...her_mailserver
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix Cannot Receive Email - Smtp Timed Out newbielinx Installation/Configuration 4 26th September 2011 17:14
Sending email issue lezelf Installation/Configuration 15 9th August 2011 11:20
cant receive email, issue with user@www.domain.com Julian_Lopez Installation/Configuration 1 13th February 2009 12:15
Email Forwarding Issue crayz1 Server Operation 4 15th January 2009 13:49
Minor issue with email rabrol Installation/Configuration 3 16th November 2007 09:47


All times are GMT +2. The time now is 20:50.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.