Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th March 2012, 08:57
immortalbikram immortalbikram is offline
Junior Member
 
Join Date: Dec 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default postfix/trivial-rewrite[30414]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains

I am facing strange problem in my ispconfig from last two days. The error log is as
Mar 27 11:17:27 ns1 postfix/smtpd[28072]: warning: problem talking to service rewrite: Connection reset by peer
Mar 27 11:17:27 ns1 postfix/smtpd[26710]: warning: problem talking to service rewrite: Success
Mar 27 11:17:27 ns1 postfix/master[5274]: warning: process /usr/lib/postfix/trivial-rewrite pid 30316 exit status 1
Mar 27 11:17:27 ns1 postfix/smtpd[29239]: warning: problem talking to service rewrite: Success
Mar 27 11:17:27 ns1 postfix/smtpd[29120]: warning: problem talking to service rewrite: Connection reset by peer
Mar 27 11:17:27 ns1 postfix/master[5274]: warning: process /usr/lib/postfix/trivial-rewrite pid 30317 exit status 1
Mar 27 11:17:29 ns1 postfix/smtpd[10634]: fatal: watchdog timeout
Mar 27 11:17:30 ns1 postfix/master[5274]: warning: process /usr/lib/postfix/smtpd pid 10634 exit status 1
Mar 27 11:17:30 ns1 postfix/master[5274]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Mar 27 11:18:27 ns1 postfix/proxymap[26694]: warning: connect to mysql server 127.0.0.1: Lost connection to MySQL server at 'reading initial communication packet', system error: 0
Mar 27 11:18:27 ns1 postfix/proxymap[26694]: warning: connect to mysql server 127.0.0.1: Lost connection to MySQL server at 'reading initial communication packet', system error: 0
Mar 27 11:18:27 ns1 postfix/trivial-rewrite[30414]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
Mar 27 11:18:27 ns1 postfix/trivial-rewrite[30415]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
Mar 27 11:18:27 ns1 postfix/trivial-rewrite[30416]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
Mar 27 11:18:27 ns1 postfix/trivial-rewrite[30417]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
Mar 27 11:18:27 ns1 postfix/trivial-rewrite[30418]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
Mar 27 11:18:27 ns1 postfix/trivial-rewrite[30419]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
Mar 27 11:18:27 ns1 postfix/trivial-rewrite[30420]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
Mar 27 11:18:27 ns1 postfix/trivial-rewrite[30421]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
Mar 27 11:18:27 ns1 postfix/trivial-rewrite[30422]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
Mar 27 11:18:27 ns1 postfix/trivial-rewrite[30423]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem

http://pastebin.com/crUuv8kr

Dear Falko Please help me. I am not able to send mail from my server.
Reply With Quote
Sponsored Links
  #2  
Old 27th March 2012, 09:01
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Which tutorial did you use to setup the server?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 27th March 2012, 09:05
immortalbikram immortalbikram is offline
Junior Member
 
Join Date: Dec 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

the server is around one year old. I have used how to forge tutorial. My machine is Ubuntu 10.04. I have forgotten the link actually what i followed.
Reply With Quote
  #4  
Old 27th March 2012, 09:29
immortalbikram immortalbikram is offline
Junior Member
 
Join Date: Dec 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here is the log of mail.log
http://pastebin.com/NQgQtrbX
Reply With Quote
  #5  
Old 27th March 2012, 09:36
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Please restart mysql and amavis on your server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 27th March 2012, 10:01
immortalbikram immortalbikram is offline
Junior Member
 
Join Date: Dec 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have restarted both services and tried rebooting the machine but not working. I am searching over the net and not able to get solution. please help me . Do you require any other log for this ?? please tell me.
When I pgrep postfix
I don't see any process of postfix.
But i can see mysql

Last edited by immortalbikram; 27th March 2012 at 10:07.
Reply With Quote
  #7  
Old 27th March 2012, 22:16
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
 
Default

please post the output of:

netstat -tap
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't receive mails baicunko Server Operation 12 3rd August 2011 23:02
mail.err warnings and some mail unable to receive HellMind General 4 8th October 2010 20:57
Squirrelmail login failure Cracklefish Installation/Configuration 9 30th June 2010 21:38
Sending mail ISPConfig 3 but not receivind catza Installation/Configuration 20 19th May 2010 13:47
mail stop on one account provell General 10 26th November 2009 22:29


All times are GMT +2. The time now is 01:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.