Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 19th July 2006, 15:34
TheJackal TheJackal is offline
Junior Member
 
Join Date: Jul 2006
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default PHP page not displaying properly

I have a client web site /home/www/web19/web which has php which calls htm pages. This worked properly before being moved to this installation.

ls -l
-rw-r--r-- 1 root root 53 Jul 18 15:37 .htaccess
-rw-r--r-- 1 root root 12288 Jul 18 15:38 .htaccess.swp
-rw-r--r-- 1 root web19 1195 Jul 12 19:50 about-us.htm
-rw-r--r-- 1 root web19 1222 Jul 12 19:52 downloads.php
drwxrwxr-x 2 root web19 576 Jul 16 18:21 error
-rw-r--r-- 1 root web19 1150 Jul 3 23:19 favicon.ico
-rw-r--r-- 1 root web19 1215 Jul 12 16:08 forum.php
drwxrwxrwx 2 root web19 3248 Jul 18 13:23 images
-rw-rw-r-- 1 root web19 1213 Jul 16 18:21 index.html.orig
-rw-r--r-- 1 root web19 1419 Jul 12 19:51 index.php
-rw-r--r-- 1 root web19 1212 Jul 12 16:08 join.php
-rw-r--r-- 1 root web19 1980 Jul 12 19:51 leftset.htm
-rw-r--r-- 1 root web19 1214 Jul 12 16:08 links.php
-rw-r--r-- 1 root web19 2863 Jul 12 19:52 mainset.htm
-rw-r--r-- 1 root web19 756 Jul 12 19:53 mainsetdownloads.htm
-rw-r--r-- 1 root web19 757 Jul 12 19:54 mainsetforum.htm
-rw-r--r-- 1 root web19 1569 Jul 12 19:53 mainsetjoin.htm
-rw-r--r-- 1 root web19 166 Jul 12 16:08 mainsetlinks.htm
-rw-r--r-- 1 root web19 871 Jul 12 19:53 mainsetmembers.htm
-rw-r--r-- 1 root web19 1202 Jul 12 19:54 mainsetscreenshots.htm
-rw-r--r-- 1 root web19 1218 Jul 12 16:08 members.php
-rw-r--r-- 1 root web19 2968 Jul 12 19:54 rightset.htm
-rw-r--r-- 1 root web19 1643 Jul 12 19:54 rightset2.htm
-rw-r--r-- 1 root web19 1525 Jul 12 16:08 seabreeze1.css
-rw-r--r-- 1 root web19 5394 Jul 12 19:55 topset.htm
-rw-r--r-- 1 root web19 925 Jul 12 16:08 w00tsit.htm

The problem is that the images will not show up properly.

Attached is a screen capture.

ISP site has php enabled

PHP 5.1.4
Suse 10.1
Apache version 2.2.0
Attached Images
 
Reply With Quote
Sponsored Links
  #2  
Old 19th July 2006, 17:24
Ben Ben is offline
Moderator
 
Join Date: Jul 2006
Posts: 1,029
Thanks: 7
Thanked 62 Times in 56 Posts
Default

AS far as php is only processing html code everything works from the side of php. Because if you are only including htm files php only merges their content, nothing else... (if php -l tells no syntax error on that script everything is fine from here)

For more you should look at the page source.

The images look like not beeing found or sth. like that, so you should look at the access / error log of your webserver, maybe only pathes are wrong...
Reply With Quote
  #3  
Old 20th July 2006, 01:00
TheJackal TheJackal is offline
Junior Member
 
Join Date: Jul 2006
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default

nope do not see any errors on path.

Question, deos the files need to be owned bye the account owner?

example:
web8_admin web8 index.html

or shoule they be owne by root:
root web8 index.html
Reply With Quote
  #4  
Old 20th July 2006, 02:33
TheJackal TheJackal is offline
Junior Member
 
Join Date: Jul 2006
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Thanks for the tip, it solved my problem. I was lookin at the wrong log file.

Again thanks for all of the help.

Bob
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! qvindesland Installation/Configuration 22 21st May 2007 16:05
2 domains, 1 site wadims Installation/Configuration 13 31st May 2006 00:21
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! xinefnarg Installation/Configuration 2 28th March 2006 16:45
Downgrade php5 to php4.4.2 llizards Installation/Configuration 4 13th March 2006 23:58
all my site go to /var/www/ Absolusteph Installation/Configuration 14 11th March 2006 21:27


All times are GMT +2. The time now is 18:31.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.