Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 14th March 2006, 15:31
nenad nenad is offline
Senior Member
 
Join Date: Nov 2005
Location: Novi Sad, Serbia
Posts: 415
Thanks: 13
Thanked 5 Times in 5 Posts
Default

I use the first and only username (for first website) that I created since installing ISPConfig.
I can login into webmail using that username/pass and I can FTP also
Reply With Quote
Sponsored Links
  #22  
Old 14th March 2006, 17:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

The username must be of the form web1_user.

Do you have an .htaccess file in the stats folder? What's in it?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #23  
Old 14th March 2006, 18:41
nenad nenad is offline
Senior Member
 
Join Date: Nov 2005
Location: Novi Sad, Serbia
Posts: 415
Thanks: 13
Thanked 5 Times in 5 Posts
Default

yes, username is in form web1_ xxxx

there is .htacess file in dir:

AuthType Basic
AuthName "Members Only"
AuthUserFile /var/www/web1/.htpasswd
<limit GET PUT POST>
require valid-user
</limit>


I noticed that in
/var/www/web1/.htpasswd

web1_xxxxx: ghhgihggGUGUGuhh --- this string does not match my password ? (probably it is encrypted?)

After I input username/password it looks like user is logged in, but then error
"403 Error- Forbidden!" occurs.

Last edited by nenad; 14th March 2006 at 19:02.
Reply With Quote
  #24  
Old 15th March 2006, 00:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

Quote:
Originally Posted by nenad
I noticed that in
/var/www/web1/.htpasswd

web1_xxxxx: ghhgihggGUGUGuhh --- this string does not match my password ? (probably it is encrypted?)
Yes, the password is encrypted.

Quote:
Originally Posted by nenad
After I input username/password it looks like user is logged in, but then error
"403 Error- Forbidden!" occurs.
Normally this means there's no index page in the directory.
Please post the output of
Code:
ls -la /var/www/web1/web/stats
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #25  
Old 15th March 2006, 07:33
nenad nenad is offline
Senior Member
 
Join Date: Nov 2005
Location: Novi Sad, Serbia
Posts: 415
Thanks: 13
Thanked 5 Times in 5 Posts
Default

[root@noc ~]# ls -la /var/www/web1/web/stats
total 284
drwxr-xr-x 2 web1_nenad web1 4096 Mar 5 13:16 .
drwxrwxr-x 19 web1_nenad web1 4096 Mar 13 03:16 ..
-rwxr-xr-x 1 web1_nenad web1 3183 Mar 15 04:00 ctry_usage_200603.png
-rwxr-xr-x 1 web1_nenad web1 3009 Mar 15 04:00 daily_usage_200603.png
-rwxr-xr-x 1 web1_nenad web1 12288 Mar 14 04:00 dns_cache.db
-rwxr-xr-x 1 web1_nenad web1 2111 Mar 15 04:00 hourly_usage_200603.png
-rw-rw-r-- 1 web1_nenad web1 124 Mar 15 04:00 .htaccess
-rwxr-xr-x 1 web1_nenad web1 3779 Mar 15 04:00 index.html
-rwxr-xr-x 1 web1_nenad web1 91765 Mar 15 04:00 usage_200603.html
-rwxr-xr-x 1 web1_nenad web1 2363 Mar 15 04:00 usage.png
-rwxr-xr-x 1 web1_nenad web1 89110 Mar 15 04:00 webalizer.current
-rwxr-xr-x 1 web1_nenad web1 41 Mar 15 04:00 webalizer.hist
Reply With Quote
  #26  
Old 15th March 2006, 12:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

That's ok.
And you can't login with all users from the "User & Email" tab, or is it only one that makes problems?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #27  
Old 15th March 2006, 18:09
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,257
Thanks: 75
Thanked 22 Times in 18 Posts
Default

hi, I have already told you somewhere in the middle of this psot, that I had exactly the same issue, now after Till advised me to create another test user - after waiting for more than 24hours, this user does work, I can access the stats. BUT none of the older users does work... even if I change their password and some of their settings, clicking on save afterwards these accounts do not work... I guess I have to recreate them, will that work if I delete them, empty the recycle bin and recreate them? what do you think?
Reply With Quote
  #28  
Old 15th March 2006, 19:11
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,216 Times in 4,089 Posts
Default

Quote:
Originally Posted by Tenaka
hi, I have already told you somewhere in the middle of this psot, that I had exactly the same issue, now after Till advised me to create another test user - after waiting for more than 24hours, this user does work, I can access the stats.
Ok, thats the first step.

Quote:
BUT none of the older users does work... even if I change their password and some of their settings, clicking on save afterwards these accounts do not work...
Have you waited 24 ours after you changed the passwords? ISPConfig is creating the .htaccess files once each night, when the stats where generated.

Quote:
I guess I have to recreate them, will that work if I delete them, empty the recycle bin and recreate them? what do you think?
I dont think that this is nescessary. Are the old users in this file too?

/var/www/web1/.htpasswd
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #29  
Old 15th March 2006, 19:40
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,257
Thanks: 75
Thanked 22 Times in 18 Posts
Default

yes the old users are in /var/www/web1/.htpasswd too and yes I have waited about 24 hours...

could I try again and change their passwords to the same value they had before? will that work? or does ispcfg recognize the password is the same and not write the changes?
Reply With Quote
  #30  
Old 15th March 2006, 19:52
nenad nenad is offline
Senior Member
 
Join Date: Nov 2005
Location: Novi Sad, Serbia
Posts: 415
Thanks: 13
Thanked 5 Times in 5 Posts
 
Default

1. is it possible to reassign existing sites to new users ? How?

2. is it possible to force ISPConfig to re-create .htacess in shorter period than 24hrs ?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Webalizer - Usage by Country statistics leno Installation/Configuration 3 28th April 2005 18:12


All times are GMT +2. The time now is 04:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.