Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st February 2012, 14:23
satimis satimis is offline
Senior Member
 
Join Date: Oct 2006
Posts: 533
Thanks: 4
Thanked 2 Times in 2 Posts
Default Problem on configuring postfix

Hi all,

VM - ubuntu1010 server 64bit
host - ubuntu1104 desktop 64bit
Orcle VirtualBox

On router
Port 25 pointing VM Ip(local)
(ISP won't block port 25. I'm subscribing fixed IP)

I was following;

The Perfect Server - Ubuntu 10.10 [ISPConfig 3]
http://www.howtoforge.com/perfect-se...ispconfig-3-p4

to build this server running on a VM of Oracle VirtualBox. Then I followed;
Postfix Complete VirtualMail System Howto
https://help.ubuntu.com/community/Po...ailSystemHowto

further configuring postfix.

After encountering problem I followed the advice on #2
Setup mailaccount
http://www.howtoforge.com/forums/showthread.php?t=2

trying to solve it without result.

$ telnet localhost smtp
Trying ::1...
Connected to localhost.
Escape character is '^]'.
220 mail.server1.domain.com ESMTP Postfix (Ubuntu)

ehlo server1.domain.com
250-mail.server1.domain.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN

mail from:<user@server1.domain.com>
250 2.1.0 Ok

rcpt to:<somebody@yahoo.com>
554 5.7.1 <somebody@yahoo.com>: Relay access denied

rcpt to:<stephen@server1.domain.com>
250 2.1.5 Ok

stephen is the new user created on following;
Setup mailaccount
http://www.howtoforge.com/forums/showthread.php?t=2

$ ls /home/
Code:
other_users
stephen a/c couldn't be found

$ su stephen
sh-4.1$ls
Code:
smtpd.crt smtpd.key web
it works but I couldn't find the mail. I don't know why.

B.R.
satimis

Last edited by satimis; 1st February 2012 at 14:26.
Reply With Quote
Sponsored Links
  #2  
Old 2nd February 2012, 19:29
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,900
Thanked 2,702 Times in 2,545 Posts
Default

You are mixing incompatible tutorials. The first two tutorials are for virtual users, while the forum link talks about setting up system user email accounts.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 3rd February 2012, 03:46
satimis satimis is offline
Senior Member
 
Join Date: Oct 2006
Posts: 533
Thanks: 4
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by falko View Post
You are mixing incompatible tutorials. The first two tutorials are for virtual users, while the forum link talks about setting up system user email accounts.
Hi falko,

OK, I would start again using Ubuntu 10.04(LTS) base server.

I'm prepared testing virtual users on VM, i.e. several domains running on the same IP (fixed). Would following howto be suitable for me?

Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 11.10)
http://www.howtoforge.com/virtual-us...l-ubuntu-11.10 (Submitted by falko on Mon, 2011-11-07 01:29)
?

About 3 years ago I did the same test making use of "Perdiction". It worked for me. Unfortunately I forget how to make it. I'm now digging hard on my database.

TIA

B.R.
satimis
Reply With Quote
  #4  
Old 3rd February 2012, 12:47
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,900
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by satimis View Post
I'm prepared testing virtual users on VM, i.e. several domains running on the same IP (fixed). Would following howto be suitable for me?
Yes, it's fine for multiple domains.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 6th February 2012, 10:57
satimis satimis is offline
Senior Member
 
Join Date: Oct 2006
Posts: 533
Thanks: 4
Thanked 2 Times in 2 Posts
Default

Hi falko,

I followed your Howto building the server. There was no problem up to;
9 Install amavisd-new, SpamAssassin, And ClamAV
http://www.howtoforge.com/virtual-us...buntu-11.10-p3

server name = server01.domain.com

# hostname
Code:
server01.domain.com
# hostname -f
Code:
server01.domain.com
On running;
# netstat -tap
Code:
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 *:ssh                   *:*                     LISTEN      1195/sshd       
tcp        0      0 *:smtp                  *:*                     LISTEN      6629/master     
tcp        0      0 localhost:10024         *:*                     LISTEN      4668/amavisd (maste
tcp        0      0 localhost:10025         *:*                     LISTEN      6629/master     
tcp        0      0 localhost:mysql         *:*                     LISTEN      842/mysqld      
tcp        0      0 192.168.0.218:ssh       192.168.0.200:41762     ESTABLISHED 1228/sshd: domain 
tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      1195/sshd       
tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      827/couriertcpd 
tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN      870/couriertcpd 
tcp6       0      0 [::]:pop3               [::]:*                  LISTEN      845/couriertcpd 
tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      805/couriertcpd 
tcp6       0      0 [::]:www                [::]:*                  LISTEN      1054/apache2
On above output, the line
Code:
tcp        0      0 192.168.0.218:ssh       192.168.0.200:41762     ESTABLISHED 1228/sshd: domain
differs from your howto;
Code:
tcp        0    300 server1.example.com:ssh 192.168.0.199:4041      ESTABLISHED 693/0
server name missing and domain (without .com) appearing at the end of the line.

Is it a problem. If "YES" where shall I check and how to correct it? TIA

B.R.
satimis
Reply With Quote
  #6  
Old 7th February 2012, 12:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,900
Thanked 2,702 Times in 2,545 Posts
Default

It's no problem, but make sure you have your hostname in /etc/hosts.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 7th February 2012, 12:59
satimis satimis is offline
Senior Member
 
Join Date: Oct 2006
Posts: 533
Thanks: 4
Thanked 2 Times in 2 Posts
 
Default

Quote:
Originally Posted by falko View Post
It's no problem, but make sure you have your hostname in /etc/hosts.
$ cat /etc/hosts
Code:
127.0.0.1       localhost
127.0.1.1       ser01.mydomain.com ser01
192.168.0.218   mail.mydomain.com

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
This server can send mail but unable to receive mail. I'll start another posting. Thanks

satimis
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Catchall and Forwarding not working simmo General 6 22nd March 2014 00:54
Postfix Timeout after DATA from some emails treeman Server Operation 13 25th September 2013 12:51
Getting Email Working ISPConfig3 Squirrelmail and Courier etc Ian Wilson Installation/Configuration 17 19th June 2013 22:58
CGI and FormMail Cracklefish Installation/Configuration 17 13th October 2009 13:40
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 17:39


All times are GMT +2. The time now is 17:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.