Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 18th July 2006, 17:02
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,654 Times in 4,463 Posts
Default

Quote:
Originally Posted by jockstrap
Autoresponder Problems Still

One of the enhancements of this version was to have the .vacation.cache deleted each time you turn off the autoresponder option...

Unfortunately, this is not working..

Have upgraded to 2.2.5 and turned on autoresponder - works normally...

unchecked autoresponder option and even removed the message - neither resulted in the .autoresponder.cache being deleted!

Maybe a script or permissions problem ?

I have not modified anything - a very vanilla "perfect debian 3.1" install with roundcube mail.

Any idea guys ???

How long did you wait? The autoresponder cache is removed by the server process, this may take 2-3 minutes.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Sponsored Links
  #12  
Old 18th July 2006, 17:14
jockstrap jockstrap is offline
Member
 
Join Date: Jul 2006
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well - option was removed from panels before i wrote the above post... been about 20min now and it's still there ?
Reply With Quote
  #13  
Old 18th July 2006, 17:28
wr19026 wr19026 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 172
Thanks: 7
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by Ben
I guess everything that has to be reached via ISPConfigs own apache on port 81 won't be accessible during upgrade, because the services are shut down.
So it will also affect webmail, phpMyAdmin if you use it via ISPConfigs own apache.


it's linux not windows (no you don't have to)
Thanks for your help
Reply With Quote
  #14  
Old 18th July 2006, 17:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Quote:
Originally Posted by jockstrap
Well - option was removed from panels before i wrote the above post... been about 20min now and it's still there ?
The name of the cache is .vacation.cache, not .autoresponder.cache.
Just checked again, it's working for me.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:

Last edited by falko; 18th July 2006 at 17:38.
Reply With Quote
  #15  
Old 18th July 2006, 17:42
jockstrap jockstrap is offline
Member
 
Join Date: Jul 2006
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
The name of the cache is .vacation.cache, not .autoresponder.cache.

Yes - sorry falco - just my typo... it's still there and contains the email address that i used to email to the user. Thus verifying that it is still the same and not even a deleted reallocated one.
Reply With Quote
  #16  
Old 18th July 2006, 18:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

I've just tested again. It's working with mbox, but not with Maildir... This software is getting too complex to test it all...

Please replace /root/ispconfig/isp/conf/autoresponder.rc.master with this one:

Code:
SHELL=/bin/sh    # for other shells, this might need adjustment
EMAIL=`formail -zxTo:`

              :0 Whc: vacation.lock
               # Perform a quick check to see if the mail was addressed to us
               #* $^To:.*\<$\LOGNAME\>
               # Don't reply to daemons and mailinglists
              * !^FROM_DAEMON
               # Mail loops are evil
              * !^X-Loop: ${EMAIL}
              | formail -rD 8192 {PFAD}/.vacation.cache

                :0 ehc         # if the name was not in the cache
                | (formail -rI"From: {EMAIL_ADDRESS}" -I"Precedence: junk" \
                     -A"X-Loop: ${EMAIL}" ; \
                   cat {PFAD}/.vacation.msg \
                  ) | $SENDMAIL -oi -t
And now I'm going to forget about the last 24 hours. Making me sick...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #17  
Old 18th July 2006, 21:25
fobicodam fobicodam is offline
Senior Member
 
Join Date: Apr 2006
Location: Argentina
Posts: 346
Thanks: 0
Thanked 1 Time in 1 Post
Send a message via MSN to fobicodam
Default

Quote:
Originally Posted by falko
I've just tested again. It's working with mbox, but not with Maildir... This software is getting too complex to test it all...

And now I'm going to forget about the last 24 hours. Making me sick...
Dont worry, thats why we are here too you try to fix the errors fast
Reply With Quote
  #18  
Old 18th July 2006, 21:45
jockstrap jockstrap is offline
Member
 
Join Date: Jul 2006
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by fobicodam
Dont worry, thats why we are here too you try to fix the errors fast
Ditto!
Reply With Quote
  #19  
Old 19th July 2006, 02:31
djtremors djtremors is offline
Senior Member
 
Join Date: Apr 2006
Location: Sydney
Posts: 278
Thanks: 0
Thanked 13 Times in 11 Posts
Default

Am I reading this right? This is another install for a single bugfix?
Is there a diff patch available to do the same thing rather than going through the installer again and messing up the certificates?
Last time I just modified the certificates part of the scripts to copy my backups from another path but to do this again *sigh*.

Also, I noticed launguage problems in places as well which I could live with. Some messages sort of like "Please fill in the 'Vorname' field".. half english, half german
Reply With Quote
  #20  
Old 19th July 2006, 08:49
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,654 Times in 4,463 Posts
 
Default

Quote:
Originally Posted by djtremors
Am I reading this right? This is another install for a single bugfix?
Is there a diff patch available to do the same thing rather than going through the installer again and messing up the certificates?
Last time I just modified the certificates part of the scripts to copy my backups from another path but to do this again *sigh*.
Please have a look here:

http://www.howtoforge.com/forums/sho...2&postcount=25
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 2.2.4 released till General 25 18th July 2006 14:04
ISPConfig 2.2.3 released till General 16 14th June 2006 01:42
ISPConfig 2.2.1 released till General 11 28th May 2006 11:39
ISPConfig 2.2.2 released till General 9 10th May 2006 14:03
ISPConfig 2.3.1-dev released till General 0 8th May 2006 23:18


All times are GMT +2. The time now is 22:04.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.