Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 18th July 2006, 11:43
hotchilli hotchilli is offline
Member
 
Join Date: Jan 2006
Posts: 60
Thanks: 2
Thanked 0 Times in 0 Posts
Default postfix/mozills thunderbird mailclient

I installed mozilla thunderbird mail client and in the incomimg and outgoing boxes i placed my fqn mail.hotchilli.net but connection was refused.

in my /etc/hosts i have the entry 192.168.1.64 mail.hotchilli.net mail



I have postfix and in the man.cf
mynetwors = 127.0.0.1/8
so in postfix main.cf i added this line to mynetworks 192.168.1.1/24
but still on running thunderbired conection refused.

hotchilli
Reply With Quote
Sponsored Links
  #2  
Old 18th July 2006, 11:46
Ben Ben is offline
Moderator
 
Join Date: Jul 2006
Posts: 1,029
Thanks: 7
Thanked 62 Times in 56 Posts
Default

what tells /var/log/mail.log (/var/log/maillog) while trying to access your mailserver?

maybe server or clientfirewall blocking incoming / outgoing traffic on that port?
Reply With Quote
  #3  
Old 18th July 2006, 12:23
hotchilli hotchilli is offline
Member
 
Join Date: Jan 2006
Posts: 60
Thanks: 2
Thanked 0 Times in 0 Posts
Default mail client

there is nothing in mail.log
there is no client firewall

hotchilli
Reply With Quote
  #4  
Old 18th July 2006, 12:28
Ben Ben is offline
Moderator
 
Join Date: Jul 2006
Posts: 1,029
Thanks: 7
Thanked 62 Times in 56 Posts
Default

which OS do you run on your server?

If nothing is in your mail.log then your mailserver does not receive anything.

Any iptable rules active? -> iptables -L
Reply With Quote
  #5  
Old 18th July 2006, 12:42
hotchilli hotchilli is offline
Member
 
Join Date: Jan 2006
Posts: 60
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Ben
what tells /var/log/mail.log (/var/log/maillog) while trying to access your mailserver?

maybe server or clientfirewall blocking incoming / outgoing traffic on that port?

OS is dapper drake 6.06(ubuntu) server

iptables.

Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination


if the above need to be completed? if so how to complete?

here is part of my main.cf (no pop) does this matter for mail client that mail server doesnot have pop?

main.cf
postfix main.cf

recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = no
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_tls_auth_only = yes
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

-----------------------------------------------------------------------------------------------------------------------
i have outgoing configured outgoing smtp to use localhost or 127.0.0.1 as its SMTP server. on prt 25
in thunderbird but still refused connection to potfix.


also under edit>>>>account settings>>>>>>>>>>>server settings
server type: pop mail server
server name :mail.hotchilli.net
port :110
user name admin (i must point out here that admin does not have root privlagies)
use secure connection TLS







hotchilli

Last edited by hotchilli; 19th July 2006 at 08:35.
Reply With Quote
  #6  
Old 19th July 2006, 13:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Is 212.67.203.170 your server's public IP address?
What's the output of
Code:
netstat -tap
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 19th July 2006, 13:40
hotchilli hotchilli is offline
Member
 
Join Date: Jan 2006
Posts: 60
Thanks: 2
Thanked 0 Times in 0 Posts
Default mail client

Is 212.67.203.170 your server's public IP address? no?

netstat -tap

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:smtp *:* LISTEN 3972/master
tcp6 0 0 *:ssh *:* LISTEN 3991/sshd
tcp6 0 0 *:nntp *:* LISTEN 3891/innd
tcp6 0 0 *:smtp *:* LISTEN 3972/master



OK imy posrfix server does not have pop then what can i expect sorry.

but what i would like to know is that postfix is a local ie 127.0.0.0.1/8

now I have a smtp feed from my ISP and i only use postfix and my ISP
in the way that I use the MX record from my ISP ie mail.hotchilli.com

I am wondering if it would be possible in thunderbird to use the pop and smtp
from my ISP ?

but if i use the same usernames as are connected to my
domain ie lex@hotchilli.com and admin@hotchilli.com) would this
confuse things in my local serverv(postfix) as you can see in post no5
of this thread how it is configured?





hotchilli

Last edited by hotchilli; 20th July 2006 at 12:03.
Reply With Quote
  #8  
Old 20th July 2006, 13:00
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Quote:
Originally Posted by hotchilli
Is 212.67.203.170 your server's public IP address? no?
That's not your server's public IP address? Then you must change the DNS record for mail.hotchilli.com because mail.hotchilli.com is pointing to that IP address which means your mail client connects to that IP address...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 21st July 2006, 09:00
hotchilli hotchilli is offline
Member
 
Join Date: Jan 2006
Posts: 60
Thanks: 2
Thanked 0 Times in 0 Posts
Default mail client

ok its my fault first of all hotchili.net or . com is an example i used it is not my web site or ISP.

I have two accounts at example.net

hotchilli
and
admin(this user does not have root access)

I am loged in as user hotchilli and am creating a mail account for admin@example.net

mail for hotchilli comes into /home/hotchilli
and
mail for adim comes into /home/admin

thunderbird is altering me with this message

unable to create lock file /var/spool/mail/hotchilli.lock for ovemail to work , it is neccessary
to create lock files in the mail spool directory on many syatems this is beat done by making the
the spool directory be mode 01777

how to create lock files ?
asuming my mail comes ito /home/admin how to change this to /var/spool directory?





hotchilli

Last edited by hotchilli; 21st July 2006 at 15:50.
Reply With Quote
  #10  
Old 22nd July 2006, 15:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
 
Default

Please run
Code:
chmod 01777 /var/spool/mail/
Do you use Maildir or mbox? What's the output of
Code:
netstat -tap
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 23:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.