Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th May 2011, 22:32
tomaszm tomaszm is offline
Junior Member
 
Join Date: May 2011
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default .htaccess + mod_rewrite

Hello!

I've problem with ispconfig3 and mod_rewrite and .htaccess files.
When I create .htaccess file and I put there:
Options +Indexes
It dosen't work.
Also mod_rewrite dosen't work.
Reply With Quote
Sponsored Links
  #2  
Old 28th May 2011, 12:08
falko falko is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Please check the AllowOverride setting in the corresponding vhost. See http://httpd.apache.org/docs/2.0/mod...#allowoverride
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 29th May 2011, 12:12
commentator commentator is offline
Senior Member
 
Join Date: Jul 2008
Location: The Netherlands
Posts: 146
Thanks: 49
Thanked 7 Times in 5 Posts
Default

Same problem here with mod_rewrite.

Server with Debian Squeeze/Sid and ISPConfig 3.0.3.3


Problem is php fastcgi. Set it to mod-php and it works as it should be.

@falco / @till is there a fix for this so it can work with fastcgi?
Reply With Quote
  #4  
Old 23rd February 2012, 19:22
commentator commentator is offline
Senior Member
 
Join Date: Jul 2008
Location: The Netherlands
Posts: 146
Thanks: 49
Thanked 7 Times in 5 Posts
 
Default

Update :

Code:
RewriteEngine on
RewriteRule ^index.php / [R=301,L]
RewriteRule  ^[a-z0-9]+\.[a-z0-9]+$ - [NC,L]
RewriteCond %{ENV:REDIRECT_STATUS} ^$
RewriteRule ^([a-z_0-9/\.-]+)$ test.php/$1 [NC,QSA,L]
works perfect with mod-php but not with fast-cgi. Why ?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CRON and .htaccess problems devilslayer General 1 23rd November 2007 16:49
.htaccess Liac Server Operation 15 20th June 2007 15:19
wordpress MU and ISPconfig .htaccess isues palkat General 4 18th October 2006 11:57
.htaccess login challenge broken with mod_rewrite ozonblue Installation/Configuration 2 13th September 2006 10:09
No .htaccess in automatic backup? tron Installation/Configuration 3 22nd March 2006 18:03


All times are GMT +2. The time now is 10:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.