Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th January 2012, 09:00
giftsnake giftsnake is offline
Senior Member
 
Join Date: Jan 2009
Posts: 108
Thanks: 15
Thanked 9 Times in 8 Posts
Default new dns-zone not created properly after upgrade to 3.0.4.2

similar to http://www.howtoforge.com/forums/showthread.php?t=55816, my dns does not work anymore.

running debian squeeze with bind on ispconfig 3.0.4.2.
I created a new zone (first after upgrade, existant domain, but not on my server) with the wizard, the zone-file gets created, but
Code:
dig @my.server.com domain.com
just gives:
Code:
->>HEADER<<- opcode: QUERY, status: REFUSED
on the server itself, it gives the result for the old configuration:
Code:
dig @localhost domain.com

; <<>> DiG 9.7.3 <<>> @localhost domain.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 56020
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0

;; QUESTION SECTION:
;domain.com.			IN	A

;; ANSWER SECTION:
domain.com.		3600	IN	A	IP.IP.IP.IP

;; AUTHORITY SECTION:
domain.com.		3600	IN	NS	ns2.domain2.com.
domain.com.		3600	IN	NS	ns.domain2.com.
the zone does not get transfered to secondary nameservers as well...
thanks for help in advance :-)
Reply With Quote
Sponsored Links
  #2  
Old 20th January 2012, 09:33
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,183
Thanks: 829
Thanked 5,414 Times in 4,257 Posts
Default

Check syslog on master and slave for bind / named errors.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 20th January 2012, 10:14
giftsnake giftsnake is offline
Senior Member
 
Join Date: Jan 2009
Posts: 108
Thanks: 15
Thanked 9 Times in 8 Posts
Default

nothing there, except for the request...
Code:
Jan 20 10:08:05 hostname named[25989]: client IP#60326: query (cache) 'domain.com/A/IN' denied
Reply With Quote
  #4  
Old 20th January 2012, 11:09
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,183
Thanks: 829
Thanked 5,414 Times in 4,257 Posts
Default

Please check that you added the IP address of the slave server(s) in the filed "Allow zone transfers to these IPs (comma separated list)" of the DNS zone.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 21st January 2012, 01:55
giftsnake giftsnake is offline
Senior Member
 
Join Date: Jan 2009
Posts: 108
Thanks: 15
Thanked 9 Times in 8 Posts
Default

checked, its all in there.
Reply With Quote
  #6  
Old 21st January 2012, 12:39
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Are there any other errors in your syslog (both on the master and the slave)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 21st January 2012, 12:41
giftsnake giftsnake is offline
Senior Member
 
Join Date: Jan 2009
Posts: 108
Thanks: 15
Thanked 9 Times in 8 Posts
Default

not that i am aware of. even when i restart bind or change something in the zone file

edit: looks like the entry in 'named.conf.local' was mising.

Last edited by giftsnake; 22nd January 2012 at 00:53.
Reply With Quote
  #8  
Old 23rd January 2012, 08:36
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,183
Thanks: 829
Thanked 5,414 Times in 4,257 Posts
Default

Then there must be a probem that blocks the ispconfig server.sh script or cron is not running. See FAQ on how to debug that:

http://www.faqforge.com/linux/debugg...-of-a-failure/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 23rd January 2012, 08:45
giftsnake giftsnake is offline
Senior Member
 
Join Date: Jan 2009
Posts: 108
Thanks: 15
Thanked 9 Times in 8 Posts
Wink

/usr/local/ispconfig/server/server.sh
Code:
23.01.2012-07:39 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
23.01.2012-07:39 - DEBUG - Found 9 changes, starting update process.
23.01.2012-07:39 - DEBUG - Calling function 'soa_insert' from plugin 'bind_plugin' raised by event 'dns_soa_insert'.
23.01.2012-07:39 - DEBUG - Writing BIND domain file: /etc/bind/pri.testdomain.info
PHP Warning:  file_put_contents(/etc/bind): failed to open stream: Is a directory in /usr/local/ispconfig/server/plugins-available/bind_plugin.inc.php on line 361
23.01.2012-07:39 - DEBUG - Writing BIND named.conf.local file: /etc/bind
23.01.2012-07:39 - DEBUG - Processed datalog_id 2431
23.01.2012-07:39 - DEBUG - Calling function 'rr_insert' from plugin 'bind_plugin' raised by event 'dns_rr_insert'.
23.01.2012-07:39 - DEBUG - Writing BIND domain file: /etc/bind/pri.testdomain.info
PHP Warning:  file_put_contents(/etc/bind): failed to open stream: Is a directory in /usr/local/ispconfig/server/plugins-available/bind_plugin.inc.php on line 361
23.01.2012-07:39 - DEBUG - Writing BIND named.conf.local file: /etc/bind
23.01.2012-07:39 - DEBUG - Processed datalog_id 2432
23.01.2012-07:39 - DEBUG - Calling function 'rr_insert' from plugin 'bind_plugin' raised by event 'dns_rr_insert'.
23.01.2012-07:39 - DEBUG - Writing BIND domain file: /etc/bind/pri.testdomain.info
PHP Warning:  file_put_contents(/etc/bind): failed to open stream: Is a directory in /usr/local/ispconfig/server/plugins-available/bind_plugin.inc.php on line 361
23.01.2012-07:39 - DEBUG - Writing BIND named.conf.local file: /etc/bind
23.01.2012-07:39 - DEBUG - Processed datalog_id 2433
23.01.2012-07:39 - DEBUG - Calling function 'rr_insert' from plugin 'bind_plugin' raised by event 'dns_rr_insert'.
23.01.2012-07:39 - DEBUG - Writing BIND domain file: /etc/bind/pri.testdomain.info
PHP Warning:  file_put_contents(/etc/bind): failed to open stream: Is a directory in /usr/local/ispconfig/server/plugins-available/bind_plugin.inc.php on line 361
23.01.2012-07:39 - DEBUG - Writing BIND named.conf.local file: /etc/bind
23.01.2012-07:39 - DEBUG - Processed datalog_id 2434
23.01.2012-07:39 - DEBUG - Calling function 'rr_insert' from plugin 'bind_plugin' raised by event 'dns_rr_insert'.
23.01.2012-07:39 - DEBUG - Writing BIND domain file: /etc/bind/pri.testdomain.info
PHP Warning:  file_put_contents(/etc/bind): failed to open stream: Is a directory in /usr/local/ispconfig/server/plugins-available/bind_plugin.inc.php on line 361
23.01.2012-07:39 - DEBUG - Writing BIND named.conf.local file: /etc/bind
23.01.2012-07:39 - DEBUG - Processed datalog_id 2435
23.01.2012-07:39 - DEBUG - Calling function 'rr_insert' from plugin 'bind_plugin' raised by event 'dns_rr_insert'.
23.01.2012-07:39 - DEBUG - Writing BIND domain file: /etc/bind/pri.testdomain.info
PHP Warning:  file_put_contents(/etc/bind): failed to open stream: Is a directory in /usr/local/ispconfig/server/plugins-available/bind_plugin.inc.php on line 361
23.01.2012-07:39 - DEBUG - Writing BIND named.conf.local file: /etc/bind
23.01.2012-07:39 - DEBUG - Processed datalog_id 2436
23.01.2012-07:39 - DEBUG - Calling function 'rr_insert' from plugin 'bind_plugin' raised by event 'dns_rr_insert'.
23.01.2012-07:39 - DEBUG - Writing BIND domain file: /etc/bind/pri.testdomain.info
PHP Warning:  file_put_contents(/etc/bind): failed to open stream: Is a directory in /usr/local/ispconfig/server/plugins-available/bind_plugin.inc.php on line 361
23.01.2012-07:39 - DEBUG - Writing BIND named.conf.local file: /etc/bind
23.01.2012-07:39 - DEBUG - Processed datalog_id 2437
23.01.2012-07:39 - DEBUG - Calling function 'rr_insert' from plugin 'bind_plugin' raised by event 'dns_rr_insert'.
23.01.2012-07:39 - DEBUG - Writing BIND domain file: /etc/bind/pri.testdomain.info
PHP Warning:  file_put_contents(/etc/bind): failed to open stream: Is a directory in /usr/local/ispconfig/server/plugins-available/bind_plugin.inc.php on line 361
23.01.2012-07:39 - DEBUG - Writing BIND named.conf.local file: /etc/bind
23.01.2012-07:39 - DEBUG - Processed datalog_id 2438
23.01.2012-07:39 - DEBUG - Calling function 'rr_insert' from plugin 'bind_plugin' raised by event 'dns_rr_insert'.
23.01.2012-07:39 - DEBUG - Writing BIND domain file: /etc/bind/pri.testdomain.info
PHP Warning:  file_put_contents(/etc/bind): failed to open stream: Is a directory in /usr/local/ispconfig/server/plugins-available/bind_plugin.inc.php on line 361
23.01.2012-07:39 - DEBUG - Writing BIND named.conf.local file: /etc/bind
23.01.2012-07:39 - DEBUG - Processed datalog_id 2439
23.01.2012-07:39 - DEBUG - Calling function 'restartBind' from module 'dns_module'.
23.01.2012-07:39 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
finished.
changing the configuration in 'system->server config->dns' to the full path including each filename fixed it.

Last edited by giftsnake; 23rd January 2012 at 08:50. Reason: found the solution
Reply With Quote
  #10  
Old 25th January 2012, 16:59
BrainyForge BrainyForge is offline
Junior Member
 
Join Date: Jun 2011
Location: Italia
Posts: 27
Thanks: 1
Thanked 4 Times in 4 Posts
 
Default

I've also had the same problem,
in the different tests I've done the research to figure out why my DNS stopped working, I found the same problem, somehow reverberates also on installations with MyDNS.
I have a feeling the source of the problem is the same, I show my link http://www.howtoforge.com/forums/showthread.php?t=55914 maybe you can give some useful details.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS not responding MyKE General 23 5th January 2011 15:59
DNS Zone Transfer Problem centosarus Installation/Configuration 11 17th July 2009 16:11
DNS broken after Fedora 10 upgrade woodson2 Server Operation 2 5th December 2008 03:33
DNS records fail to be created _ronnie_ General 18 30th December 2007 20:27
DNS Configuration Problems VMartins Installation/Configuration 10 24th July 2007 14:40


All times are GMT +2. The time now is 11:13.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.