#1  
Old 20th January 2012, 05:23
Tekati Tekati is offline
ISPConfig Developer
 
Join Date: Aug 2007
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default Multi site data replication?

Can it be explained how when I add a mail user on the master server that that transaction then is sent to the mail server?

The reason I ask is I had to restore the mail server from an old backup so what I did to get it working was basically dump the master database and restored it on the mail server. But the issue now is the mail server is not receiving updates from the master server.

Basically after adding yet another user the mail server does not receive that information.

Can someone explain how the replication actually works?
Reply With Quote
Sponsored Links
  #2  
Old 20th January 2012, 09:32
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

The slave server queries the master server for changes by searching for new records in sys_datalog and then replicates the data then into its local database before it executes the plugin actions.

See FAQ on how to debug you setup:

http://www.faqforge.com/linux/debugg...-of-a-failure/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 24th January 2012, 20:01
Tekati Tekati is offline
ISPConfig Developer
 
Join Date: Aug 2007
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Although the link provided and information about sys_datalog pushed me in the right direction it really did not solve my issue.

The real problem was the mysql server on the master server somehow had its configuration replaced so that it was binding to 127.0.0.1.

Doing the testing from that faq did not reveal the fact that it was unable to contact to the master db server. It said finished. and nothing else

Setting the logging to debug did not help as since that is in the database itself not being able to replicate that to the slave servers there was no way for that setting to take effect.

I would suggest that if a slave server cannot talk to the master server that an error be thrown to the console/log stating that the connection failed in all log settings.

In the log I actually had messages from last year about not being able to contact the master server when I set this system up but nothing current was in the log to suggest that the master server was any part of the problem.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Master MySQL Data Base replication issue On Debian Squeeze Linox91 Installation/Configuration 1 12th January 2012 22:34
Aliases failing after ISPConfig 3.04 update kassyo Installation/Configuration 3 13th November 2011 10:50
mysql ssl data replication problem certificate issue? isn Server Operation 5 30th July 2010 15:38
Setting up a multi site web server and DNS wxman Installation/Configuration 7 31st October 2007 17:33
Help with Bluetooth PAND josto HOWTO-Related Questions 1 7th August 2007 20:53


All times are GMT +2. The time now is 06:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.