Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 17th July 2006, 18:57
edge edge is online now
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,036
Thanks: 268
Thanked 153 Times in 133 Posts
Default

Quote:
Originally Posted by till
Sure, first you will have to install a patched SSH daemon as chrooting is not supported by SSH by default.

See step 2 in this howto:
http://www.howtoforge.com/chrooted_ssh_howto_debian

Then you will have to enable it in ISPConfig in the file config.inc.php, set:

$go_info["server"]["ssh_chroot"] = 1;

The user account will be chrooted for every user with SSH enabled that you create or update.
What config.inc.php file?? I've got 3

Code:
/home/admispconfig/ispconfig/lib/config.inc.php
/home/admispconfig/ispconfig/web/phpmyadmin/config.inc.php
/root/ispconfig/scripts/lib/config.inc.php
Also.. the step 2 in the howto did give me an error about 'zlib' beeing old!
I've done the ./configure with the extra "--without-zlib-version-check" option.

** edit

I guess it's the
Code:
/home/admispconfig/ispconfig/lib/config.inc.php
as it's the only one with $go_info["server"]["ssh_chroot"] in it

Last edited by edge; 17th July 2006 at 19:01.
Reply With Quote
Sponsored Links
  #12  
Old 17th July 2006, 19:04
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 213
Thanked 648 Times in 294 Posts
Talking Thanks again, from Holland!

Thanks for the nice work again!

I have updated from 2.2.3 to 2.2.4 without any problems.
Really nice V. 2.2.4 in DUTCH !!!
__________________
Hans

MrHostman | Master in managed hosting
Reply With Quote
  #13  
Old 17th July 2006, 19:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Quote:
Originally Posted by edge
I guess it's the
Code:
/home/admispconfig/ispconfig/lib/config.inc.php
as it's the only one with $go_info["server"]["ssh_chroot"] in it
Yes, that's right.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #14  
Old 17th July 2006, 20:11
fobicodam fobicodam is offline
Senior Member
 
Join Date: Apr 2006
Location: Argentina
Posts: 346
Thanks: 0
Thanked 1 Time in 1 Post
Send a message via MSN to fobicodam
Thumbs up

Quote:
Originally Posted by till
ISPConfig 2.2.4 is available for download.

- Added: Added a tool to move a website from one customer
to another one.
- Added: New Feature: Webalizer statistics can now be turned on
or off for each web site individually.
I love you because of that.

Ill try updating tonight..

For next releases, do the daily backups optionals too ). I (as many webhosting enterprises) sell disk space and some clients dont want to expend 40% because a zip..
Reply With Quote
  #15  
Old 17th July 2006, 20:30
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,395
Thanks: 833
Thanked 5,490 Times in 4,322 Posts
Default

Quote:
Originally Posted by edge
Also.. the step 2 in the howto did give me an error about 'zlib' beeing old!
I've done the ./configure with the extra "--without-zlib-version-check" option.
Yes, either disable the zlib version check or install zlib as described in step 1 of the howto.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #16  
Old 17th July 2006, 22:41
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 213
Thanked 648 Times in 294 Posts
Angry Error in ISPConfig 2.2.4

When i login as a client and when i select any website from the structure tree, then click any tab on the ISP Site form:
the folowing error occurs:

------------------------------------------------
The following error occurred:

Field: Domain
Only the following sign are allowed: a-z A-Z 0-9 -
------------------------------------------------

Now my clients can not make any setting anymore!

What is this???

By the way sorry for my double post, but this error is NOT nice, a serious problem for clients to be solved SOON!
__________________
Hans

MrHostman | Master in managed hosting

Last edited by Hans; 17th July 2006 at 23:31.
Reply With Quote
  #17  
Old 17th July 2006, 22:51
TheRudy TheRudy is offline
Senior Member
 
Join Date: Dec 2005
Posts: 216
Thanks: 1
Thanked 7 Times in 5 Posts
Default

Indeed, get the same error:

Field: Domain
Only the following sign are allowed: a-z A-Z 0-9 -
Reply With Quote
  #18  
Old 18th July 2006, 00:00
todvard todvard is offline
Member
 
Join Date: Aug 2005
Posts: 85
Thanks: 1
Thanked 6 Times in 5 Posts
Default

indeed. the allowed signs for Domain field sould be extended with dot (.)
Reply With Quote
  #19  
Old 18th July 2006, 02:22
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Quote:
Originally Posted by Hans
When i login as a client and when i select any website from the structure tree, then click any tab on the ISP Site form:
the folowing error occurs:

------------------------------------------------
The following error occurred:

Field: Domain
Only the following sign are allowed: a-z A-Z 0-9 -
------------------------------------------------

Now my clients can not make any setting anymore!

What is this???
This happens when the domain on the "Basis" tab does not match the regular expression for domains. Does your domain maybe end with a dot? Can you post the domain here (exactly as it is written in the domain field)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #20  
Old 18th July 2006, 06:32
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 213
Thanked 648 Times in 294 Posts
 
Default

Falko,

i reply here:
http://www.howtoforge.com/forums/showthread.php?t=5590

Sorry for my double post. I will not do that again. But i thought this is important.
__________________
Hans

MrHostman | Master in managed hosting
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 2.2.3 released till General 16 14th June 2006 00:42
ISPConfig 2.2.1 released till General 11 28th May 2006 10:39
ISPConfig 2.2.2 released till General 9 10th May 2006 13:03
ISPConfig 2.3.1-dev released till General 0 8th May 2006 22:18
ISPConfig 2.0.8 released till General 6 29th August 2005 10:43


All times are GMT +2. The time now is 20:30.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.