Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd October 2011, 22:08
vaio vaio is offline
Member
 
Join Date: Nov 2010
Posts: 48
Thanks: 21
Thanked 1 Time in 1 Post
Default Webmail/server/ftp work, but no websites

Hello,
i have a strange issue with ispconfig.
It was working great but suddently it is not showing websites.

Server is UP, have tried reseting apache, also restart server (v-server).
Server works, also i can get to webmail and ftp, but hostnames have apparently a problem. How can i repair that?

Thank you for fast reply,
V.

DNS-server is not running. How to restart it?

Last edited by vaio; 22nd October 2011 at 22:16.
Reply With Quote
Sponsored Links
  #2  
Old 22nd October 2011, 22:23
vaio vaio is offline
Member
 
Join Date: Nov 2010
Posts: 48
Thanks: 21
Thanked 1 Time in 1 Post
Default

Ok, after 30min it started working on its own....

Don't know why? Is DNS service optioned with some cron job?

Thank you for further explanation.
Reply With Quote
  #3  
Old 23rd October 2011, 19:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Did you check your logs?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 24th October 2011, 16:49
vaio vaio is offline
Member
 
Join Date: Nov 2010
Posts: 48
Thanks: 21
Thanked 1 Time in 1 Post
Default

Hello,
i have checked logs on control panel but there are only for last few entries.

falko, please kindly tell me how to check logs on server to paste them here.

Thanks,
V.
Reply With Quote
  #5  
Old 25th October 2011, 13:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

The logs are in the /var/log/ directory. You can check them with vi, cat, or tail, e.g.
Code:
tail -n100 /var/log/messages
to get the last 100 lines from /var/log/messages.
Take a look at the man pages of vi, cat, and tail.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 24th December 2011, 22:57
vaio vaio is offline
Member
 
Join Date: Nov 2010
Posts: 48
Thanks: 21
Thanked 1 Time in 1 Post
Default

Hello Falko,
output is here:
Code:
Dec 24 21:16:53 s1 kernel: [    0.171445] Brought up 1 CPUs
Dec 24 21:16:53 s1 kernel: [    0.171459] PCI: setting up Xen PCI frontend stub
Dec 24 21:16:53 s1 kernel: [    0.171886] ACPI: Interpreter disabled.
Dec 24 21:16:53 s1 kernel: [    0.171892] Linux Plug and Play Support v0.97 (c) Adam Belay
Dec 24 21:16:53 s1 kernel: [    0.171913] pnp: PnP ACPI: disabled
Dec 24 21:16:53 s1 kernel: [    0.172088] suspend: event channel 7
Dec 24 21:16:53 s1 kernel: [    0.172374] xen_mem: Initialising balloon driver.
Dec 24 21:16:53 s1 kernel: [    0.175660] usbcore: registered new interface driver usbfs
Dec 24 21:16:53 s1 kernel: [    0.175699] usbcore: registered new interface driver hub
Dec 24 21:16:53 s1 kernel: [    0.175727] usbcore: registered new device driver usb
Dec 24 21:16:53 s1 kernel: [    0.175826] PCI: System does not support PCI
Dec 24 21:16:53 s1 kernel: [    0.175830] PCI: System does not support PCI
Dec 24 21:16:53 s1 kernel: [    0.181135] NET: Registered protocol family 2
Dec 24 21:16:53 s1 kernel: [    0.216851] IP route cache hash table entries: 65536 (order: 7, 524288 bytes)
Dec 24 21:16:53 s1 kernel: [    0.217029] TCP established hash table entries: 262144 (order: 10, 4194304 bytes)
Dec 24 21:16:53 s1 kernel: [    0.218209] TCP bind hash table entries: 65536 (order: 8, 1048576 bytes)
Dec 24 21:16:53 s1 kernel: [    0.218509] TCP: Hash tables configured (established 262144 bind 65536)
Dec 24 21:16:53 s1 kernel: [    0.218513] TCP reno registered
Dec 24 21:16:53 s1 kernel: [    0.228871] NET: Registered protocol family 1
Dec 24 21:16:53 s1 kernel: [    0.228946] checking if image is initramfs... it is
Dec 24 21:16:53 s1 kernel: [    0.239077] Freeing initrd memory: 21416k freed
Dec 24 21:16:53 s1 kernel: [    0.242115] platform rtc_cmos: registered platform RTC device (no PNP device found)
Dec 24 21:16:53 s1 kernel: [    0.242330] audit: initializing netlink socket (disabled)
Dec 24 21:16:53 s1 kernel: [    0.242341] type=2000 audit(1324757788.343:1): initialized
Dec 24 21:16:53 s1 kernel: [    0.242511] VFS: Disk quotas dquot_6.5.1
Dec 24 21:16:53 s1 kernel: [    0.242530] Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
Dec 24 21:16:53 s1 kernel: [    0.242548] msgmni has been set to 4137
Dec 24 21:16:53 s1 kernel: [    0.242607] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
Dec 24 21:16:53 s1 kernel: [    0.242613] io scheduler noop registered
Dec 24 21:16:53 s1 kernel: [    0.242616] io scheduler anticipatory registered
Dec 24 21:16:53 s1 kernel: [    0.242618] io scheduler deadline registered
Dec 24 21:16:53 s1 kernel: [    0.242625] io scheduler cfq registered (default)
Dec 24 21:16:53 s1 kernel: [    0.242815] Linux agpgart interface v0.103
Dec 24 21:16:53 s1 kernel: [    0.242841] Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
Dec 24 21:16:53 s1 kernel: [    0.243672] brd: module loaded
Dec 24 21:16:53 s1 kernel: [    0.243713] input: Macintosh mouse button emulation as /class/input/input0
Dec 24 21:16:53 s1 kernel: [    0.244040] Xen virtual console successfully installed as tty1
Dec 24 21:16:53 s1 kernel: [    0.244066] Event-channel device installed.
Dec 24 21:16:53 s1 kernel: [    0.250600] netfront: Initialising virtual ethernet driver.
Dec 24 21:16:53 s1 kernel: [    0.255926] PNP: No PS/2 controller found. Probing ports directly.
Dec 24 21:16:53 s1 kernel: [    0.264056] mice: PS/2 mouse device common for all mice
Dec 24 21:16:53 s1 kernel: [    0.264128] rtc_cmos rtc_cmos: rtc core: registered rtc_cmos as rtc0
Dec 24 21:16:53 s1 kernel: [    0.264203] No iBFT detected.
Dec 24 21:16:53 s1 kernel: [    0.264442] TCP cubic registered
Dec 24 21:16:53 s1 kernel: [    0.264446] NET: Registered protocol family 17
Dec 24 21:16:53 s1 kernel: [    0.264508] registered taskstats version 1
Dec 24 21:16:53 s1 kernel: [    0.283122] xen-vbd: registered block device major 3
Dec 24 21:16:53 s1 kernel: [    0.283133] blkfront: hda1: barriers enabled
Dec 24 21:16:53 s1 kernel: [    0.364009] XENBUS: Device with no driver: device/console/0
Dec 24 21:16:53 s1 kernel: [    0.364021] drivers/rtc/hctosys.c: unable to open rtc device (rtc0)
Dec 24 21:16:53 s1 kernel: [    0.364035] Freeing unused kernel memory: 216k freed
Dec 24 21:16:53 s1 kernel: [    0.456556] thermal: Unknown symbol acpi_processor_set_thermal_limit
Dec 24 21:16:53 s1 kernel: [    0.688385] device-mapper: uevent: version 1.0.3
Dec 24 21:16:53 s1 kernel: [    0.689121] device-mapper: ioctl: 4.13.0-ioctl (2007-10-18) initialised: dm-devel@redhat.com
Dec 24 21:16:53 s1 kernel: [    0.733138] kjournald starting.  Commit interval 5 seconds
Dec 24 21:16:53 s1 kernel: [    0.733157] EXT3-fs: mounted filesystem with ordered data mode.
Dec 24 21:16:53 s1 kernel: [    1.597700] udevd version 125 started
Dec 24 21:16:53 s1 kernel: [   12.864351] EXT3 FS on hda1, internal journal
Dec 24 21:16:53 s1 kernel: [   13.050095] Uniform Multi-Platform E-IDE driver
Dec 24 21:16:53 s1 kernel: [   13.050103] ide: Assuming 50MHz system bus speed for PIO modes; override with idebus=xx
Dec 24 21:16:53 s1 kernel: [   13.078614] ide_generic: please use "probe_mask=0x3f" module parameter for probing all legacy ISA IDE ports
Dec 24 21:16:53 s1 kernel: [   14.200721] register_blkdev: cannot get major 3 for ide0
Dec 24 21:16:53 s1 kernel: [   14.200735] ide0: failed to initialize IDE interface
Dec 24 21:16:53 s1 kernel: [   14.200749] Failed to obtain physical IRQ 15
Dec 24 21:16:53 s1 kernel: [   14.200759] ide1 at 0x170-0x177,0x376 on irq 15
Dec 24 21:16:53 s1 kernel: [   22.952324] Adding 4194296k swap on /hda2.  Priority:-1 extents:1060 across:5628416k
Dec 24 21:16:53 s1 kernel: [   24.343330] NET: Registered protocol family 10
Dec 24 21:16:53 s1 kernel: [   24.343550] lo: Disabled Privacy Extensions
Dec 24 21:16:57 s1 kernel: [   29.818221] ip_tables: (C) 2000-2006 Netfilter Core Team
Dec 24 21:16:58 s1 kernel: [   29.910982] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
Dec 24 21:17:01 s1 kernel: [   33.502472] warning: `pure-ftpd-mysql' uses 32-bit capabilities (legacy support in use)
Dec 24 21:27:51 s1 kernel: [   47.686036] mydns[1688]: segfault at 14c1a48 ip 409eb6 sp 7fff265724b0 error 4 in mydns[400000+32000]
Dec 24 21:27:51 s1 kernel: [   47.690303] mydns[3205]: segfault at 14c1a48 ip 409eb6 sp 7fff26572450 error 4 in mydns[400000+32000]
Dec 24 21:27:51 s1 kernel: [   47.694487] mydns[3206]: segfault at 14c1a48 ip 409eb6 sp 7fff26572450 error 4 in mydns[400000+32000]
Dec 24 21:27:51 s1 kernel: [   47.704291] mydns[3208]: segfault at 14c1a48 ip 409eb6 sp 7fff26572450 error 4 in mydns[400000+32000]
Dec 24 21:27:51 s1 kernel: [   47.714169] mydns[3209]: segfault at 14c1a48 ip 409eb6 sp 7fff26572450 error 4 in mydns[400000+32000]
Dec 24 21:27:51 s1 kernel: [   47.721979] mydns[3212]: segfault at 14c1a48 ip 409eb6 sp 7fff26572450 error 4 in mydns[400000+32000]
Dec 24 21:27:51 s1 kernel: [   47.733808] mydns[3214]: segfault at 14c1a48 ip 409eb6 sp 7fff26572450 error 4 in mydns[400000+32000]
Dec 24 21:27:51 s1 kernel: [   47.743663] mydns[3216]: segfault at 14c1a48 ip 409eb6 sp 7fff26572450 error 4 in mydns[400000+32000]
Dec 24 21:27:51 s1 kernel: [   47.753526] mydns[3217]: segfault at 14c1a48 ip 409eb6 sp 7fff26572450 error 4 in mydns[400000+32000]
Dec 24 21:27:51 s1 kernel: [   47.761323] mydns[3220]: segfault at 14c1a48 ip 409eb6 sp 7fff26572450 error 4 in mydns[400000+32000]
Dec 24 21:27:56 s1 kernel: [   52.685073] __ratelimit: 1123 messages suppressed
Dec 24 21:27:56 s1 kernel: [   52.685083] mydns[4386]: segfault at 14c1a48 ip 409eb6 sp 7fff26572450 error 4 in mydns[400000+32000]
Dec 24 21:28:01 s1 kernel: [   57.684987] __ratelimit: 1208 messages suppressed
Dec 24 21:28:01 s1 kernel: [   57.684998] mydns[5595]: segfault at 14c1a48 ip 409eb6 sp 7fff26572450 error 4 in mydns[400000+32000]
Dec 24 21:28:06 s1 kernel: [   62.686350] __ratelimit: 1199 messages suppressed
Dec 24 21:28:06 s1 kernel: [   62.686360] mydns[6795]: segfault at 14c1a48 ip 409eb6 sp 7fff26572450 error 4 in mydns[400000+32000]
Dec 24 21:28:11 s1 kernel: [   67.686961] __ratelimit: 1189 messages suppressed
Dec 24 21:28:11 s1 kernel: [   67.686971] mydns[7991]: segfault at 14c1a48 ip 409eb6 sp 7fff26572450 error 4 in mydns[400000+32000]
Dec 24 21:28:16 s1 kernel: [   72.688113] __ratelimit: 1208 messages suppressed
Dec 24 21:28:16 s1 kernel: [   72.688124] mydns[9201]: segfault at 14c1a48 ip 409eb6 sp 7fff26572450 error 4 in mydns[400000+32000]
Dec 24 21:30:18 s1 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
Dec 24 21:30:18 s1 pure-ftpd: (?@127.0.0.1) [INFO] Logout.
Dec 24 21:30:19 s1 kernel: [  195.757289] ip6_tables: (C) 2000-2006 Netfilter Core Team
Dec 24 21:35:01 s1 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
Dec 24 21:35:01 s1 pure-ftpd: (?@127.0.0.1) [INFO] Logout.
Dec 24 21:40:05 s1 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
Dec 24 21:40:05 s1 pure-ftpd: (?@127.0.0.1) [INFO] Logout.
Dec 24 21:45:01 s1 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
Dec 24 21:45:01 s1 pure-ftpd: (?@127.0.0.1) [INFO] Logout.
Problem is that some sites work, others not. For example i have two sites on WP with same theme and one works (http://lix.in/-b1db79) other not (http://lix.in/-a72d1c)...

What can it be wrong? I haven't found anything on internet about that. If all sites work/don't work issue is easy, but now it isn't...

Much appreciated and marry christmas to all ISPCONFIG community!!

p.s. in MAIL QUEUE i get:
-Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
DD9D842A4A1 5581 Sat Dec 24 21:04:33 DDDD@domain.tld
(connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
FFFF@domain.ltd

Last edited by vaio; 24th December 2011 at 22:59. Reason: added to p.s.
Reply With Quote
  #7  
Old 25th December 2011, 03:06
vaio vaio is offline
Member
 
Join Date: Nov 2010
Posts: 48
Thanks: 21
Thanked 1 Time in 1 Post
Default

Hello dear Falko,
i have found solution - reconfigure (update/upgrade ispconfig 3.0.4 to reconfigure services and it worked).

But i wanted to know why in first place that happened? Do you have any info or advice how not to repeat that?

Thank you,
V.
Reply With Quote
The Following User Says Thank You to vaio For This Useful Post:
falko (25th December 2011)
  #8  
Old 9th January 2012, 09:03
vaio vaio is offline
Member
 
Join Date: Nov 2010
Posts: 48
Thanks: 21
Thanked 1 Time in 1 Post
Default

Hello Falko,
again i experience that some websites don't work and others do.

Apparently we didn't find and solve whole problem.

Can you advise me what to do?
Thanks,
M.
Reply With Quote
  #9  
Old 9th January 2012, 09:14
vaio vaio is offline
Member
 
Join Date: Nov 2010
Posts: 48
Thanks: 21
Thanked 1 Time in 1 Post
 
Question

To reconfigure services do as manual update:

Quote:
cd /tmp
wget http://www.ispconfig.org/downloads/I...-stable.tar.gz
tar xvfz ISPConfig-3-stable.tar.gz
cd ispconfig3_install/install
php -q update.php

Last edited by vaio; 9th January 2012 at 09:21.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Webalizer returns no output,getnameinfo didn't return any usable information! CarbonCopy Server Operation 1 11th August 2009 04:46
Remoting frame work work with version 2.32 ??? afandino Developers' Forum 7 8th June 2009 17:23
install ispconfig2 ok site dos not work ferasfm Installation/Configuration 5 7th May 2009 21:16
Pure domain DNS doesn't work SyRenity Installation/Configuration 7 12th December 2006 13:12
Cant get any messenger program to work SimplyMepis 6.0 gtoman Technical 1 13th November 2006 16:26


All times are GMT +2. The time now is 02:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.