Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th March 2012, 02:23
shakethefloor shakethefloor is offline
Junior Member
 
Join Date: Mar 2012
Posts: 6
Thanks: 3
Thanked 0 Times in 0 Posts
Question proftpd not working on fresh ispconfig/debian install

I got an unmanaged VPS last week and before that I was completely new to Linux. I set it up with CentOS and I started to get used to that, but wanted ISPConfig installed and the recommended OS was Debian, and seen as I have no ties to CentOS I decided to switch.

I used the VPS Control Panel that I got with the VPS to reinstall the OS to Debian 5.0, and followed the Perfect Server with BIND and Dovecot tutorial (for ISPConfig 3), and hit some problems when I was at the Installing FTP part.

When it told me to restart the ftp server, it said something couldnt be found (i'm not too sure what it was, as i'm new to all this). I skipped the FTP steps as I just wanted to get everything installed, but now I can't get it working at all.

I used apt-get to remove the proftpd and used a different tutorial to install that, but it still won't start. Now i'm not sure what to remove to get rid of the new one I installed, and i'm absolutely lost on what to do with getting FTP working.

Sorry if I have missed out any information, not sure what is needed.

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 7th March 2012, 04:15
kwickcut kwickcut is offline
Senior Member
 
Join Date: Nov 2005
Location: nj usa
Posts: 223
Thanks: 14
Thanked 11 Times in 10 Posts
Default

what is the link to the howto that you used
Quote:
Originally Posted by shakethefloor View Post
followed the Perfect Server with BIND and Dovecot tutorial (for ISPConfig 3), and hit some problems when I was at the Installing FTP part.
what one did you use?
Quote:
Originally Posted by shakethefloor View Post
I used apt-get to remove the proftpd and used a different tutorial to install that, but it still won't start. Now i'm not sure what to remove to get rid of the new one I installed, and i'm absolutely lost on what to do with getting FTP working.
__________________
Operating system Ubuntu Linux 10.04.4
ISPConfig Version: 3.0.4.3
Webmin version 1.580
Kernel and CPU Linux 2.6.32-40-server on x86_64
Processor information AMD Phenom(tm) II X4 945 Processor, 4 cores
Real memory 4.0 GB total
Reply With Quote
  #3  
Old 7th March 2012, 10:30
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,751
Thanks: 840
Thanked 5,601 Times in 4,412 Posts
Default

You mix up the FTP applications here, ispconfig does not support proftpd, it uses pure-ftpd which is a different ftp server program.

The pure-ftpd installation steps are described in the perfect server tutorial. If you used a different guide to install a ftp daemon, then it will most likely not work with ispconfig. If your provider uses openvz and has capabilities disabled, then you can install pure-ftpd as described here:

http://www.faqforge.com/linux/contro...ities-enabled/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
shakethefloor (9th March 2012)
  #4  
Old 7th March 2012, 15:29
shakethefloor shakethefloor is offline
Junior Member
 
Join Date: Mar 2012
Posts: 6
Thanks: 3
Thanked 0 Times in 0 Posts
 
Thumbs up

Brilliant cheers. I can see how I got mixed up haha.

I'll try this now

Thanks

UPDATE: it worked perfectly, everything I needed was on that page, and when I was done I just gave my VPS a reboot and everything was fine, the ftp server was shown as running in the Services Monitor too.

Thanks again

Last edited by shakethefloor; 7th March 2012 at 16:05. Reason: update
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS not working on fresh install crypted Installation/Configuration 1 15th April 2010 09:16
Fresh Debian Install w/o Exim? carlosinfl Server Operation 0 26th February 2010 19:42
Fresh Install majorpayne Installation/Configuration 12 19th February 2010 15:04
ISPConfig 3.0.0.7 Beta - ProFTPd: Offline - FTP not working djh-compnet Installation/Configuration 5 27th October 2008 10:05
Fresh Install of FC4 using Perfect Install HowTo latcarf HOWTO-Related Questions 21 10th August 2005 23:55


All times are GMT +2. The time now is 20:22.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.