#1  
Old 4th January 2012, 21:32
methus methus is offline
Junior Member
 
Join Date: Jan 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Trouble viewing webpage

So, I followed the "Prefect Server" guide for Ubuntu 10.04 to a tee. I also added the appropriate DNS zone (an A record @ pointing to my IP address).

This is my problem:
When trying to access my website by domain (domain.tld) I get a 403 error stating I do not have permission to view / and the same for the errorDocument. I DO have an index.html file in the /var/www folder though, and it is set for everyone to read. If I try adding www before the domain (www.domain.tld) I can view it just fine.
When trying to access my website by public IP address, I can view my index.html in /var/www just fine.

If I add a website via ISPConfig 3 (and it therefore creates a symlink) then I can access the website it creates for me just fine through my domain (domain.tld).

What's keeping me from accessing my /var/www folder through my domain?
Reply With Quote
Sponsored Links
  #2  
Old 4th January 2012, 22:16
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 392
Thanks: 29
Thanked 58 Times in 50 Posts
Default

This is by design. See:

Code:
/etc/apache2/sites-available/ispconfig.conf
Code:
# Do not allow access to the root file system of the server for security reasons
<Directory />
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>
Reply With Quote
  #3  
Old 4th January 2012, 22:19
methus methus is offline
Junior Member
 
Join Date: Jan 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, but why would it allow me to do so using www in front of my domain? It would still be the root directory then.
Reply With Quote
  #4  
Old 4th January 2012, 22:20
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 392
Thanks: 29
Thanked 58 Times in 50 Posts
Default

Oh, wait, my bad... that's for the root of the filesystem. Let me dig a little more...

In the meantime, why not examine your log file while you visit that URL?

Code:
# tail -f -n 30 /var/www/example.com/log/error.log
Reply With Quote
  #5  
Old 4th January 2012, 22:35
methus methus is offline
Junior Member
 
Join Date: Jan 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, here's what I want basically...

I want to be able to type in my domain (domain.tld) and be able to access my site files in /var/www. I can do that currently by typing www first (www.domain.tld), but I don't want to have to do that. That's currently the only way I can access my webmail as well. There's a symlink for my webmail in /var/www, and of course I can't access it with domain.tld/webmail, because my access is denied. I CAN however access is via www.domain.tld/webmail. But, like I said, I don't want to have to use www every time.

Here's my error log from the ISPConfig 3-made site via /var/www/domain.tld:

client denied by server configuration: /var/www/domain.tld/web/webmail/index.php

Last edited by methus; 4th January 2012 at 23:26. Reason: Corrected an error on my part.
Reply With Quote
  #6  
Old 5th January 2012, 15:38
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 392
Thanks: 29
Thanked 58 Times in 50 Posts
 
Default

If you're going to use ISPConfig, why not use the website structure that ISPConfig creates?

In other words, rather than attempting to store your site's files in /var/www, why not store them in /var/www/example.com/web, as ISPConfig expects?

Or am I misunderstanding you, and your files are already in /var/www/example.com/web?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Being Spammed/Hacked/Probed not sure PLEASE HELP! kresser General 10 29th October 2010 17:25
kernel or hardware trouble ? DreamK Kernel Questions 0 8th February 2010 13:11
Postfix problem and few questions Gimly Installation/Configuration 12 7th July 2009 16:27
Trouble viewing Site chilka General 7 15th July 2006 13:31
Ethereal Trouble mcrosby Installation/Configuration 8 25th June 2006 03:50


All times are GMT +2. The time now is 23:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.