Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 21st November 2011, 00:39
denpark denpark is offline
HowtoForge Supporter
 
Join Date: Nov 2011
Location: silicon valley
Posts: 23
Thanks: 1
Thanked 0 Times in 0 Posts
Default enabled ssl for a virtualhost, now apache will not start

Hello, here's the situation:

-I have several sites on my ispconfig - all of them are using the same IP.

right now apache will not start after I enabled SSL for one of the sites.

here's the error log for apache2:

-------------------------------------------------------
Code:
[Sun Nov 20 06:25:05 2011] [notice] Digest: generating secret for digest authentication ...
[Sun Nov 20 06:25:05 2011] [notice] Digest: done
[Sun Nov 20 06:25:05 2011] [notice] Apache/2.2.20 (Ubuntu) DAV/2 SVN/1.6.12 mod_fcgid/2.3.6 PHP/5.3.6-13ubuntu3.2 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2
011-06-30) mod_ssl/2.2.20 OpenSSL/1.0.0e configured -- resuming normal operations
[Sun Nov 20 06:25:05 2011] [warn] long lost child came home! (pid 2029)
[Sun Nov 20 14:52:09 2011] [error] [client 9.9.9.9] PHP Notice:  Undefined index: login in /usr/local/ispconfig/interface/lib/classes/plugin.inc.php on li
ne 139, referer: http://mydomain.com:8080/
[Sun Nov 20 14:52:11 2011] [error] [client 9.9.9.9] PHP Notice:  Undefined offset: 3 in /usr/local/ispconfig/interface/web/dashboard/dashboard.php on line
 103, referer: http://mydomain.com:8080/index.php
[Sun Nov 20 14:52:11 2011] [error] [client 9.9.9.9] PHP Notice:  Undefined offset: 3 in /usr/local/ispconfig/interface/web/dashboard/dashboard.php on line
 103, referer: http://mydomain.com:8080/index.php
[Sun Nov 20 14:52:11 2011] [error] [client 9.9.9.9] PHP Notice:  Undefined offset: 3 in /usr/local/ispconfig/interface/web/dashboard/dashboard.php on line
 110, referer: http://mydomain.com:8080/index.php
[Sun Nov 20 14:52:11 2011] [error] [client 9.9.9.9] PHP Notice:  Undefined offset: 3 in /usr/local/ispconfig/interface/web/dashboard/dashboard.php on line
 110, referer: http://mydomain.com:8080/index.php
[Sun Nov 20 14:52:15 2011] [error] [client 9.9.9.9] PHP Notice:  Undefined index: web_id in /usr/local/ispconfig/interface/web/sites/ajax_get_json.php on
line 38, referer: http://mydomain.com:8080/index.php
[Sun Nov 20 14:52:21 2011] [error] [client 9.9.9.9] PHP Notice:  Undefined variable: page_form in /usr/local/ispconfig/interface/web/sites/web_domain_edit
.php on line 557, referer: http://mydomain.com:8080/index.php
[Sun Nov 20 14:52:21 2011] [error] [client 9.9.9.9] PHP Notice:  Trying to get property of non-object in /usr/local/ispconfig/interface/web/sites/web_doma
in_edit.php on line 557, referer: http://mydomain.com:8080/index.php
[Sun Nov 20 14:52:21 2011] [error] [client 9.9.9.9] PHP Notice:  Undefined variable: page_form in /usr/local/ispconfig/interface/web/sites/web_domain_edit
.php on line 558, referer: http://mydomain.com:8080/index.php
[Sun Nov 20 14:52:21 2011] [error] [client 9.9.9.9] PHP Notice:  Trying to get property of non-object in /usr/local/ispconfig/interface/web/sites/web_doma
in_edit.php on line 558, referer: http://mydomain.com:8080/index.php
[Sun Nov 20 14:52:21 2011] [error] [client 9.9.9.9] PHP Notice:  Undefined variable: page_form in /usr/local/ispconfig/interface/web/sites/web_domain_edit
.php on line 559, referer: http://mydomain.com:8080/index.php
[Sun Nov 20 14:52:21 2011] [error] [client 9.9.9.9] PHP Notice:  Trying to get property of non-object in /usr/local/ispconfig/interface/web/sites/web_doma
in_edit.php on line 559, referer: http://mydomain.com:8080/index.php
[Sun Nov 20 14:52:21 2011] [error] [client 9.9.9.9] PHP Notice:  Undefined variable: page_form in /usr/local/ispconfig/interface/web/sites/web_domain_edit
.php on line 560, referer: http://mydomain.com:8080/index.php
[Sun Nov 20 14:52:21 2011] [error] [client 9.9.9.9] PHP Notice:  Trying to get property of non-object in /usr/local/ispconfig/interface/web/sites/web_doma
in_edit.php on line 560, referer: http://mydomain.com:8080/index.php
[Sun Nov 20 14:52:21 2011] [error] [client 9.9.9.9] PHP Notice:  Undefined index: on_after_update in /usr/local/ispconfig/interface/lib/classes/plugin.inc
.php on line 139, referer: http://mydomain.com:8080/index.php
[Sun Nov 20 14:52:21 2011] [error] [client 9.9.9.9] PHP Notice:  Undefined index: sites:on_after_update in /usr/local/ispconfig/interface/lib/classes/plug
in.inc.php on line 139, referer: http://mydomain.com:8080/index.php
[Sun Nov 20 14:52:21 2011] [error] [client 9.9.9.9] PHP Notice:  Undefined index: sites:web_domain:on_after_update in /usr/local/ispconfig/interface/lib/c
lasses/plugin.inc.php on line 139, referer: http://mydomain.com:8080/index.php
[Sun Nov 20 14:52:29 2011] [error] [client 9.9.9.9] PHP Notice:  Undefined index: web_id in /usr/local/ispconfig/interface/web/sites/ajax_get_json.php on
line 38, referer: http://mydomain.com:8080/index.php
[Sun Nov 20 14:52:30 2011] [error] [client 9.9.9.9] PHP Notice:  Undefined variable: page_form in /usr/local/ispconfig/interface/web/sites/web_domain_edit
.php on line 557, referer: http://mydomain.com:8080/index.php
[Sun Nov 20 14:52:30 2011] [error] [client 9.9.9.9] PHP Notice:  Trying to get property of non-object in /usr/local/ispconfig/interface/web/sites/web_doma
in_edit.php on line 557, referer: http://mydomain.com:8080/index.php
[Sun Nov 20 14:52:30 2011] [error] [client 9.9.9.9] PHP Notice:  Undefined variable: page_form in /usr/local/ispconfig/interface/web/sites/web_domain_edit
.php on line 558, referer: http://mydomain.com:8080/index.php
[Sun Nov 20 14:52:30 2011] [error] [client 9.9.9.9] PHP Notice:  Trying to get property of non-object in /usr/local/ispconfig/interface/web/sites/web_doma
in_edit.php on line 558, referer: http://mydomain.com:8080/index.php
[Sun Nov 20 14:52:30 2011] [error] [client 9.9.9.9] PHP Notice:  Undefined variable: page_form in /usr/local/ispconfig/interface/web/sites/web_domain_edit
.php on line 559, referer: http://mydomain.com:8080/index.php
[Sun Nov 20 14:52:30 2011] [error] [client 9.9.9.9] PHP Notice:  Trying to get property of non-object in /usr/local/ispconfig/interface/web/sites/web_doma
in_edit.php on line 559, referer: http://mydomain.com:8080/index.php
[Sun Nov 20 14:52:30 2011] [error] [client 9.9.9.9] PHP Notice:  Undefined variable: page_form in /usr/local/ispconfig/interface/web/sites/web_domain_edit
.php on line 560, referer: http://mydomain.com:8080/index.php
[Sun Nov 20 14:52:30 2011] [error] [client 9.9.9.9] PHP Notice:  Trying to get property of non-object in /usr/local/ispconfig/interface/web/sites/web_doma
in_edit.php on line 560, referer: http://mydomain.com:8080/index.php
[Sun Nov 20 14:52:30 2011] [error] [client 9.9.9.9] PHP Notice:  Undefined index: on_after_update in /usr/local/ispconfig/interface/lib/classes/plugin.inc
.php on line 139, referer: http://mydomain.com:8080/index.php
[Sun Nov 20 14:52:30 2011] [error] [client 9.9.9.9] PHP Notice:  Undefined index: sites:on_after_update in /usr/local/ispconfig/interface/lib/classes/plug
in.inc.php on line 139, referer: http://mydomain.com:8080/index.php
---------------------------------------

any suggestions? Thanks in advance!

Dennis
__________________
System Info
  • ISP Config v3.0.4
  • Operating system: Oneiric Ubuntu Server 11.10
  • Kernel: 3.0.0-12-server
  • Processor: Dual Core AMD Athlon(tm) 4450B; 2.3 GHz, 2x512K Cache, x86_64
  • Memory: 4.0 GB
Reply With Quote
Sponsored Links
  #2  
Old 21st November 2011, 00:40
denpark denpark is offline
HowtoForge Supporter
 
Join Date: Nov 2011
Location: silicon valley
Posts: 23
Thanks: 1
Thanked 0 Times in 0 Posts
Default

just an fyi - I followed the directions for setting up SSL on a site from the manual.
__________________
System Info
  • ISP Config v3.0.4
  • Operating system: Oneiric Ubuntu Server 11.10
  • Kernel: 3.0.0-12-server
  • Processor: Dual Core AMD Athlon(tm) 4450B; 2.3 GHz, 2x512K Cache, x86_64
  • Memory: 4.0 GB
Reply With Quote
  #3  
Old 21st November 2011, 00:47
denpark denpark is offline
HowtoForge Supporter
 
Join Date: Nov 2011
Location: silicon valley
Posts: 23
Thanks: 1
Thanked 0 Times in 0 Posts
Default

here is the error log of the site that i enabled the SSL on -- it looks like it was not able to configure it?

A suggestion to resolve the issue would be great.

Code:
[Sun Nov 20 14:57:03 2011] [error] Unable to configure RSA server private key
[Sun Nov 20 14:57:03 2011] [error] SSL Library Error: 185073780 error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch

*I was able to undo / backout of the change by restoring a copy of the vhost file in /etc/apache2/sites-available/mydomain.com.vhost file.*
__________________
System Info
  • ISP Config v3.0.4
  • Operating system: Oneiric Ubuntu Server 11.10
  • Kernel: 3.0.0-12-server
  • Processor: Dual Core AMD Athlon(tm) 4450B; 2.3 GHz, 2x512K Cache, x86_64
  • Memory: 4.0 GB

Last edited by denpark; 21st November 2011 at 01:14.
Reply With Quote
  #4  
Old 21st November 2011, 09:16
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,717
Thanks: 820
Thanked 5,322 Times in 4,175 Posts
Default

The SSL certificate and key do not match. Please create a new ssl cert in ispconfig.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 21st November 2011, 11:39
denpark denpark is offline
HowtoForge Supporter
 
Join Date: Nov 2011
Location: silicon valley
Posts: 23
Thanks: 1
Thanked 0 Times in 0 Posts
Default

thanks for your response.

2 questions:

1) where in the ispconfig UI do i have to go to generate the key? the cert?

2) How can I ensue that i get the cert and key to match?

thanks,
Dennis
__________________
System Info
  • ISP Config v3.0.4
  • Operating system: Oneiric Ubuntu Server 11.10
  • Kernel: 3.0.0-12-server
  • Processor: Dual Core AMD Athlon(tm) 4450B; 2.3 GHz, 2x512K Cache, x86_64
  • Memory: 4.0 GB
Reply With Quote
  #6  
Old 21st November 2011, 12:00
denpark denpark is offline
HowtoForge Supporter
 
Join Date: Nov 2011
Location: silicon valley
Posts: 23
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I have followed the instructions in :

5.4.1 of the ispconfig 3 manual.


the issue i am having now is that, I cannot paste the content of the csr into the ssl request field in the ssl tab of the domain in isp config.

this field doesn't seem to be editable.
__________________
System Info
  • ISP Config v3.0.4
  • Operating system: Oneiric Ubuntu Server 11.10
  • Kernel: 3.0.0-12-server
  • Processor: Dual Core AMD Athlon(tm) 4450B; 2.3 GHz, 2x512K Cache, x86_64
  • Memory: 4.0 GB
Reply With Quote
  #7  
Old 21st November 2011, 12:12
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,717
Thanks: 820
Thanked 5,322 Times in 4,175 Posts
Default

Quote:
I have followed the instructions in :

5.4.1 of the ispconfig 3 manual.
Ok, that explains your problem. So you havent created the ssl certificate in ispconfig and thats why the key font match.

Normally you should create a ssl cert as decsribed in chapter 5.4. Chapter 5.4.1 is only a workaround to use existing external certificates. If you use the procedure in 5.4.1 because you have already a external cert, then you have to replace the key file and the crt file. The key mismatch error that you had happened because the key and cert that you copied to the ssl folder did not belong together or that the key or cert was not replaced.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 21st November 2011, 12:16
denpark denpark is offline
HowtoForge Supporter
 
Join Date: Nov 2011
Location: silicon valley
Posts: 23
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Hi Til - when i create the cert using the methods described in 5.4 then i get the errors described in the previous messages with apache not restarting etc.

only when i follow 5.4.1 does it work.

wiht that-- the only problem now i have left is not being able to copy the ssl request into the ssl tab of the domain ui in ispconfig panel.
__________________
System Info
  • ISP Config v3.0.4
  • Operating system: Oneiric Ubuntu Server 11.10
  • Kernel: 3.0.0-12-server
  • Processor: Dual Core AMD Athlon(tm) 4450B; 2.3 GHz, 2x512K Cache, x86_64
  • Memory: 4.0 GB
Reply With Quote
  #9  
Old 7th January 2012, 18:26
bblaha bblaha is offline
Junior Member
 
Join Date: Oct 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by till View Post
Ok, that explains your problem. So you havent created the ssl certificate in ispconfig and thats why the key font match.

Normally you should create a ssl cert as decsribed in chapter 5.4. Chapter 5.4.1 is only a workaround to use existing external certificates. If you use the procedure in 5.4.1 because you have already a external cert, then you have to replace the key file and the crt file. The key mismatch error that you had happened because the key and cert that you copied to the ssl folder did not belong together or that the key or cert was not replaced.
I do have a related question... I understand how to do that but how about people using that (regular clients?) If they save an external cert which does not match the key, the apache won't start at next restart and all pages (sites of other clients) are unavailable - apache cannot start because of RSA errors...

Is there a way how to ignore such errors and force apache to start?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Monitoring server Ubuntu wiss Installation/Configuration 7 20th November 2010 12:56
server Installation Configuration deco5003 Installation/Configuration 12 5th August 2009 12:00
Monit & Munin SamTzu HOWTO-Related Questions 1 4th May 2008 18:03
The classic MySQL connect error swggy Installation/Configuration 13 10th April 2008 21:45
CENTOS 5 Ping Problem gAnDo Server Operation 11 28th March 2008 20:58


All times are GMT +2. The time now is 12:07.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.