#1  
Old 1st January 2012, 23:06
zbuzanic zbuzanic is offline
Member
 
Join Date: Sep 2011
Location: Zagreb
Posts: 79
Thanks: 43
Thanked 20 Times in 13 Posts
Default Second server

Hi, I've finally setup another ispconfig server, and everything is working ok, except that I have this error on first(master) server when viewing server02 status:

Replication failed. Error: (client) in MySQL server: (localhost) Unknown column 'limit_openvz_vm_template' in 'field list' # SQL: REPLACE INTO client

I've upgraded both server with svn version of ispconfig.
__________________
ISPConfig -> the best open source control panel
Reply With Quote
Sponsored Links
  #2  
Old 2nd January 2012, 08:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
Default

Delete the error in the system log of the ispconfig monitor, you can find a delete button in that row and check if it appears again. If thats the case, then the database scheme on your slave is not up to date.

As a general note, please dont use svn versions on production systems, svn versions contain untested code and might not work at all or break your server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
zbuzanic (2nd January 2012)
  #3  
Old 2nd January 2012, 10:09
zbuzanic zbuzanic is offline
Member
 
Join Date: Sep 2011
Location: Zagreb
Posts: 79
Thanks: 43
Thanked 20 Times in 13 Posts
Default

Ok, I've updated with 3.0.4.1 release but I still have undone tasks (jobqueue) in my master ispconfig that produce errors. How can I delete those tasks?
__________________
ISPConfig -> the best open source control panel
Reply With Quote
  #4  
Old 2nd January 2012, 10:15
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
Default

There is nothing wrong with these tasks, the problem is the update state of the slave server as you master and slave have a different database layout at the moment so that the replication can not work anymore. Login to the slave server on the shell and execute the command:

ispconfig_update.sh

as root user on the shell and select "stable" when the updater asks you.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
zbuzanic (2nd January 2012)
  #5  
Old 2nd January 2012, 11:03
zbuzanic zbuzanic is offline
Member
 
Join Date: Sep 2011
Location: Zagreb
Posts: 79
Thanks: 43
Thanked 20 Times in 13 Posts
Default

Unfortunately, it didn't help.

"There are no updates available for ISPConfig 3.0.4.1"

I've looked into master SQL table and even on master there is no "limit_openvz_vm_template" collumn, so I guess it should be limit_openvz_vm_template_id, how to correct it in jobqueue?

ps. fixed it I've renamed table on slave, then renamed it back to original and now it's working as it should.
__________________
ISPConfig -> the best open source control panel

Last edited by zbuzanic; 2nd January 2012 at 13:01.
Reply With Quote
  #6  
Old 11th September 2014, 21:02
zbuzanic zbuzanic is offline
Member
 
Join Date: Sep 2011
Location: Zagreb
Posts: 79
Thanks: 43
Thanked 20 Times in 13 Posts
Default

Old topic, but still I'm intrigued with the same problem with every new server I add to my multi-server. Every time I add new server I have this error:

Code:
Replication failed. Error: (client) in MySQL server: (localhost) Unknown column 'limit_openvz_vm_template' in 'field list' # SQL: REPLACE INTO client (`client_id`,`sys_userid`,`sys_groupid`,`sys_perm_user`,`sys_perm_group`,`sys_perm_other`,`company_name`,`company_id`,`contact_name`,`customer_no`,`vat_id`,`street`,`zip`,`city`,`state`,`country`,`telephone`,`mobile`,`fax`,`email`,`internet`,`icq`,`notes`,`default_mailserver`,`limit_maildomain`,`limit_mailbox`,`limit_mailalias`,`limit_mailaliasdomain`,`limit_mailforward`,`limit_mailcatchall`,`limit_mailrouting`,`limit_mailfilter`,`limit_fetchmail`,`limit_mailquota`,`limit_spamfilter_wblist`,`limit_spamfilter_user`,`limit_spamfilter_policy`,`default_webserver`,`limit_web_ip`,`limit_web_domain`,`limit_web_quota`,`web_php_options`,`limit_web_subdomain`,`limit_web_aliasdomain`,`limit_ftp_user`,`limit_shell_user`,`ssh_chroot`,`limit_webdav_user`,`default_dnsserver`,`limit_dns_zone`,`limit_dns_slave_zone`,`limit_dns_record`,`default_dbserver`,`limit_database`,`limit_cron`,`limit_cron_type`,`limit_cron_frequency`,`limit_traffic_quota`,`limit_client`,`limit_mailmailinglist`,`limit_openvz_vm`,`limit_openvz_vm_template`,`parent_client_id`,`username`,`password`,`language`,`usertheme`,`template_master`,`template_additional`,`created_at`,`id_rsa`,`ssh_rsa`)
I've search on my "old" master server for string "limit_openvz_vm_template" and didn't find it anywhere (database on old and new is limit_openvz_vm_template_id) so I'm just puzzled where is that string saved and how can I fix it or change it to updated one "limit_openvz_vm_template_id".
__________________
ISPConfig -> the best open source control panel
Reply With Quote
  #7  
Old 12th September 2014, 10:40
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
 
Default

The problem is that a new slave has to resync all changes that are marked with server_id = 0 from sys_datalog to become compatibl with the master servers and one of this resync records has this non existing field.

What you can do is this:

1) make a backup of th master database
2) delete all records from sys_datalog where dbtable = 'client'.
3) Go To tools >Resync in ispconfig and select to resync all clients (only the clients, not the other items).
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
zbuzanic (12th September 2014)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Not working emails (DNS and postfix problem?) shekiman Installation/Configuration 9 1st March 2011 16:25
Getmail problem cante93 Installation/Configuration 6 20th September 2010 14:40
I don't recieve mail. privir Installation/Configuration 2 3rd June 2009 22:08
Rejecting outbound mail tristanlee85 General 11 20th May 2007 17:04
Webmail Relay Error palkat General 17 23rd April 2006 18:12


All times are GMT +2. The time now is 12:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.