Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th December 2011, 20:53
karalitani karalitani is offline
Junior Member
 
Join Date: Jan 2011
Posts: 14
Thanks: 0
Thanked 2 Times in 2 Posts
Default how to setup external mail client to send mail

i setup a server with this tutorial:

The Perfect Server - Debian Squeeze (Debian 6.0) With BIND & Courier [ISPConfig 3]

then i installed roundcube instead of the squirrelmail

i can send and recieve mail with roundcube (webmail)

but when i try to setup a desktop email client like thunderbird,
i can only receive emails i cant send them.

i believe that i have tried using the submission port,
but that doesnt work wither,

any ideas?

thanks in advance.
Reply With Quote
Sponsored Links
  #2  
Old 14th December 2011, 18:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Are there any errors in your mail log (in the /var/log/ directory)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 15th December 2011, 02:48
karalitani karalitani is offline
Junior Member
 
Join Date: Jan 2011
Posts: 14
Thanks: 0
Thanked 2 Times in 2 Posts
Default i figured it out

i had to un-comment the submission port
and add the port to the ispconfig firewall.

that enabled it.

i also came across another error after i got it working,
about the file-system when the email client connected.

i installed the gamin library

apt-get install gamin

then i restarted courier services:

find /etc/init.d/ | grep courier | while read line; do $line restart; done

and the error went away.

thanks for your quick reply falko.
Reply With Quote
The Following User Says Thank You to karalitani For This Useful Post:
falko (15th December 2011)
  #4  
Old 31st December 2011, 17:29
pier56 pier56 is offline
Member
 
Join Date: Aug 2010
Posts: 37
Thanks: 10
Thanked 4 Times in 3 Posts
Default

Hello,

The same problem happens after upgrading to squeeze, keeping ispconfig 3.0.4.1. I have a dedicated server OVH.

In /var/log/mail.log :
Dec 31 17:20:02 ks_ postfix/smtpd[7284]: connect from localhost.localdomain[127.0.0.1]
Dec 31 17:20:02 ks_ postfix/smtpd[7284]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Dec 31 17:20:02 ks_ postfix/smtpd[7284]: disconnect from localhost.localdomain[127.0.0.1]

Thanks !

Last edited by pier56; 1st January 2012 at 18:33. Reason: hiding name server
Reply With Quote
  #5  
Old 1st January 2012, 18:32
pier56 pier56 is offline
Member
 
Join Date: Aug 2010
Posts: 37
Thanks: 10
Thanked 4 Times in 3 Posts
Default

Precisions :
  • it is possible to send emails to the server
  • it is possible to send mails by smtp server from webmail
  • it is only impossible to use smtp from thunderbird
And other problem (explained in another post) : now, I can't manage emails accounts by ispconfig.


Quote:
Originally Posted by pier56 View Post
Hello,

The same problem happens after upgrading to squeeze, keeping ispconfig 3.0.4.1. I have a dedicated server OVH.

In /var/log/mail.log :
Dec 31 17:20:02 ks_ postfix/smtpd[7284]: connect from localhost.localdomain[127.0.0.1]
Dec 31 17:20:02 ks_ postfix/smtpd[7284]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Dec 31 17:20:02 ks_ postfix/smtpd[7284]: disconnect from localhost.localdomain[127.0.0.1]

Thanks !
Reply With Quote
  #6  
Old 3rd January 2012, 01:22
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 392
Thanks: 29
Thanked 58 Times in 50 Posts
 
Default

Quote:
it is possible to send emails to the server
Okay, so Dovevot/Courier/whatever is working as intended.

Quote:
it is possible to send mails by smtp server from webmail
This makes sense, given that the connection is local (no firewalls in the way, etc.)

Quote:
it is only impossible to use smtp from thunderbird
Have you even tried taking the same step as karalitani? Try un-commenting the so-called "submission port" in your Postfix configuration and restarting the Postfix service.

If the port(s) is (are) already open, then try setting your SMTP port in your email client to 587 (plaintext or STARTTLS) or 465 (SSL).
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix Timeout after DATA from some emails treeman Server Operation 13 25th September 2013 12:51
Sendig mail Error fisherofer Installation/Configuration 12 30th November 2011 07:56
ISPconfig 3.0.3.2 postfix not relaying outgoing attachments mychoice2009 Installation/Configuration 3 13th April 2011 17:42
Why did Squirrelmail, Dovecot/IMAP & Outbound mail break? websissy Technical 4 29th October 2009 22:39
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 17:39


All times are GMT +2. The time now is 08:26.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.