Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th December 2011, 14:40
parkerj parkerj is offline
Member
 
Join Date: Feb 2007
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
Default Wrong Info in vhost

I have an ISPConfig/Nginx install, and when a new site is created, in the php section of the vhost it has fastcgi_pass 127.0.0.1:9004; when it should be fastcgi_pass 127.0.0.1:9000;. I can change it manually, but it will get overwritten when changes are made and saved in the directives. How can I fix this issue? Thank you.
Reply With Quote
Sponsored Links
  #2  
Old 30th December 2011, 15:31
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Each website gets a new port as each website runs under its own user,so ispconfig is acting correctly here. The start port is set under system > website config.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 30th December 2011, 16:29
parkerj parkerj is offline
Member
 
Join Date: Feb 2007
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, but when a new website is created with a new port, I get a "ERROR 502 - Bad Gateway!" So what do I need to change or look at in order to not get this error when new websites are created? Thanks again for your help.
Reply With Quote
  #4  
Old 30th December 2011, 17:49
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Which guide did you follow to install your server?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 30th December 2011, 17:58
parkerj parkerj is offline
Member
 
Join Date: Feb 2007
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I followed the Ubuntu 11.10 guide but followed it to the point that it made sense for 10.04. I also upgraded Nginx to the latest version.
Reply With Quote
  #6  
Old 30th December 2011, 18:07
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Thats most likely the reason for your problems as the nginx implementation requires the software versions from Ubuntu 11.10 for several software packes like php, fcgiwrap,nginx and maybe others. For that reason we have not published a guide for debian 6 and Ubuntu 10.04.

If you like to use nginx with ISPConfig 3 you should use Ubuntu 11.10 as 10.04 is not supported for nginx.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 30th December 2011, 18:08
parkerj parkerj is offline
Member
 
Join Date: Feb 2007
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, thanks. My hosting doesn't yet support 11.10, but I will see if I can twist their arm.
Reply With Quote
  #8  
Old 30th December 2011, 18:27
parkerj parkerj is offline
Member
 
Join Date: Feb 2007
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
Default

@till, well hosting people are not willing to add it yet, so is there anything in the code that I can change to keep it from trying to generate new port numbers? I just bought the billing module, so I'd hate to start all over.
Reply With Quote
  #9  
Old 30th December 2011, 18:36
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Quote:
so is there anything in the code that I can change to keep it from trying to generate new port numbers?
You can do that by editing the file /usr/local/ispconfig/server/conf/nginx:vhost.conf.master. But you should be aware that all your php scripts will run under the www-data user and not the web user then, so that the system is not as secure as a normal install would be and php scripts wont be able to write to the website directories as they run under the wrong user.

But using ports is just one option, you can change the website to use sockets instead of ports in the website settings on the options tab.

Quote:
@till, well hosting people are not willing to add it yet
You dont need a insall from them as you can update your Ubuntu Linux yourself. Install a minimal Ubuntu 10.04, then update it to 11.10 before you follow the installtion guide.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 30th December 2011, 18:48
parkerj parkerj is offline
Member
 
Join Date: Feb 2007
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

sockets don't work either, but I will try your suggestion for replacing the 10.04 debs with the 11.10 debs in the source.list.
Reply With Quote
Reply

Bookmarks

Tags
fast-cgi, nginx, php5

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
F11 courier-imap fails. Nachogrande General 6 1st November 2010 17:55
Heartbeat on FreeBSD7.2 not changing to Virtual IP jodizzz Server Operation 1 15th April 2010 07:46
/home ad symlink after rsync run DreamK General 4 8th March 2010 12:44
High on Lenny - Lvm Mount Problem Serverman Technical 1 23rd June 2009 16:26
ISP Config hesitation when opening web pages frankb Installation/Configuration 7 15th December 2008 13:06


All times are GMT +2. The time now is 10:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.