Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th December 2011, 18:38
jwhimpel jwhimpel is offline
Junior Member
 
Join Date: Dec 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix - Virtual domain vs actual domain

I believe I have followed the instructions found on Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (CentOS 6.0 x86_64). In the sql tables, I have defined a domain that is my local domain and a domain that is a virtual domain. I have also defined users in each domain. Yet when email arrives addressed to my local domain, it is stored in /var/spool/mail. When email arrives addressed to the virtual domain, it is stored in /var/spool/virtual_domain/virtual_user. What might I need to do to have email addressed to my local domain stored in /var/spool/mail also?
Reply With Quote
Sponsored Links
  #2  
Old 31st December 2011, 13:08
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

Please remove your local domain from the mydestinations line in /etc/postfix/main.cf (and also from myorigin and myhostname - please use another hostname/domain).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix SMTP Auth to Dovecot Not Working -- HELP! Scratchpad Server Operation 6 12th April 2011 13:29
ftp authentication fails fooboo Installation/Configuration 34 26th March 2010 14:04
CGI and FormMail Cracklefish Installation/Configuration 17 13th October 2009 13:40
CentoS doesn't send the emails vaio1 Installation/Configuration 18 5th November 2008 17:51
postfix config jmroth Installation/Configuration 6 18th September 2005 15:58


All times are GMT +2. The time now is 16:58.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.