Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th July 2006, 17:35
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,042
Thanks: 269
Thanked 154 Times in 133 Posts
Default VMware Server on a Debian server?

Is it possible to run the "VMware Server" on a Debian Server (the server is not running any X screen thingy, and in a data center)

If so.. Can I install lets say Windows within the VMware, and access it with SSH, or any other way?
Reply With Quote
Sponsored Links
  #2  
Old 16th July 2006, 20:24
Ben Ben is offline
Moderator
 
Join Date: Jul 2006
Posts: 1,029
Thanks: 7
Thanked 62 Times in 56 Posts
Default

sure you could run any VMWare supported OS.
But Windows vai ssh I don't know...terminal service client should be the better way here...

The question is what you wanna do... fur just having virtual servers why don't you try XEN?
Reply With Quote
  #3  
Old 16th July 2006, 20:35
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,042
Thanks: 269
Thanked 154 Times in 133 Posts
Default

I would love to run a windows application on my linux server.

The application needs Windows 2k3, and thats the only reason that I still have an extra server running.
If I could install Windows 2k3 in VMware (or any other virtual OS) under Linux (not running any shell!) than there is no need for me to have the extra server!

Last edited by edge; 17th July 2006 at 01:34.
Reply With Quote
  #4  
Old 16th July 2006, 21:25
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,042
Thanks: 269
Thanked 154 Times in 133 Posts
Default

I was afraid for this..

Quote:
edge@host:~$ vmware &
[1] 3655
edge@host:~$
(vmware:3666): Gtk-WARNING **: cannot open display:

[1]+ Done vmware
edge@host:~$
I guess VMware does need a propper display :/
Reply With Quote
  #5  
Old 17th July 2006, 01:33
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,042
Thanks: 269
Thanked 154 Times in 133 Posts
Default

WOW...

After doing some more testing (and reading http://www.howtoforge.com/ubuntu_vmware_server) I got it to work!

This VMware is so nice!
Reply With Quote
  #6  
Old 24th July 2006, 20:09
d0nut d0nut is offline
Junior Member
 
Join Date: Jul 2006
Posts: 14
Thanks: 1
Thanked 0 Times in 0 Posts
Default

hi edge,
how could you install windows?
did you find a vmware image or do you have access to the cd drive?

tia
Torben
Reply With Quote
  #7  
Old 25th July 2006, 10:56
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,749
Thanks: 840
Thanked 5,601 Times in 4,412 Posts
Default

Quote:
Originally Posted by d0nut
hi edge,
how could you install windows?
did you find a vmware image or do you have access to the cd drive?
Just insert the windows CD in the CD drive on your server, then start the virtual machine and the windows setup will start automazically.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 25th July 2006, 22:21
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,042
Thanks: 269
Thanked 154 Times in 133 Posts
 
Default

Or... Make an ISO, and mout it with VMware as the CD drive.

I have now Windows 2000 and Windows 2003 running at the same time in my Debian, and as I have 8 IP's each OS is accessible by internet :-)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
php Apps email not going through palkat General 8 21st September 2011 06:35
Statistic not working mzo Installation/Configuration 49 20th April 2011 13:19
Email - Ueb-Miau mazhar Installation/Configuration 5 21st December 2005 11:01
e-mail problem!!! Debian 3.1 maroonworks Installation/Configuration 18 6th December 2005 15:42
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 03:30


All times are GMT +2. The time now is 16:26.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.