Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #31  
Old 5th January 2012, 06:18
m.xander m.xander is offline
Member
 
Join Date: Dec 2011
Posts: 81
Thanks: 5
Thanked 3 Times in 3 Posts
Default The server isn't on the LAN

Quote:
Originally Posted by imjsa View Post
some ISP don't allow loopback or whatever they call it to access your own ip even if it has a domain name...
try using the LAN ip address as the server name... instead of your chosen server name...
thanks imjsa... but the server isn't on the LAN, it's in a data centre.
Reply With Quote
Sponsored Links
  #32  
Old 5th January 2012, 14:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Code:
mh1:~# telnet urbancampsite.com 25
Trying 202.130.46.114...
Connected to urbancampsite.com.
Escape character is '^]'.
220 25612-21212.vps.digitalpacific.com.au ESMTP Postfix (Ubuntu)
ehlo localhost
250-25612-21212.vps.digitalpacific.com.au
250-PIPELINING
250-SIZE 2097152
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
quit
221 2.0.0 Bye
Connection closed by foreign host.
mh1:~# dig 25612-21212.vps.digitalpacific.com.au

; <<>> DiG 9.3.4 <<>> 25612-21212.vps.digitalpacific.com.au
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 38644
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;25612-21212.vps.digitalpacific.com.au. IN A

;; AUTHORITY SECTION:
digitalpacific.com.au.  3600    IN      SOA     ns1.digitalpacific.com.au. hostmaster.digitalpacific.com.au. 2011112501 86400 600 1209600 3600

;; Query time: 339 msec
;; SERVER: 213.133.98.98#53(213.133.98.98)
;; WHEN: Thu Jan  5 14:29:26 2012
;; MSG SIZE  rcvd: 106

mh1:~#
Your mail server identifies itself as 25612-21212.vps.digitalpacific.com.au, but there's no A record for it. Either rename your mail server or create an A record for 25612-21212.vps.digitalpacific.com.au.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #33  
Old 5th January 2012, 21:28
m.xander m.xander is offline
Member
 
Join Date: Dec 2011
Posts: 81
Thanks: 5
Thanked 3 Times in 3 Posts
Default updated A record...

... have added 25612-21212.vps.digitalpacific.com.au as an A record...
evolution still won't send from test@urbancampsite.com

The reported error was "Could not connect to urbancampsite.com: Connection refused".
Reply With Quote
  #34  
Old 5th January 2012, 22:31
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 392
Thanks: 29
Thanked 58 Times in 50 Posts
Default

Quote:
... have added 25612-21212.vps.digitalpacific.com.au as an A record...
Why can't I ping it?

Code:
Ping request could not find host 25612-21212.vps.digitalpacific.com.au. Please check the name and try again.

I can ping urbancampsite.com, though:

Code:
Pinging urbancampsite.com [202.130.46.114] with 32 bytes of data:
Reply from 202.130.46.114: bytes=32 time=262ms TTL=43
Reply from 202.130.46.114: bytes=32 time=265ms TTL=43
Reply from 202.130.46.114: bytes=32 time=255ms TTL=43
Reply from 202.130.46.114: bytes=32 time=260ms TTL=43

Ping statistics for 202.130.46.114:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 255ms, Maximum = 265ms, Average = 260ms

Last edited by cbj4074; 5th January 2012 at 22:40.
Reply With Quote
  #35  
Old 5th January 2012, 22:43
m.xander m.xander is offline
Member
 
Join Date: Dec 2011
Posts: 81
Thanks: 5
Thanked 3 Times in 3 Posts
Default

it's there...?



is there supposed to be a MX record..?
Reply With Quote
  #36  
Old 5th January 2012, 23:45
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 392
Thanks: 29
Thanked 58 Times in 50 Posts
Default

I don't use ISPConfig to manage my nameservers (they're handled by the VPS provider), but I have configured nameservers via ISPConfig before. I'm pretty sure that your DNS setup needs revision, though.

ISPConfig's DNS interface is a little confusing in one particular area: A records should include only the subdomain name (use an empty string if there is no subdomain for the record).

If I'm not mistaken, you should have a wildcard record somewhere in there (no value in the name field):

Code:
Type		Name		Data

A				1.2.3.4
A		mail		1.2.3.4
A		www		1.2.3.4
I'm not sure about NX, PTR, and NS records... maybe one of the other folks who uses bind with ISPC can comment.

Or, you could spend $5 on the manual .

Last edited by cbj4074; 5th January 2012 at 23:47. Reason: Clarified a couple of points.
Reply With Quote
  #37  
Old 5th January 2012, 23:58
m.xander m.xander is offline
Member
 
Join Date: Dec 2011
Posts: 81
Thanks: 5
Thanked 3 Times in 3 Posts
Default /etc/bind/pri.urbancampsite.com

This is the current /etc/bind/pri.urbancampsite.com

Code:
$TTL        86400
@       IN      SOA     ns1.urbancampsite.com. m.xander.urbancampsite.com. (
                        2012010605       ; serial, todays date + todays serial #
                        28800              ; refresh, seconds
                        7200              ; retry, seconds
                        604800              ; expire, seconds
                        86400 )            ; minimum, seconds
;

 86400 A        202.130.46.114
ns1.urbancampsite.com. 86400 A        202.130.46.114
ns2.urbancampsite.com. 86400 A        202.130.46.114
urbancampsite.com. 86400 A        202.130.46.114
urbancampsite.com. 86400      MX    10   urbancampsite.com.
urbancampsite.com. 86400      NS        ns1.urbancampsite.com.
urbancampsite.com. 86400      NS        ns2.urbancampsite.com.
vps.digitalpacific.com.au. 86400 A        202.130.46.114
www 86400 A        202.130.46.114

Last edited by m.xander; 6th January 2012 at 00:06.
Reply With Quote
  #38  
Old 6th January 2012, 00:18
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 392
Thanks: 29
Thanked 58 Times in 50 Posts
Default

Any chance you have Webmin installed on that server? I find it to be an essential complement to ISPConfig.

If so, you might use Webmin to check the records for problems. Within Webmin, go to Servers -> BIND DNS Server -> Check BIND Config.

Networking and DNS are not my specialty, so I'm pretty much at the limit of my usefulness here. However, I think it's safe to say that this is a DNS problem at this point.

Falko?
Reply With Quote
  #39  
Old 6th January 2012, 00:36
m.xander m.xander is offline
Member
 
Join Date: Dec 2011
Posts: 81
Thanks: 5
Thanked 3 Times in 3 Posts
Default Webmin

Quote:
Originally Posted by cbj4074 View Post
Any chance you have Webmin installed on that server? I find it to be an essential complement to ISPConfig.

If so, you might use Webmin to check the records for problems. Within Webmin, go to Servers -> BIND DNS Server -> Check BIND Config.

Networking and DNS are not my specialty, so I'm pretty much at the limit of my usefulness here. However, I think it's safe to say that this is a DNS problem at this point.

Falko?
OK.. I'll have to google it... is there an installation guide that you can recommend..?
I've only seen Webmin mentioned before, I'll start looking into it.
Reply With Quote
  #40  
Old 6th January 2012, 09:48
m.xander m.xander is offline
Member
 
Join Date: Dec 2011
Posts: 81
Thanks: 5
Thanked 3 Times in 3 Posts
 
Default Webmin installed

Webmin is now installed...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Version 1.3 of the ISPConfig 3 Manual is finally available! falko General 44 2nd December 2011 12:04
SquirrelMail login not working glenneh Installation/Configuration 13 9th April 2011 20:01
dovecot: lda: Fatal: Unknown user dpicella Installation/Configuration 1 22nd August 2010 02:59
ERROR: Connection dropped by IMAP server. [Centos 5.4, courier imap,squirrel, etc] darevil HOWTO-Related Questions 7 9th June 2010 14:49
just the last step...and it works. Postfix...need help config. ubuntusr Installation/Configuration 1 5th January 2009 09:50


All times are GMT +2. The time now is 22:00.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.