Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th December 2011, 21:43
Thang Thang is offline
Junior Member
 
Join Date: Nov 2005
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default After Updating to CentOS 6.1 php seems to be quite a pain

On some sites i get the following errors and only see white pages or error pages

PHP Warning: require(): open_basedir restriction in effect. File() is not within the allowed path(s):

Any Idea ? It did work before the update.
__________________
The world is not enough
Reply With Quote
Sponsored Links
  #2  
Old 17th December 2011, 17:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Please check the open_basedir setting on the Options tab of your websites in ISPConfig.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 18th December 2011, 13:41
Thang Thang is offline
Junior Member
 
Join Date: Nov 2005
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Doesnt look any different then before the update.

I did even try to delete it completely, but that does not seem to work.

Perhaps the problem is with the user wordpress version.
Although i would expect it to still work when doing a minor version change of cents.


I found the solution, but it does not work from ISP Config Interface for me

apc.include_once_override 0

How would i set that ?
__________________
The world is not enough

Last edited by Thang; 18th December 2011 at 14:08.
Reply With Quote
  #4  
Old 19th December 2011, 08:32
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,486
Thanks: 813
Thanked 5,256 Times in 4,121 Posts
Default

This is set in the php.ini file, on centos it should be /etc/php,ini if I remeber correctly.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 19th December 2011, 19:09
Thang Thang is offline
Junior Member
 
Join Date: Nov 2005
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Hi Till sure i know that, but i thought i would set that within the custom php.ini settings for the one vhost.

But it does not appear in the ghosts httpd.conf


Found it myself. thx
__________________
The world is not enough

Last edited by Thang; 21st December 2011 at 16:34.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Only Problems since Updating from 3.0.3.3 to 3.0.4.1 mbay General 4 17th May 2012 12:56
ubuntu and nginx delgado2061 Installation/Configuration 0 27th November 2011 23:36
Problem with services!! banzaiwebstudio.com Installation/Configuration 7 19th May 2010 21:13
Unable to install ISPConfig bdonecker Installation/Configuration 21 26th May 2009 08:20
Apache2 Freezes celtic Server Operation 31 28th May 2007 17:18


All times are GMT +2. The time now is 07:07.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.