Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th December 2011, 13:32
White White is offline
Member
 
Join Date: Apr 2008
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
Default Connecting Smart Phones To Email

Ok, now i have my popstfix sorted to i can send and receive all emails from anywhere in the world i find i cannot connect my smart phone.

I have my msoutlook setup to go fetch my emails no problem but if i try and set up an account using the same settings in my smart phone it just fails.

I have tried all manner of combinations of none/ssl/tls/combined nothing works, anyone any ideas it would be nice toi check on my server emails while out and about.
Reply With Quote
Sponsored Links
  #2  
Old 6th December 2011, 15:25
nbhadauria nbhadauria is offline
Member
 
Join Date: Aug 2010
Location: New Delhi, India
Posts: 79
Thanks: 1
Thanked 13 Times in 13 Posts
Send a message via Skype™ to nbhadauria
Default

Tell us more about your account ..

server ??
port (ssl or not) ?

user auth ?

which phone ?
__________________
Best
Nitin Bhadauria
Reply With Quote
  #3  
Old 7th December 2011, 12:45
White White is offline
Member
 
Join Date: Apr 2008
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
Default

its a debian lenny server (perfect server setup) running
postfix mysql, virtual hosts setup with amavis/ clamavis etc
port 25 / 110

my phone is an xperia 10

mail settings

user admin@mydomain.com
password ********

pop3 mail.myhost.com
stmp mail.myhost.com
Reply With Quote
  #4  
Old 7th December 2011, 12:55
nbhadauria nbhadauria is offline
Member
 
Join Date: Aug 2010
Location: New Delhi, India
Posts: 79
Thanks: 1
Thanked 13 Times in 13 Posts
Send a message via Skype™ to nbhadauria
Default

port (ssl or not) ?
__________________
Best
Nitin Bhadauria
Reply With Quote
  #5  
Old 7th December 2011, 18:02
White White is offline
Member
 
Join Date: Apr 2008
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i used this how to

http://www.howtoforge.com/virtual-us...ebian-lenny-p2

it has openssl in it and saslauthd i dont know enough about it to know wether ssl is on or off
Reply With Quote
  #6  
Old 7th December 2011, 18:12
nbhadauria nbhadauria is offline
Member
 
Join Date: Aug 2010
Location: New Delhi, India
Posts: 79
Thanks: 1
Thanked 13 Times in 13 Posts
Send a message via Skype™ to nbhadauria
Default

Check for following error in /var/log/mail.log

when you try to add account:

warning: unknown[1.2.3.4]: SASL PLAIN authentication failed: no mechanism available
*
__________________
Best
Nitin Bhadauria
Reply With Quote
  #7  
Old 7th December 2011, 22:00
SwOsHiE SwOsHiE is offline
HowtoForge Supporter
 
Join Date: Jun 2011
Location: Stockholm, Sweden
Posts: 82
Thanks: 8
Thanked 8 Times in 7 Posts
Send a message via Skype™ to SwOsHiE
Default

Be sure to check if your phone company is blocking port 25 as this is a common thing, mostly to fight spam.

I have this problem both at home and my phone, solved this by redirecting port 587 to 25 at the main router infront of the mailserver.
Reply With Quote
  #8  
Old 7th December 2011, 22:01
White White is offline
Member
 
Join Date: Apr 2008
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
Default

mail.log shows msoutlook connections and last google connection but shows nothing for the several attempts i have made from my phone.
Reply With Quote
  #9  
Old 7th December 2011, 22:04
SwOsHiE SwOsHiE is offline
HowtoForge Supporter
 
Join Date: Jun 2011
Location: Stockholm, Sweden
Posts: 82
Thanks: 8
Thanked 8 Times in 7 Posts
Send a message via Skype™ to SwOsHiE
Default

Also, I would recommend using IMAP if you can use this mode with your server. POP3 will store your emails at the local computer and will not sync it from the server to every device as IMAP does.

Maybe you know this already, but just a recommendation as I said
Reply With Quote
  #10  
Old 8th December 2011, 12:15
White White is offline
Member
 
Join Date: Apr 2008
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

would imap already be setup on my server? (having followed the howto mentioned above)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Email delivery problem - Ubuntu Karmic Koala (Ubuntu 9.10) [ISPConfig 2] qiubosu General 58 16th April 2010 12:24
Email delivery problem - Ubuntu Karmic Koala (Ubuntu 9.10) [ISPConfig 2] qiubosu Installation/Configuration 1 18th January 2010 09:21
hotmail rejects outgoing email nzimas Server Operation 3 1st May 2009 03:39
email forwarding locally consumes all resources rdells General 20 1st May 2006 19:43
Connecting email client gimhan90 Installation/Configuration 8 24th February 2006 07:36


All times are GMT +2. The time now is 23:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.