Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 14th December 2011, 17:17
Cletus Cletus is offline
Junior Member
 
Join Date: Nov 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problems with AWStats

Dear all,

I have AWStats configured on my Centos 5.7 box with ISPConfig 3 installed. After a lot of googleing i still cant get AWstats to work properly. Webalizer does work fine.

when going to the /stats directory of your site you can login and you will see the jump thingy and below that an 404 error.

I checked the daily cron thing on my server and started it manually to see error messages and i see this error message:

Code:
[root@duskwood spruitjes.org]# /usr/local/ispconfig/server/cron_daily.sh
PHP Warning:  rename(/var/www/clients/client3/web3/web/stats/awstats.spruitjes.org.html,/var/www/clients/client3/web3/web/stats/awsindex.html): No such file or directory in /usr/local/ispconfig/server/cron_daily.php on line 240
PHP Warning:  rename(/var/www/clients/client6/web8/web/stats/awstats.soosrsa.nl.html,/var/www/clients/client6/web8/web/stats/awsindex.html): No such file or directory in /usr/local/ispconfig/server/cron_daily.php on line 240
finished.
The sites are already up and running for a few weeks and with AWStats selected already longer than a day so i don't think that the 24 hour generation is the issue in this case.

Can somebody give me the golden tip?

Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 14th December 2011, 17:49
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,070
Thanks: 826
Thanked 5,396 Times in 4,240 Posts
Default

Check that the paths to the awstats scripts in ISPConfig under System > Server Config match the real paths on your server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 14th December 2011, 18:57
Cletus Cletus is offline
Junior Member
 
Join Date: Nov 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Dear Till,

Thanks for your answer, i already did some directory checking before posting this thread.

The following configuration was active:

awstats conf folder: /etc/awstats
awstats data folder: /var/lib/awstats
awstats.pl script: /usr/lib/cgi-bin/awstats.pl
awstats_buildstaticpages.pl script: /usr/share/awstats/tools/awstats_buildstaticpages.pl

This however generated the same errors as displayed above:

I changed the directories to the following ones before i posted this thread and the error messages displayed above are with this directory settings. (Standard Centos 5.7 + ISPConfig 3 installation via: http://www.howtoforge.com/perfect-se...64-ispconfig-3)

awstats conf folder: /etc/awstats
awstats data folder: /var/www/awstats
awstats.pl script: /var/www/awstats/awstats.pl
awstats_buildstaticpages.pl script: /usr/bin/awstats_buildstaticpages.pl

Can you tell me if there are any wrong path's?

Thanks!
Reply With Quote
  #4  
Old 15th December 2011, 09:15
Cletus Cletus is offline
Junior Member
 
Join Date: Nov 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

After a night of waiting i still get the 404 error

Path's should be correct as far as i know with my newbie linux knowledge

When manually executing the script the same error appears. Funny thing is though that i get a dropdownbox with the date of 2011-12 but below that the 404.

Anyone?
Reply With Quote
  #5  
Old 15th December 2011, 09:40
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,070
Thanks: 826
Thanked 5,396 Times in 4,240 Posts
Default

Please post the output of:

ls -la /usr/bin/awstats_buildstaticpages.pl

and

ls -la /usr/share/awstats/tools/awstats_buildstaticpages.pl
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 15th December 2011, 10:01
Cletus Cletus is offline
Junior Member
 
Join Date: Nov 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Dear Till,

I only can find the first one:

Code:
[root@duskwood /]# find / -name awstats_buildstaticpages.pl
/usr/bin/awstats_buildstaticpages.pl
[root@duskwood /]#
Code:
[root@duskwood /]# ls -la /usr/bin/awstats_buildstaticpages.pl
-rwxr-xr-x 1 root root 19594 Aug  4  2010 /usr/bin/awstats_buildstaticpages.pl
Code:
[root@duskwood /]# ls -la /usr/share/awstats/tools/awstats_buildstaticpages.pl
ls: /usr/share/awstats/tools/awstats_buildstaticpages.pl: No such file or directory
[root@duskwood /]#
Reply With Quote
  #7  
Old 17th December 2011, 16:15
Cletus Cletus is offline
Junior Member
 
Join Date: Nov 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Anyone?
Reply With Quote
  #8  
Old 22nd December 2011, 08:57
Donald Donald is offline
Junior Member
 
Join Date: Feb 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well I don't know how you have installed it but hope you can get some help from here - http://www.host.co.in/knowledgebase/...s-in-my-cpanel
Reply With Quote
  #9  
Old 22nd December 2011, 09:33
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,070
Thanks: 826
Thanked 5,396 Times in 4,240 Posts
Default

@Donald: Your link is for CPanel but the first poster uses ISPConfig. Cpanel is a different controlpanel.

@Cletus: The script path is fine.

Please post the output of:

ls /etc/awstats
ls -la /var/www/awstats/awstats.pl
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 22nd December 2011, 10:20
Cletus Cletus is offline
Junior Member
 
Join Date: Nov 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Hi All,

Thanks

Here are the outputs:

ls /etc/awstats (and an ls -l /etc/awstats)
Code:
[root@duskwood ~]# ls /etc/awstats
awstats.forum.wow-nerds.nl.conf     awstats.photo.guild-error.com.conf
awstats.localhost.localdomain.conf  awstats.soosrsa.nl.conf
awstats.model.conf                  awstats.spruitjes.org.conf
[root@duskwood ~]# ll /etc/awstats
total 152
-rw-r--r-- 1 root root   191 Dec 13 18:50 awstats.forum.wow-nerds.nl.conf
-rw-r--r-- 1 root root 61665 Apr  9  2011 awstats.localhost.localdomain.conf
-rw-r--r-- 1 root root 61665 Apr  9  2011 awstats.model.conf
-rw-r--r-- 1 root root   208 Dec 22 00:30 awstats.photo.guild-error.com.conf
-rw-r--r-- 1 root root   175 Dec 22 00:30 awstats.soosrsa.nl.conf
-rw-r--r-- 1 root root   184 Dec 22 00:30 awstats.spruitjes.org.conf
[root@duskwood ~]#
ls -la /var/www/awstats/awstats.pl
Code:
[root@duskwood ~]# ls -la /var/www/awstats/awstats.pl
-rwxr-xr-x 1 root root 657790 Oct 16  2010 /var/www/awstats/awstats.pl
[root@duskwood ~]#
Thanks!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
AWStats - Fix and Improvement (working) erosbk Developers' Forum 33 1st May 2012 12:04
Ispconfig + awstats on debian etch Dennis Installation/Configuration 1 19th April 2008 22:57
Management/system config/settings & /server/settings not working!! dactor Installation/Configuration 9 6th February 2008 09:11
Suse Ispconfig and AWstats shajazzi Installation/Configuration 4 15th May 2006 23:04
Empty Recycle Bin jon335 General 40 6th May 2006 11:56


All times are GMT +2. The time now is 03:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.