#1  
Old 15th July 2006, 11:11
dimas dimas is offline
Senior Member
 
Join Date: Jul 2006
Posts: 122
Thanks: 7
Thanked 25 Times in 6 Posts
Default samba and suse 10.1

I wonder if you could help me to find the information on how to properly configure samba on suse 10.1

the pc with linux is a 'server-only' pc - everything is made according to the 'perfect setup', and everything works fine

the first net adapter is connected to a 100-mbit channel from the ISP and is behind NAT - there are 10 ip addresses like 192.168.5.xxx (one main ip and nine aliases) and netmask 255.255.248.0. there is a second net card that I allocated one ip 172.16.0.40 with netmask 255.240.0.0. this second adapter is plugged into a switch. there are two more pcs (windows pcs) plugged into the same switch - they have ips 172.16.0.10 and 172.16.0.20.

all 172.16.0.xxx addresses are pinged successfully from any pc - so there is a working connection

what I basically need is to be able to share a folder on the linux pc and also to be able to read and write to any of the shared folders on the windows pcs.

all pcs are part of the same workgroup, there is no DHCP or WINS.

BUT no matter how I configure samba - the network neigborhood of both windows pcs show only the shares on the windows pcs, and the linux pc is just not there.

I realize my question is rather abstract - so I just ask where to read more about the configuration in my situation. thank you!
Reply With Quote
Sponsored Links
  #2  
Old 15th July 2006, 13:29
platd platd is offline
Member
 
Join Date: Apr 2006
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Default

move your smb.conf out of the way then setup your own along the lines of

[global]
encrypt passwords=yes
workgroup=workgroup
netbios name = FREEBSD
comment = WELCOME BLUELIGHT SERVER


[homes]
read only = No

[sharename]
path = /path/to/share
read only = No


[sharename2]
comment = Drivers Apps Docs etc
path = /path/to/share2
readonly=no

It all explains it self really then just add users with smbpasswd -a username
Thats about it.
Reply With Quote
  #3  
Old 15th July 2006, 21:44
dimas dimas is offline
Senior Member
 
Join Date: Jul 2006
Posts: 122
Thanks: 7
Thanked 25 Times in 6 Posts
 
Default

thank you, it was stupid of me really
everything started to work when I added a user and edited the 'hosts' files
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
editing samba users suse 9.2 bmayock Server Operation 0 9th June 2006 22:47
fileserver with samba enabled bmayock Installation/Configuration 2 21st May 2006 21:23


All times are GMT +2. The time now is 14:52.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.