Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th December 2011, 04:45
quest quest is offline
Junior Member
 
Join Date: Apr 2009
Posts: 6
Thanks: 0
Thanked 2 Times in 1 Post
Default 403 Error When a Site possess same domain as server

Hello,

I've recently set up Ispconfig 3 on an Ubuntu 10.04 box using the perfect server tutorial.

The Ispconfig server is called linuxserver1.domain.com. I have no problem accessing the ISpconfig control panel from this domain.

I have a website hosting a company blog at www.domain.com. domain.com should also point to this blog site.

I've set up the new site in Ispconfig and applied the www subdomain to it.

However I'm receiving a 403 error when trying to access the site.

I believe this is caused due to a conflict with the domain name of the site being identical to the domain name of Ispconfig.

I have ~10 other sites, using different domains, up and running fine.

Any suggestions are appreciated.
Reply With Quote
Sponsored Links
  #2  
Old 9th December 2011, 11:29
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Please check the outputs of
Code:
hostname
hostname -f
and the contents of /etc/hosts.

Is your server named www.domain.com (bad), or is it something like server1.domain.com (good)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 9th December 2011, 23:18
quest quest is offline
Junior Member
 
Join Date: Apr 2009
Posts: 6
Thanks: 0
Thanked 2 Times in 1 Post
Default

Hello Falko!

First I want to personally thank you for producing such a fine open source project. This world can use more open source projects such as this in all aspects of development.

output:

Code:
@linuxserver1:~$ hostname
linuxserver1.domain.com
@linuxserver1:~$ hostname -f
linuxserver1.domain.com
And /etc/hosts:

Code:
127.0.0.1 localhost
111.22.333.44  linuxserver1.domain.com linuxserver1

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

Last edited by quest; 9th December 2011 at 23:20.
Reply With Quote
  #4  
Old 10th December 2011, 12:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

This looks fine.

Can you post the www.domain.com vhost configuration?

Did you check the website's error log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 12th December 2011, 23:16
quest quest is offline
Junior Member
 
Join Date: Apr 2009
Posts: 6
Thanks: 0
Thanked 2 Times in 1 Post
Default

From /etc/apache2/sites-available/domain.com.vhost:

Code:
<Directory /var/www/domain.com>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

<VirtualHost *:80>
      DocumentRoot /var/www/domain.com/web

    ServerName domain.com
    ServerAlias www.domain.com
    ServerAdmin webmaster@domain.com

    ErrorLog /var/log/ispconfig/httpd/domain.com/error.log

    <Directory /var/www/domain.com/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
        <Files ~ '.php[s3-6]{0,1}$'>
            Order allow,deny
            Deny from all

From /var/log/ispconfig/httpd/domain.com/error.log:

Code:
[Mon Dec 12 19:56:14 2011] [error] [client 111.22.3.444] client denied by server configuration: /var/www/domain.com/web/wp-login.php
Are these what you're looking for?
Reply With Quote
  #6  
Old 13th December 2011, 01:30
quest quest is offline
Junior Member
 
Join Date: Apr 2009
Posts: 6
Thanks: 0
Thanked 2 Times in 1 Post
 
Default

SOLVED.

After reviewing the above posted domain.com.vhost It's obvious .php files are blocked.

A few options in the Ispconfig control panel have the site up and running:

php: Fast-Cgi (was disabled)[I'm not familiar with the difference between fast-cgi, CGI, modphp, or suphp - Fast-cgi seems to work so I'm sticking with it.]

CGI: unchecked(was checked).

Thanks!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with mail server and subdomains MyKE General 7 26th February 2010 11:18
ISPConfig3 Mail Warn Errors reason8 General 3 25th November 2009 14:58
problem with upgrade to 2.2.34 brianetilley Installation/Configuration 14 11th November 2009 18:22
Problems with Postfix Mysql Courier PatrickAdrichem Installation/Configuration 3 13th April 2007 16:44
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 03:30


All times are GMT +2. The time now is 04:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.