Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th December 2011, 20:23
jjonsson jjonsson is offline
Junior Member
 
Join Date: Dec 2011
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default How to change default file ?

When I install Wordpress on a website created/hosted by ISPconfig it default loads index.html.
How can i change so that it loads other files as well, for instance index.php ?
Reply With Quote
Sponsored Links
  #2  
Old 6th December 2011, 21:28
Ghostdare Ghostdare is offline
Senior Member
 
Join Date: Aug 2009
Location: Europe - Romania - Bucharest
Posts: 146
Thanks: 10
Thanked 22 Times in 22 Posts
Default

When you crate the domain automaticaly ISPConfig puts default files in it... if you want index.php to be loaded.... simply delete index.html

I think that apache reads index file in some order html, etc ...
Reply With Quote
  #3  
Old 6th December 2011, 23:09
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 392
Thanks: 29
Thanked 58 Times in 50 Posts
 
Default

Ghostdare is correct in that the simplest course of action is to delete index.html.

He's correct also in that Apache looks for index files in a particular order (index.html is the first, by default).

The DirectoryIndex directive controls the order. You can either change this value server-wide (e.g., insert the new value into /etc/apache2/httpd.conf) or for individual sites via the ISPConfig interface (Sites -> example.com -> Options, Apache Directives box).

An example would be to paste-in the following:

Code:
DirectoryIndex index.php index.shtml  index.html  index.htm
Apache looks for the files in order from left to right.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
dovecot: lda: Fatal: Unknown user dpicella Installation/Configuration 1 22nd August 2010 02:59
Cannot send or receive mail farbrorc Installation/Configuration 6 24th January 2010 11:56
High on Lenny - Lvm Mount Problem Serverman Technical 1 23rd June 2009 16:26
Undelivered Mail Returned to Sender Error202 General 5 7th May 2009 11:14
libWand.so.10 error Taxick Installation/Configuration 8 3rd May 2009 01:27


All times are GMT +2. The time now is 10:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.