#1  
Old 18th November 2011, 00:34
jessesalazar jessesalazar is offline
Junior Member
 
Join Date: Nov 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problem port 25

I've followed the tutorial perfect server ubuntu 11.04, and everything is working pretty good, But when I send a message or receive from my external account it doesn't work, because my ISP is blocking the port 25, so, I went to no-ip webpage and add an "alternate smtp" and "reflector", now I can receive message using the port 587, but when I setup the main.cf to use auth sasl, like no-ip said, sending message doesn't work. here is the setup for smtp:
Use the following settings:

Outgoing SMTP Server: smtp-auth.no-ip.com
Port Number: 3325 or 587
Username: yourdomain.com@noip-smtp
Password: <Set on No-IP.com, see above.
Defaults to your No-IP account password>

/etc/postfix/main.cf:
smtp_sasl_auth_enable = yes
relayhost = [mail.isp.example]
# Alternative form:
# relayhost = [mail.isp.example]:submission
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd

/etc/postfix/sasl_passwd:
# destination credentials
[mail.isp.example] usernameassword
# Alternative form:
# [mail.isp.example]:submission usernameassword

What else do I need to do?


Thanks
Reply With Quote
Sponsored Links
  #2  
Old 1st December 2011, 12:02
eko_taas eko_taas is offline
Member
 
Join Date: Feb 2011
Posts: 92
Thanks: 2
Thanked 12 Times in 10 Posts
Default receiving port 25 easy workaround

I found easy solution for my receiving problem (blocked port 25) from
http://www.bergek.com/2007/11/29/mak...econdary-port/

to shell (as su)
Quote:
# iptables -t nat -A PREROUTING -p tcp --dport 587 -j REDIRECT --to-ports 25
Inspired by DydDNS discounts, I took 1y for EmailGateway
Quote:
Zone Service
example.com Dyn Email Gateway to example.com:587
Also I made MX settings on domain DNS
Quote:
MX @ mx1.mailhop.org
MX @ mx2.mailhop.org
Now I should find out how to add that to ISPConfig firewall-script (that applies also on reboot...) - anyone with good advice, let me know (I found only quote old howtoforge-posts...)
Reply With Quote
  #3  
Old 7th December 2011, 04:22
eko_taas eko_taas is offline
Member
 
Join Date: Feb 2011
Posts: 92
Thanks: 2
Thanked 12 Times in 10 Posts
Default Firewall script

Could solve permanent issue based on mini-howto long time back:
http://www.howtoforge.com/forums/showthread.php?t=6209

Now I can receive and send my emails w/o ISP issues (seems that outgoing port not yet problem for them even if told so.....)
Reply With Quote
  #4  
Old 7th December 2011, 15:10
eko_taas eko_taas is offline
Member
 
Join Date: Feb 2011
Posts: 92
Thanks: 2
Thanked 12 Times in 10 Posts
 
Default now I needed smtp-relay as well

My ISP closed sending port after few trials, so now I added relay as well.

Got it running w/o pain based on
http://www.howtoforge.com/forums/sho...4&postcount=18

I am using one of my (new/extra) ISP-email-accounts just to login to ISP's smtp (as relay i.e normal ports OK).....

Now now both receiving and sending working like a charm for all server1-accounts
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
New subdomains not added to Vhosts_ispconfig.conf? kuckus General 41 1st January 2010 10:41
squid port 443 problem. abid HOWTO-Related Questions 1 26th March 2009 18:08
Mydns-ng problem, port 53 already in use. jerek Installation/Configuration 1 13th March 2009 10:27
Problem with Postfix and SMTP port 25 laidbackwebsage Installation/Configuration 10 24th February 2009 02:18
My php scripts don't send e-mail html forms. CombatGod Installation/Configuration 5 8th November 2006 11:16


All times are GMT +2. The time now is 02:55.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.