Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th November 2011, 16:38
beliashou beliashou is offline
Junior Member
 
Join Date: Nov 2011
Location: Minsk
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default How setup nginx as frontend to apache with full support for nginx ISPConfig3?

I'd like to setup nginx as frontend to apache. ISPConfig3 is full support for nginx. Should I use instruction like this or some new way?

In my ISPConfig3 Manual I didn't find nginx as frontend to apache.

PS; Centos 6 x64, ISPConfig 3.0.4.1
Reply With Quote
Sponsored Links
  #2  
Old 25th November 2011, 17:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Nginx as frontend for apache is not supported, supported are either nginx or apache. The guide you linked to does not apply to current ispconfig versions, so its likely not compatible with current ISPConfig versions.

The instructions to install ISPConfig with nginx can be found here:

http://www.howtoforge.com/perfect-se...nx-ispconfig-3

Nginx support is only tested with Ubuntu 11.10.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 26th November 2011, 10:07
beliashou beliashou is offline
Junior Member
 
Join Date: Nov 2011
Location: Minsk
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up

Oh, thanks! Our developers (user of my server) need a nginx as frontend. I have to setup it. In current version I didn't find in site template config port numbers. But I'll find it and set it up. :-)

Thank you for explination.
Reply With Quote
  #4  
Old 26th November 2011, 12:16
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

The port numbers are configured in ispconfig under System > Server IP
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 28th November 2011, 09:45
beliashou beliashou is offline
Junior Member
 
Join Date: Nov 2011
Location: Minsk
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hmm... I had no records in System > Server IP addresses. I've only one IP for my server. It in System > Server Config >Server > IP Address. But there is no deafult port on System > Server Config > Web page.

I tryed create new record for the same IP address and port 82 on System > System IP page and set the IP on Sites -> Websites page, but nothing to change and my site answer at port 80.
Reply With Quote
  #6  
Old 28th November 2011, 10:05
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Have you configured apache to listen on port 82 instead of port 80 in the httpd.conf configuration file?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 28th November 2011, 11:27
beliashou beliashou is offline
Junior Member
 
Join Date: Nov 2011
Location: Minsk
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes. Now I set up port 82 in /etc/httpd/conf/httpd.conf, restart server, but get centos-apache test page (with 80 and 82 ports), but not my site!
Reply With Quote
  #8  
Old 28th November 2011, 11:34
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Ensure that you selected the IP address and not * in the website settings of this website in ISPConfig and that port 82 is set for this IP address under System > ServerIP and that the namevirtualhost checkbox in the IP settings is enabled.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 30th November 2011, 13:14
beliashou beliashou is offline
Junior Member
 
Join Date: Nov 2011
Location: Minsk
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I think it's a bug:

Add to server ip address with ports 82,445.
Add site with this ip.

# grep VirtualHost /etc/httpd/conf/sites-available/bla-bla.by.vhost
<VirtualHost xx.xx.xx.235:80>
</VirtualHost>
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Error upgrading ispconfig to 2.2.33 version adrenalinic Installation/Configuration 20 1st October 2009 17:24
Ubuntu 8.04 server edition ISPconfig installation error malinens Installation/Configuration 4 30th July 2008 08:30
Problem installing ISPConfig on Suse10.1 nliebherr Installation/Configuration 18 14th September 2007 01:30
Another ERROR: The PHP binary coming with ISPConfig does not work properly on your sy hoopsx3 Installation/Configuration 2 29th January 2007 08:56
setup fails on debian 3.1 dtrumbower Installation/Configuration 7 7th March 2006 14:42


All times are GMT +2. The time now is 23:37.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.