Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th November 2011, 15:12
eko_taas eko_taas is offline
Member
 
Join Date: Feb 2011
Posts: 92
Thanks: 2
Thanked 12 Times in 10 Posts
Question Postfix warnings on my ISPConfig logs

My email server seems to have an issue

ISPConfig 3.0.4 / Mail-Warn - Log:
Quote:
....
Nov 17 13:30:07 server1 postfix/qmgr[28241]: warning: mail for [127.0.0.1]:10024 is using up 20000 of 20000 active queue entries
Nov 17 13:30:07 server1 postfix/qmgr[28241]: warning: you may need to reduce amavis connect and helo timeouts
Nov 17 13:30:07 server1 postfix/qmgr[28241]: warning: so that Postfix quickly skips unavailable hosts
Nov 17 13:30:07 server1 postfix/qmgr[28241]: warning: you may need to increase the main.cf minimal_backoff_time and maximal_backoff_time
Nov 17 13:30:07 server1 postfix/qmgr[28241]: warning: so that Postfix wastes less time on undeliverable mail
Nov 17 13:30:07 server1 postfix/qmgr[28241]: warning: you may need to increase the master.cf amavis process limit
Nov 17 13:30:07 server1 postfix/qmgr[28241]: warning: please avoid flushing the whole queue when you have
Nov 17 13:30:07 server1 postfix/qmgr[28241]: warning: lots of deferred mail, that is bad for performance
Nov 17 13:30:07 server1 postfix/qmgr[28241]: warning: to turn off these warnings specify: qmgr_clog_warn_time = 0
Nov 17 13:35:16 server1 postfix/qmgr[28241]: warning: mail for [127.0.0.1]:10024 is using up 20000 of 20000 active queue entries
Nov 17 13:35:16 server1 postfix/qmgr[28241]: warning: you may need to reduce amavis connect and helo timeouts
Nov 17 13:35:16 server1 postfix/qmgr[28241]: warning: so that Postfix quickly skips unavailable hosts
Nov 17 13:35:16 server1 postfix/qmgr[28241]: warning: you may need to increase the main.cf minimal_backoff_time and maximal_backoff_time
Nov 17 13:35:16 server1 postfix/qmgr[28241]: warning: so that Postfix wastes less time on undeliverable mail
Nov 17 13:35:16 server1 postfix/qmgr[28241]: warning: you may need to increase the master.cf amavis process limit
Nov 17 13:35:16 server1 postfix/qmgr[28241]: warning: please avoid flushing the whole queue when you have
Nov 17 13:35:16 server1 postfix/qmgr[28241]: warning: lots of deferred mail, that is bad for performance
Nov 17 13:35:16 server1 postfix/qmgr[28241]: warning: to turn off these warnings specify: qmgr_clog_warn_time = 0
When opening thunderbird, I get also warning
Quote:
Alert from account abc@excample.com: Filesystem notification initialization error -- contact your mail admin (check from configuration errors with the FAM/Gamin library)
ISPConfig3 Mail server (Debian squeeze) is almost empty, only existing few "Fetch emails from external POP3 / IMAP servers" making that account 3000+ emails....

Tried to google solution already w/o success

Any advice for newbee (on servers)
Reply With Quote
Sponsored Links
  #2  
Old 17th November 2011, 15:17
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,260 Times in 4,124 Posts
Default

From where do you fetch these emails? Maybe you created a mail loop by forwarding the emails or a copy of the emails back to the account where you fetch the emails from.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 17th November 2011, 15:45
eko_taas eko_taas is offline
Member
 
Join Date: Feb 2011
Posts: 92
Thanks: 2
Thanked 12 Times in 10 Posts
Default fetch mails

ISPConfig3 account abc@example.com fetches emails from 2 accounts
xyz@hotmail.com
opq@gmail.com
(This is due my ISP has blocked port 25 to server1.excample.com and is temp work-around)

There is No Mail Forward set on server1.example.com

Due some hackers on other forums, I changed email passwords for hotmail and gmail just few days back (and also on Fetch-mail-items). Also update to 3.0.4. done few days back.

Which one has caused this, cannot tell....

When opening email with roundcube / webmail, e.g. sort-by-date does not work well at all (as was working before)..
Reply With Quote
  #4  
Old 17th November 2011, 15:58
eko_taas eko_taas is offline
Member
 
Join Date: Feb 2011
Posts: 92
Thanks: 2
Thanked 12 Times in 10 Posts
Default

deactivated 30min back all mail fetch from ISPConfig3, yet still same error every 5min on "Mail-Error - Log"
Reply With Quote
  #5  
Old 22nd November 2011, 07:12
eko_taas eko_taas is offline
Member
 
Join Date: Feb 2011
Posts: 92
Thanks: 2
Thanked 12 Times in 10 Posts
Default Messages dublicated

One more: On abc@example.com mailbox setings "Send copy to " empty...

Problem seems like all mails are listed many times, some of them up to 16 times (and some "only" 8 times . This happened only after told changes....

I would not like to delete this email-box, as used as achive for hotmail and gmail accounts...

Now put also Spamfilter as "unsensored" for both email-domain and box to test if helps....
Reply With Quote
  #6  
Old 22nd November 2011, 17:00
eko_taas eko_taas is offline
Member
 
Join Date: Feb 2011
Posts: 92
Thanks: 2
Thanked 12 Times in 10 Posts
Default error with deactivated email domains

Now deactivated also all email domains and finally whole email-service (on server1), still after restart and waiting 1.5h error look like this:

Quote:
Nov 22 15:17:55 server1 postfix/smtp[6073]: warning: host Nov 22 15:17:55 server1 postfix/smtp[6073]: warning: host example.com[123.456.231.170]:25 replied to HELO/EHLO with my own hostname server1.example.com
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: mail for [127.0.0.1]:10024 is using up 20000 of 20000 active queue entries
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: you may need to reduce amavis connect and helo timeouts
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: so that Postfix quickly skips unavailable hosts
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: you may need to increase the main.cf minimal_backoff_time and maximal_backoff_time
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: so that Postfix wastes less time on undeliverable mail
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: you may need to increase the master.cf amavis process limit
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: please avoid flushing the whole queue when you have
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: lots of deferred mail, that is bad for performance
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: to turn off these warnings specify: qmgr_clog_warn_time = 0
Nov 22 15:18:37 server1 postfix/smtp[6073]: warning: host example.com[123.456.231.170]:25 greeted me with my own hostname server1.example.com
N.com[123.456.231.170]:25 replied to HELO/EHLO with my own hostname server1.Nov 22 15:17:55 server1 postfix/smtp[6073]: warning: host example.com[123.456.231.170]:25 replied to HELO/EHLO with my own hostname server1.example.com
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: mail for [127.0.0.1]:10024 is using up 20000 of 20000 active queue entries
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: you may need to reduce amavis connect and helo timeouts
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: so that Postfix quickly skips unavailable hosts
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: you may need to increase the main.cf minimal_backoff_time and maximal_backoff_time
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: so that Postfix wastes less time on undeliverable mail
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: you may need to increase the master.cf amavis process limit
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: please avoid flushing the whole queue when you have
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: lots of deferred mail, that is bad for performance
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: to turn off these warnings specify: qmgr_clog_warn_time = 0
Nov 22 15:18:37 server1 postfix/smtp[6073]: warning: host example.com[123.456.231.170]:25 greeted me with my own hostname server1.example.com
N.com
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: mail for [127.0.0.1]:10024 is using up 20000 of 20000 active queue entries
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: you may need to reduce amavis connect and helo timeouts
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: so that Postfix quickly skips unavailable hosts
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: you may need to increase the main.cf minimal_backoff_time and maximal_backoff_time
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: so that Postfix wastes less time on undeliverable mail
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: you may need to increase the master.cf amavis process limit
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: please avoid flushing the whole queue when you have
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: lots of deferred mail, that is bad for performance
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: to turn off these warnings specify: qmgr_clog_warn_time = 0
Nov 22 15:18:37 server1 postfix/smtp[6073]: warning: host Nov 22 15:17:55 server1 postfix/smtp[6073]: warning: host example.com[123.456.231.170]:25 replied to HELO/EHLO with my own hostname server1.example.com
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: mail for [127.0.0.1]:10024 is using up 20000 of 20000 active queue entries
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: you may need to reduce amavis connect and helo timeouts
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: so that Postfix quickly skips unavailable hosts
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: you may need to increase the main.cf minimal_backoff_time and maximal_backoff_time
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: so that Postfix wastes less time on undeliverable mail
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: you may need to increase the master.cf amavis process limit
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: please avoid flushing the whole queue when you have
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: lots of deferred mail, that is bad for performance
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: to turn off these warnings specify: qmgr_clog_warn_time = 0
Nov 22 15:18:37 server1 postfix/smtp[6073]: warning: host example.com[123.456.231.170]:25 greeted me with my own hostname server1.example.com
N.com[123.456.231.170]:25 greeted me with my own hostname server1.Nov 22 15:17:55 server1 postfix/smtp[6073]: warning: host example.com[123.456.231.170]:25 replied to HELO/EHLO with my own hostname server1.example.com
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: mail for [127.0.0.1]:10024 is using up 20000 of 20000 active queue entries
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: you may need to reduce amavis connect and helo timeouts
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: so that Postfix quickly skips unavailable hosts
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: you may need to increase the main.cf minimal_backoff_time and maximal_backoff_time
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: so that Postfix wastes less time on undeliverable mail
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: you may need to increase the master.cf amavis process limit
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: please avoid flushing the whole queue when you have
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: lots of deferred mail, that is bad for performance
Nov 22 15:17:55 server1 postfix/qmgr[2849]: warning: to turn off these warnings specify: qmgr_clog_warn_time = 0
Nov 22 15:18:37 server1 postfix/smtp[6073]: warning: host example.com[123.456.231.170]:25 greeted me with my own hostname server1.example.com
...
Nov 22 15:23:12 server1 postfix/smtp[6169]: warning: host example.com[123.456.231.170]:25 greeted me with my own hostname server1.example.com
Nov 22 15:23:12 server1 postfix/smtp[6169]: warning: host example.com[123.456.231.170]:25 replied to HELO/EHLO with my own hostname server1.example.com
Nov 22 15:23:17 server1 postfix/qmgr[2849]: warning: mail for [127.0.0.1]:10024 is using up 19998 of 20000 active queue entries
Nov 22 15:23:17 server1 postfix/qmgr[2849]: warning: you may need to reduce amavis connect and helo timeouts
Nov 22 15:23:17 server1 postfix/qmgr[2849]: warning: so that Postfix quickly skips unavailable hosts
Nov 22 15:23:17 server1 postfix/qmgr[2849]: warning: you may need to increase the main.cf minimal_backoff_time and maximal_backoff_time
Nov 22 15:23:17 server1 postfix/qmgr[2849]: warning: so that Postfix wastes less time on undeliverable mail
Nov 22 15:23:17 server1 postfix/qmgr[2849]: warning: you may need to increase the master.cf amavis process limit
Nov 22 15:23:17 server1 postfix/qmgr[2849]: warning: please avoid flushing the whole queue when you have
Nov 22 15:23:17 server1 postfix/qmgr[2849]: warning: lots of deferred mail, that is bad for performance
Nov 22 15:23:17 server1 postfix/qmgr[2849]: warning: to turn off these warnings specify: qmgr_clog_warn_time = 0
Nov 22 15:23:17 server1 postfix/smtp[6094]: warning: host example.com[123.456.231.170]:25 greeted me with my own hostname server1.example.com
Nov 22 15:23:17 server1 postfix/smtp[6094]: warning: host example.com[123.456.231.170]:25 replied to HELO/EHLO with my own hostname server1.example.com
Do I have to clear something (buffers or similat) before this should end?
Reply With Quote
  #7  
Old 24th November 2011, 10:09
eko_taas eko_taas is offline
Member
 
Join Date: Feb 2011
Posts: 92
Thanks: 2
Thanked 12 Times in 10 Posts
Question How to reset queue?

Have not been able to solve yet

I still assume problem is with fetch-function (tries to fetch again and again 4000 emails several times per hour?). But before I know how to reset those 20000 from buffer, I cannot e.g. create new account to archive latest emails.

How to reset / remove that queue? anyone?
Reply With Quote
  #8  
Old 28th November 2011, 18:17
eko_taas eko_taas is offline
Member
 
Join Date: Feb 2011
Posts: 92
Thanks: 2
Thanked 12 Times in 10 Posts
 
Default

Finally Google found me something to try.....

http://homepage.mac.com/filipp/files/category-7.html
and
http://ramnik.net/wp/?p=5

So I tried hard way
Quote:
#postqueue -p
....
B53664C20CF 3527 Sat Nov 26 18:56:43 getmail@server1.example.com
xyz@example.com
9584A504269 2712 Mon Nov 14 02:18:08 getmail@server1.example.com
xyz@example.com
8EB1D4C8E07 77761 Sat Nov 12 07:30:59 getmail@server1.example.com
abc@example.com
D70D84CDAA8 10181 Sat Nov 12 07:55:50 getmail@server1.example.com
xyz@example.com
9C9E74E471B 2712 Sun Nov 13 13:23:44 getmail@server1.example.com
xyz@example.com
....

# postsuper -d ALL
postsuper: Deleted: 171061 messages
#postqueue -p
Mail queue is empty
As fetch-items now "deactivated", I hope that back in business and will start one by one to see root cause (if any)...

Now mail warnings looks better
Quote:
....
Nov 28 17:03:26 server1 postfix/smtp[8235]: warning: open active BEAB94E1556: No such file or directory
Nov 28 17:03:26 server1 postfix/smtp[8235]: warning: open active C1AAA4D9D94: No such file or directory
Nov 28 17:03:26 server1 postfix/smtp[8235]: warning: open active 38F8D501114: No such file or directory
...

Last edited by eko_taas; 28th November 2011 at 18:19. Reason: added info
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting Email Working ISPConfig3 Squirrelmail and Courier etc Ian Wilson Installation/Configuration 17 19th June 2013 22:58
SquirrelMail login not working glenneh Installation/Configuration 13 9th April 2011 20:01
Mail server using Postfix, Dovecot, Mysql... Postfix virtual maps doesn't work?? tarasbuljba HOWTO-Related Questions 33 28th May 2010 14:33
Cannot send or receive mail farbrorc Installation/Configuration 6 24th January 2010 11:56
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 17:39


All times are GMT +2. The time now is 06:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.