Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th October 2011, 23:16
ngoyette ngoyette is offline
Member
 
Join Date: Sep 2011
Posts: 41
Thanks: 15
Thanked 1 Time in 1 Post
Default need webmail.domain.com --> domain.com/webmail

hello,

i would like to be able for all my domain to be able to type webmail.domain.com to redirect to /webmail/ for squirrel..


i already created a CNAME webmail.domain.com now how do i tell ispconfig to make a redirect?


thank you
Reply With Quote
Sponsored Links
  #2  
Old 6th October 2011, 08:25
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,499 Times in 4,328 Posts
Default

Add a subdomain or aliasdomain for webmail.domain.com and then create a redirect to http://domain.com/webmail on the redirect tab.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 6th October 2011, 15:46
ngoyette ngoyette is offline
Member
 
Join Date: Sep 2011
Posts: 41
Thanks: 15
Thanked 1 Time in 1 Post
Default

thank you . this is what i tried! and it give me the green page "welcome to your website"

here is my config :


and my redirect:


note that i se google for testing only ...
Reply With Quote
  #4  
Old 6th October 2011, 16:12
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,499 Times in 4,328 Posts
Default

You have added a website and not a aliasdomain or subdomain. Delete the website and then add a alisasdomain or subdomain instaed.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
ngoyette (6th October 2011)
  #5  
Old 6th October 2011, 17:17
ngoyette ngoyette is offline
Member
 
Join Date: Sep 2011
Posts: 41
Thanks: 15
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by till View Post
You have added a website and not a aliasdomain or subdomain. Delete the website and then add a alisasdomain or subdomain instaed.
for some reason, when i config this:


i get :

Forbidden
You don't have permission to access / on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
------

even if i change http://mail.lburgoyne.ca/webmail/ to http://mail.lburgoyne.ca/webmail or http://www.google.ca or http://www.google.ca/

....

thank you!!!


edit: also i see nothing in the /var/log/lburgoyne.ca error or access log ...

Last edited by ngoyette; 6th October 2011 at 20:28. Reason: error log empty
Reply With Quote
  #6  
Old 6th October 2011, 21:00
ngoyette ngoyette is offline
Member
 
Join Date: Sep 2011
Posts: 41
Thanks: 15
Thanked 1 Time in 1 Post
Default

also created a new site test.lburgoyne.ca with redirect ... still nada
now it show :
It works!

This is the default web page for this server.

The web server software is running but no content has been added, yet.
Reply With Quote
  #7  
Old 11th October 2011, 11:18
eko_taas eko_taas is offline
Member
 
Join Date: Feb 2011
Posts: 92
Thanks: 2
Thanked 12 Times in 10 Posts
Default tried and got it right....

So your http://xxxxx.yyy/webmail is working when dir. addressed?

To test your problem on my server1 I just added in ISPConfig 3.0.3.3
Sites / Aliasdomain for website / Add new aliasdomain

Domain: mail.example.com
Parent Website: ftp.example.com (any existing one is working, so pick up one)
Redirect Type: R
Redirect Path: https://example.com:8080/webmail
Auto-Subdomain: none

Active: (selected)

Note: I have extended with ssl my squeeze-server with ssl so https:// needed
- ISPConfig manual and
- http://www.howtoforge.com/extending-...ze-ispconfig-3 (only partlly applied)

now whem making request http://mail.example.com or just mail.example.com I will be redirected to https://example.com:8080/webmail

No need to create new sites etc. due this (at least in my case)

I hope some help (even if guru already answered more accurate way...)

Last edited by eko_taas; 11th October 2011 at 11:18. Reason: typos
Reply With Quote
The Following 2 Users Say Thank You to eko_taas For This Useful Post:
ngoyette (11th October 2011), till (11th October 2011)
  #8  
Old 11th October 2011, 12:00
eko_taas eko_taas is offline
Member
 
Join Date: Feb 2011
Posts: 92
Thanks: 2
Thanked 12 Times in 10 Posts
Default

Correct how-to I have used (as done before "improved" one )
http://www.howtoforge.com/easy-round...debian-squeeze
Reply With Quote
  #9  
Old 11th October 2011, 15:48
ngoyette ngoyette is offline
Member
 
Join Date: Sep 2011
Posts: 41
Thanks: 15
Thanked 1 Time in 1 Post
Default

this exactly what im doing + cname of course this is why its confusing ... there is maybe a problem with my ispconfig config?

look at what i did:


full dns record for domain im working on:


alias sub domain in sites:


something i did was wrong? because the redirect doesnt work
Reply With Quote
  #10  
Old 11th October 2011, 18:06
eko_taas eko_taas is offline
Member
 
Join Date: Feb 2011
Posts: 92
Thanks: 2
Thanked 12 Times in 10 Posts
 
Default

As I have understood (and done) there is no need to do anything on DNS-side on your org. need... At least on my system, where only one server ("server1") in ISPConfig-system.

Actually I have had no need to change DNS-settings till today (several sites, domains pointing to same IP-address).

As newbee just happy as working w/o understanding on details
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rewrite rule: webmail.domain.com to domain.com/webmail florix.net Installation/Configuration 3 21st January 2011 14:12
Management -> system config -> settings clabrown Installation/Configuration 4 24th August 2007 16:56
Management -> Server -> Settings problems merlincc Installation/Configuration 6 27th November 2006 21:57
Traffic overview in ISP Manager > ISP Site > Statistics: Overall 0.00 tom Installation/Configuration 2 23rd April 2006 14:17
Management -> Server Settings -> DNS -> Default MX doesn't work :-( ddelbia General 6 14th January 2006 14:26


All times are GMT +2. The time now is 05:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.