Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st November 2011, 00:23
Showa Showa is offline
Member
 
Join Date: Sep 2010
Posts: 59
Thanks: 3
Thanked 1 Time in 1 Post
Default Unable to send or recieve emails.

Hello to you all,

I have got a problem recieving and sending mails. I did search howtoforge and other sites for a solution, and tried to solve my problem.

My ISP is blocking port 25. So I uncomment submission, put port 587 into my router pointing to my server, put TCP 587 into the firewall of ISPConfig 3 restarted the server as proposed in multiple threads. But without succes.

Doing a portscan port 587 is open, 25 is closed. Telnetting to the port functions, but I am unable to sent and recieve mails. In the mail error log there is the remark: No route to host (port 25). Are there other settings I have to change?

With kind regards,

Ad.
Reply With Quote
Sponsored Links
  #2  
Old 1st November 2011, 07:34
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,778
Thanks: 821
Thanked 5,334 Times in 4,184 Posts
Default

Edit postfix master.cf file and remove the # in front of the submission line. Then restart postfix.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 1st November 2011, 08:13
eko_taas eko_taas is offline
Member
 
Join Date: Feb 2011
Posts: 92
Thanks: 2
Thanked 12 Times in 10 Posts
Default

I have a same issue with ISP (blocking 25).

How you plan to receive emails (or your ISP blocked only sending)? In my case sending possible via ISP's SMTP-server, so receiving (send by others*) is main issue...
Reply With Quote
  #4  
Old 1st November 2011, 08:26
Showa Showa is offline
Member
 
Join Date: Sep 2010
Posts: 59
Thanks: 3
Thanked 1 Time in 1 Post
Default

Thanks Till but editing the master file was the first thing I did.

submission inet n - n - - smtpd
-o smtpd_enforce_tls=yes
-o smtpd_sasl_auth_enable=yes
-o smtpd_client_restrictions=permit_sasl_authenticate d,reject

Or is editing only the first line sufficient?
Do I have to put my domain name in main.cf?
Reply With Quote
  #5  
Old 1st November 2011, 08:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,778
Thanks: 821
Thanked 5,334 Times in 4,184 Posts
Default

The first line is sufficient

Please be aware that enabling port 587 only means that you can send a email with a smtp client fom a external source to your server now and not that your server is able to send emails outside, as port 587 is only used for incoming messages. So please see also what eko_taas mentioned.

If your provider offers a mail relay server, then you should use that mail relay server to send emails from your server. The details for the mail relay can be set under system > server config > email
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.

Last edited by till; 1st November 2011 at 08:50.
Reply With Quote
  #6  
Old 2nd November 2011, 00:24
Showa Showa is offline
Member
 
Join Date: Sep 2010
Posts: 59
Thanks: 3
Thanked 1 Time in 1 Post
Default

For sending my e-mail I am now using a relay server. Trying this functiones on gmail.

For another account I have got the message:
Action: failed
Status: 5.6.1
Diagnostic-Code: smtp;554 5.6.1 Body type not supported by Remote Host

I'm still not able to recieve mail. I tried this with and without opening submission.

With kind regards
Ad.
Reply With Quote
  #7  
Old 2nd November 2011, 10:15
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,778
Thanks: 821
Thanked 5,334 Times in 4,184 Posts
Default

You mean you sent a email from gmail to your server and it did not arrive? If port 25 is closed, you can not recieve emails from the internet as every external server will try to connect to your server on port 25. The submission port is only used as workarount to connect with a smtp client like thunderbird to your server directly and not for receiving external emails.

To run a full mail server that receives mails directly from the internet, you need port 25 to be open from the internet to your server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 2nd November 2011, 13:53
Showa Showa is offline
Member
 
Join Date: Sep 2010
Posts: 59
Thanks: 3
Thanked 1 Time in 1 Post
Default

No I could send mails using SquirrelMail and the mailboxes I created in ISPConfig to gmail but not to another e-mail adress. Then I got a message with the diagnostic code. I solved this problem by putting: smtp_never_send_ehlo=yes in main.cf

If I understand you correctly I am unable to use for instance info@mysite.com or any other e-mailadress for my site if my ISP does block port 25.

Momentary when I use the same ISP from a different IP-adress, mail to info@mysite.com is correctly redirected to the adresses I put in customrules. Using another ISP nothing happens. So this is due to blocking port 25?
Reply With Quote
  #9  
Old 10th November 2011, 08:27
Showa Showa is offline
Member
 
Join Date: Sep 2010
Posts: 59
Thanks: 3
Thanked 1 Time in 1 Post
Default

Still strugling with my e-mail. Never give up!

My ISP is offering a way to bypass the closed port 25.

According to them I have this in my MX and A records:

mydomain.com MX 10 smpt.mydomain.com
mydomain.com MX 20 mailrelay.planet.nl
smpt.mydomain.nl A my ip-adress

So I changed the first (existing) MX record from my.domain.com. mail priority 10 to mydomain.com. smpt.mydomain.com. priority 10

and added: my.domain.com. mailrelay.planet.nl. priority 20

and put in as A record smpt.mydomain.com. my ip-adress

Still no succes. Sending no problem receiving non.
Could this work, do I have to change something else in the settings, do I have to use mail instead of smpt?

With kind regards Ad.
Reply With Quote
  #10  
Old 11th November 2011, 11:52
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

Quote:
Originally Posted by Showa View Post
According to them I have this in my MX and A records:

mydomain.com MX 10 smpt.mydomain.com
mydomain.com MX 20 mailrelay.planet.nl
smpt.mydomain.nl A my ip-adress
I think you have forgotten the trailing dots in your records. They should be as follows:

Code:
mydomain.com. MX 10 smpt.mydomain.com.
mydomain.com. MX 20 mailrelay.planet.nl.
smpt.mydomain.nl. A my ip-adress
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot login to phpmyadmin penkku HOWTO-Related Questions 1 24th February 2011 09:26
Forbidden 403; Samba access; config of maildeamon fawkes Installation/Configuration 4 14th January 2010 18:16
not able to send and recieve emails ayad HOWTO-Related Questions 14 15th September 2009 13:16
HotSaNIC domino Tips/Tricks/Mods 23 6th November 2006 05:19
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29


All times are GMT +2. The time now is 06:34.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.