Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Developers' Forum

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 24th November 2011, 00:19
Claudio.Bartolini Claudio.Bartolini is offline
Junior Member
 
Join Date: Nov 2011
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
Default Soap Error: login_error_regex

Hello everybody,

I'm trying to use "mail_user_add.php" function, but the result is...

Logged successfull. Session ID:xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
data_processing_errorlogin_error_regex<br> SOAP Error: login_error_regex

Remote user has been created successfully into ISPConfig Version 3.0.4.

The content of my "soap_config.php" file:
$username = 'MYUSERNAME';
$password = 'MYPASSWORD';
$soap_location = 'http://MYIPADDRESS/ispconfig/remote/index.php';
$soap_uri = 'http://MYIPADDRESS/ispconfig/remote/';

Any idea to solve this problem??? Thanks in advance.

Claudio
Reply With Quote
Sponsored Links
  #2  
Old 24th November 2011, 08:50
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,438
Thanks: 813
Thanked 5,209 Times in 4,085 Posts
Default

Most likely your username contains chars that are not allowed for remote usernames. Please chnage the username so that it contains only the chars a-z and numbers 0-9
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 24th November 2011, 10:01
Claudio.Bartolini Claudio.Bartolini is offline
Junior Member
 
Join Date: Nov 2011
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Uhm.... username and password contains only allowed chars...
Username "claudio" and password "claudio", got the same error...
Reply With Quote
  #4  
Old 24th November 2011, 10:07
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,438
Thanks: 813
Thanked 5,209 Times in 4,085 Posts
Default

Ok, I misinterpreted the error message. The error message is most likely related to the login field of the mail_suer_add function.

Ensure that you have set the field 'login' in the $params array. The content of this fieldis normally the email address.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 24th November 2011, 10:35
Claudio.Bartolini Claudio.Bartolini is offline
Junior Member
 
Join Date: Nov 2011
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
Lightbulb

Uhm... maybe it's me... I didn't understand how it works...
I'm just calling the mail_user_add.php example page to see if it works...

But... where is the login field?
$params = array(
'server_id' => 1,
'email' => 'hmmnoe@test.int',
'password' => 'howtoforge',
'name' => 'hmmnoe',
'uid' => 5000,
'gid' => 5000,
'maildir' => '',
'quota' => 10000000000,
'cc' => '',
'homedir' => '',
'autoresponder' => 'n',
'autoresponder_start_date' => '',
'autoresponder_end_date' => '',
'autoresponder_text' => 'hallo',
'move_junk' => 'n',
'custom_mailfilter' => 'spam',
'postfix' => 'n',
'access' => 'n',
'disableimap' => 'n',
'disablepop3' => 'n',
'disabledeliver' => 'n',
'disablesmtp' => 'n'
);

Reply With Quote
  #6  
Old 24th November 2011, 10:48
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,438
Thanks: 813
Thanked 5,209 Times in 4,085 Posts
Default

Quote:
But... where is the login field?
It is missing in the code that you posted:

'login' => 'hmmnoe@test.int',

The new parameter is required starting from ISPConfig 3.0.4. I've fixed that in the api example too.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
Claudio.Bartolini (24th November 2011)
  #7  
Old 24th November 2011, 11:25
Claudio.Bartolini Claudio.Bartolini is offline
Junior Member
 
Join Date: Nov 2011
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Great, it works!

Very happy to have found a "bug"

Thank you very much!
Reply With Quote
  #8  
Old 15th December 2011, 13:32
maumar maumar is offline
Senior Member
 
Join Date: May 2009
Location: San Costanzo (PU - Italy)
Posts: 132
Thanks: 8
Thanked 11 Times in 11 Posts
Send a message via MSN to maumar Send a message via Skype™ to maumar
Default

roundcube plugin ispconfgi3 is not compliant, too
with 3.0.4.x ispconfig
i added login line:
Code:
      'email' => $this->rcmail_inst->user->data['username'],
      'login' => $this->rcmail_inst->user->data['username'],
after email and now I am able to change password
Reply With Quote
  #9  
Old 15th December 2011, 13:49
maumar maumar is offline
Senior Member
 
Join Date: May 2009
Location: San Costanzo (PU - Italy)
Posts: 132
Thanks: 8
Thanked 11 Times in 11 Posts
Send a message via MSN to maumar Send a message via Skype™ to maumar
Default

this is the exact diff:
Code:
--- /root/roundcubemail/plugins/ispconfig3_pass/ispconfig3_pass.php     2011-10-10 06:48:08.000000000 -0400
+++ /var/www/roundcubemail/plugins/ispconfig3_pass/ispconfig3_pass.php  2011-12-15 07:26:19.000000000 -0500
@@ -70,6 +70,7 @@
 
                                        $params = array('server_id' => $mail_user[0]['server_id'],
                                                                        'email' => $this->rcmail_inst->user->data['username'],
+                                                                       'login' => $this->rcmail_inst->user->data['username'],
                                                                        'password' => $newpwd,
                                                                        'name' => $mail_user[0]['name'],
                                                                        'uid' => $mail_user[0]['uid'],
Reply With Quote
  #10  
Old 11th January 2012, 15:03
beliashou beliashou is offline
Junior Member
 
Join Date: Nov 2011
Location: Minsk
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

The same error message in forward feature. Add the same line in ispconfig3_forward.php. Works good!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Remoting: How to manage DNS zones over SOAP? Insidious615 Developers' Forum 1 8th December 2010 10:53
Talking to Exchange with SOAP rj_mayer HOWTO-Related Questions 2 12th October 2010 12:38
SOAP Error: DTD are not supported by SOAP Skprorok General 8 25th September 2009 14:29
Enable SOAP help trcinc1 Installation/Configuration 0 3rd July 2008 19:01
Strange Soap Class error using Remoting with ISPConfig 2.2.16 - Junk after XML??? bpmee General 1 13th September 2007 04:53


All times are GMT +2. The time now is 14:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.