#1  
Old 13th July 2006, 14:22
hammer hammer is offline
Junior Member
 
Join Date: Jun 2006
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default postfix smtp sasl auth problem

Hello, i am using postfix+saslauth to auth my smtp outgoing mails.
I cant login to my smtp server. POP3 i have no problem but i can only check mails with it, smtp is needed to send ones (hmpf you already know that i guess )

So here is what i have as my configs, and logs:
Quote:
- telnet log
opasnivremena saslauthd # telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 opasnivremena.com ESMTP Postfix
ehlo opasnivremena.com
250-opasnivremena.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME
Quote:
- mail log
Jul 13 15:25:25 opasnivremena saslauthd[29373]: do_auth : auth failure: [user=hammer@opasnivremena.com] [service=smtp] [realm=opasnivremena.com] [mech=shadow] [reason=Unknown]
Jul 13 15:25:25 opasnivremena postfix/smtpd[29142]: warning: SASL authentication failure: Password verification failed
Jul 13 15:25:25 opasnivremena postfix/smtpd[29142]: warning: localhost[127.0.0.1]: SASL PLAIN authentication failed
Quote:
- saslauthd conf
SASLAUTHD_OPTS="${SASLAUTH_MECH} -a shadow -r"

Quote:
- main.cf
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_sasl_local_domain = $myhostname
smtp_sasl_auth_enable = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,
permit_mynetworks,
check_relay_domains

smtp_sasl_password_maps = hash:/etc/postfix/passwd
smtp_sasl_security_options =


HELP .. i've tried all i have comed up with. ...

in addition i can auth via testsaslauthd using the same username and password as when i auth in my smtp ... but in testsaslauthd it works ... in the smtp it doesnt. ..

and another strange thing ... when i auth vie testsaslauthd it logs it as user hammer, but when i auth via outlook express it logs it as hammer at opasnivremena.com ... hammer at opasnivremena.com is not a valid user ... how can i fix this?

hm ... f**k i've removed the -r option (after reading 100 times the manual .. .to understand that it adds the domain name after the login name) and everything is OKAY now!

Last edited by hammer; 13th July 2006 at 15:25.
Reply With Quote
Sponsored Links
  #2  
Old 13th July 2006, 18:19
kanour kanour is offline
Member
 
Join Date: Jun 2006
Posts: 56
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Thank you.
This was very handy to me because I had the same issue. One more time for everyone ( I have Debian distro).

In /etc/default/saslauthd
line with: PARAMS="-m /var/spool/postfix/var/run/saslauthd -r"
has to be changed to: PARAMS="-m /var/spool/postfix/var/run/saslauthd"
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 17:58
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
SASL AUTH with postfix on Sarge keulu Server Operation 6 31st August 2006 22:49
postfix auth problem (sasl) lerra Installation/Configuration 40 10th May 2006 23:36
Suse Postfix + Dovecot + ISP Config + smtp Auth; recieving problem! fatum112 HOWTO-Related Questions 2 15th January 2006 19:03


All times are GMT +2. The time now is 05:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.