Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 18th November 2011, 12:13
ColdDoT ColdDoT is offline
Senior Member
 
Join Date: Jan 2006
Location: Netherland
Posts: 178
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to ColdDoT
Default Domains in vmail not getting correct user/group

Hello,

Thanks for the awesome system!

I got two problems however:
1) When ever i create a new mail domain and then a mailbox under that domain i get:
Code:
drwxr-xr-x 5 vmail vmail 4096 Nov 18 11:53 mailfilters
drwx------ 3 vmail vmail 4096 Nov 11 02:13 omniasoft.nl
drwx------ 3 vmail vmail 4096 Nov 17 14:20 rouwtentsilentium.nl
drwx------ 3 root  root  4096 Nov 18 11:53 test.nl
And as you know all the system around test.nl will not work because of the wrong group. I can fix this with a simple chown -HR vmail.vmail test.nl but thats not the core problem.

2) The jailkit users are not working:
Code:
Nov 18 12:01:29 server2 sshd[29978]: Accepted password for omniasoft from 192.168.1.158 port 29790 ssh2
Nov 18 12:01:29 server2 sshd[29978]: pam_unix(sshd:session): session opened for user omniasoft by (uid=0)
Nov 18 12:01:29 server2 jk_chrootsh[29983]: path /var/www/clients/client1/web1/dev/ is not owned by user 0
Nov 18 12:01:29 server2 jk_chrootsh[29983]: path /var/www/clients/client1/web1/dev/ is not owned by group 0
Nov 18 12:01:29 server2 jk_chrootsh[29983]: abort, /var/www/clients/client1/web1 is not a safe chroot jail.
Nov 18 12:01:29 server2 sshd[29978]: pam_unix(sshd:session): session closed for user omniasoft
However when i disable Jailkit on the account it obvious works!

I did install Jailkit before ISPConfig. So what happening? Or do you say remove everything make a backup from the db, reinstall everything restore db backup?

Thanks in advance,

ColdDoT
__________________
2B or not 2B (a pro)
Reply With Quote
Sponsored Links
  #2  
Old 18th November 2011, 12:15
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,982 Times in 3,903 Posts
Default

Both problems are known (reported in the bugtracker) and already solved in ISPConfig 3.0.4.1.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 18th November 2011, 12:17
ColdDoT ColdDoT is offline
Senior Member
 
Join Date: Jan 2006
Location: Netherland
Posts: 178
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to ColdDoT
Default

Aaa i see, couldent find the problems in the bugtracker, but i will try out RC1 then.

Thanks
__________________
2B or not 2B (a pro)
Reply With Quote
  #4  
Old 18th November 2011, 12:21
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,982 Times in 3,903 Posts
 
Default

The new ispconfig version will take care that these problems dont happen again, but I'am not sure if the can correct the problem automatically without recreating the affected website. For the vmail problem, run:

chown -R vmail:vmail /var/vmail

and for the jailkit problem:

chown root:root /var/www/clients/client1/web1/dev

to fix the existing web.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
mailbox structure crypted General 8 26th July 2012 20:22
dovecot permission problems frankkahle Installation/Configuration 5 3rd November 2011 15:52
what should be in a vmail folder? crypted General 9 29th October 2010 22:15
Postfix not receive but send mail !!! mixian Installation/Configuration 22 4th August 2010 09:31
Exim Gateway with mailwatch (Unable to receive emails) siul0_0 HOWTO-Related Questions 10 8th May 2009 23:00


All times are GMT +2. The time now is 18:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.