Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th November 2011, 06:39
xemox xemox is offline
Junior Member
 
Join Date: Nov 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default [ERROR] Courier IMAP : s_connect() failed: No such file or directory

Guide followed : http://www.howtoforge.com/perfect-se...64-ispconfig-3

testing stage:
I. use authtest script
Code:
$ sudo authtest -s smtps  user@domain.tld validpassword

Nov 13 08:20:39 server authdaemond: received auth request, service=smtps, authtype=login
Nov 13 08:20:39 server authdaemond: authmysql: trying this module
Nov 13 08:20:39 server authdaemond: SQL query: SELECT email, password, "", uid, gid, "/var/vmail", maildir, quota, "", concat('disableimap=',disableimap,',disablepop3=',disablepop3) FROM mail_user WHERE email = 'user@domain.tld'
Nov 13 08:20:39 server authdaemond: password matches successfully
Nov 13 08:20:39 server authdaemond: authmysql: sysusername=<null>, sysuserid=5000, sysgroupid=5000, homedir=/var/vmail, address=user@domain.tld, fullname=<null>, maildir=/var/vmail/domain.tld/admin, quota=0, options=disableimap=n,disablepop3=n
Nov 13 08:20:39 server authdaemond: Authenticated: sysusername=<null>, sysuserid=5000, sysgroupid=5000, homedir=/var/vmail, address=user@domain.tld, fullname=<null>, maildir=/var/vmail/domain.tld/admin, quota=0, options=disableimap=n,disablepop3=n
Code:
$ sudo authtest -s pop3s  user@domain.tld validpassword

Nov 13 08:20:44 server authdaemond: received auth request, service=pop3s, authtype=login
Nov 13 08:20:44 server authdaemond: authmysql: trying this module
Nov 13 08:20:44 server authdaemond: SQL query: SELECT email, password, "", uid, gid, "/var/vmail", maildir, quota, "", concat('disableimap=',disableimap,',disablepop3=',disablepop3) FROM mail_user WHERE email = 'user@domain.tld'
Nov 13 08:20:44 server authdaemond: password matches successfully
Nov 13 08:20:44 server authdaemond: authmysql: sysusername=<null>, sysuserid=5000, sysgroupid=5000, homedir=/var/vmail, address=user@domain.tld, fullname=<null>, maildir=/var/vmail/domain.tld/admin, quota=0, options=disableimap=n,disablepop3=n
Nov 13 08:20:44 server authdaemond: Authenticated: sysusername=<null>, sysuserid=5000, sysgroupid=5000, homedir=/var/vmail, address=user@domain.tld, fullname=<null>, maildir=/var/vmail/domain.tld/admin, quota=0, options=disableimap=n,disablepop3=n
Code:
$ sudo authtest -s imaps  user@domain.tld validpassword

Nov 13 08:20:54 server authdaemond: received auth request, service=imaps, authtype=login
Nov 13 08:20:54 server authdaemond: authmysql: trying this module
Nov 13 08:20:54 server authdaemond: SQL query: SELECT email, password, "", uid, gid, "/var/vmail", maildir, quota, "", concat('disableimap=',disableimap,',disablepop3=',disablepop3) FROM mail_user WHERE email = 'user@domain.tld'
Nov 13 08:20:54 server authdaemond: password matches successfully
Nov 13 08:20:54 server authdaemond: authmysql: sysusername=<null>, sysuserid=5000, sysgroupid=5000, homedir=/var/vmail, address=user@domain.tld, fullname=<null>, maildir=/var/vmail/domain.tld/admin, quota=0, options=disableimap=n,disablepop3=n
Nov 13 08:20:54 server authdaemond: Authenticated: sysusername=<null>, sysuserid=5000, sysgroupid=5000, homedir=/var/vmail, address=user@domain.tld, fullname=<null>, maildir=/var/vmail/domain.tld/admin, quota=0, options=disableimap=n,disablepop3=n

II. telnet / openssl
Code:
$ openssl s_client -connect 127.0.0.1:993
a login user@domain.tld validpassword


Nov 13 08:11:23 server imapd-ssl: Connection, ip=[::ffff:127.0.0.1]
Nov 13 08:11:53 server imapd-ssl: authdaemon: s_connect() failed: No such file or directory
Nov 13 08:11:53 server imapd-ssl: LOGIN FAILED, user=user@domain.tld, ip=[::ffff:127.0.0.1]
Nov 13 08:11:53 server imapd-ssl: authentication error: No such file or directory

III. Found some clue
Code:
 
  any user run 'authtest' command will fail even a root, with 2 kind of reason:
  1. No suche file or directory
  2. Permission denied
Code:
 any user run 'authtest' command using 'sudo' will succeed

IV. It's file permission problem and I have no idea to fix this

Last edited by xemox; 13th November 2011 at 11:50. Reason: Found some clue
Reply With Quote
Sponsored Links
  #2  
Old 14th November 2011, 09:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

You must send an email to a new account first before you can fetch emails. The necessary directories will be created automatically when the first mail arrives.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 14th November 2011, 12:03
xemox xemox is offline
Junior Member
 
Join Date: Nov 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i did that too. sending an email to user@domain.tld.

as i report on clue part, it is permission problem.
Reply With Quote
  #4  
Old 15th November 2011, 14:29
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Can you post an excerpt fro your mail log when you try to send a mail to that account?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 15th November 2011, 16:04
xemox xemox is offline
Junior Member
 
Join Date: Nov 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Log (receive and auth)
Code:
Nov 15 17:59:06 server authdaemond: received userid lookup request: user@domain.tld
Nov 15 17:59:06 server authdaemond: authmysql: trying this module
Nov 15 17:59:06 server authdaemond: authmysqllib: connected. Versions: header 50152, client 50152, server 50152
Nov 15 17:59:06 server authdaemond: SQL query: SELECT email, password, "", uid, gid, "/var/vmail", maildir, quota, "", concat('disableimap=',disableimap,',disablepop3=',disablepop3) FROM mail_user WHERE email = 'user@domain.tld'
Nov 15 17:59:06 server authdaemond: Authenticated: sysusername=<null>, sysuserid=5000, sysgroupid=5000, homedir=/var/vmail, address=user@domain.tld, fullname=<null>, maildir=/var/vmail/domain.tld/x, quota=0, options=disableimap=n,disablepop3=n
Nov 15 17:59:06 server postfix/pipe[7961]: 666AC14588702: to=<user@domain.tld>, relay=maildrop, delay=0.36, delays=0.06/0.02/0/0.27, dsn=2.0.0, status=sent (delivered via maildrop service)
Nov 15 17:59:06 server postfix/qmgr[1283]: 666AC14588702: removed
Nov 15 18:00:41 server imapd: Connection, ip=[::ffff:127.0.0.1]
Nov 15 18:00:41 server imapd: authdaemon: s_connect() failed: No such file or directory
Nov 15 18:00:41 server imapd: LOGIN FAILED, user=user@domain.tld, ip=[::ffff:127.0.0.1]
Nov 15 18:00:41 server imapd: authentication error: No such file or directory
Reply With Quote
  #6  
Old 16th November 2011, 19:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Did you create the email account though ISPConfig?

Is SELinux disabled?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 17th November 2011, 05:58
xemox xemox is offline
Junior Member
 
Join Date: Nov 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Did you create the email account though ISPConfig?
-> No
Is SELinux disabled?
-> No
Code:
 
server ~: sudo  find /etc/ -name selinux -ls
server ~:
Reply With Quote
  #8  
Old 17th November 2011, 14:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Quote:
Originally Posted by xemox View Post
Did you create the email account though ISPConfig?
-> No
Is SELinux disabled?
-> No
Code:
 
server ~: sudo  find /etc/ -name selinux -ls
server ~:
But the tutorial is for preparing a server for the installation of ISPConfig, and SELinux must be disabled.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 17th November 2011, 15:29
xemox xemox is offline
Junior Member
 
Join Date: Nov 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I can not disable selinux because no selinux installed
Code:
server ~: sudo  find /etc/ -name selinux -ls
server ~:
Reply With Quote
  #10  
Old 18th November 2011, 10:55
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
 
Default

Take a look at chapter 6 on http://www.howtoforge.com/perfect-se...ispconfig-3-p3
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I can't finish install due a problem Sam9999 Installation/Configuration 7 17th September 2010 22:33
Install failure -- Apache 1.3 missing? Allen15 Installation/Configuration 11 24th February 2009 09:53
can't help ispconfig to install please help steve51184 Installation/Configuration 17 20th February 2009 10:37
rewrite url not work apache2+mod_rewrite mohamedtah Installation/Configuration 1 31st January 2009 13:00
ISP Config hesitation when opening web pages frankb Installation/Configuration 7 15th December 2008 13:06


All times are GMT +2. The time now is 03:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.