#1  
Old 7th November 2011, 14:14
louitz louitz is offline
Junior Member
 
Join Date: Oct 2011
Posts: 23
Thanks: 1
Thanked 3 Times in 3 Posts
Default needed: default

Ubuntu 10.04
ISPconfig 3033

I broke the file /etc/apache2/sites-enabled/000-ispconfig.vhost without having made a backup of it, my bad!

I wanted to bind the control panel to one particular domain and messed up the file, apache2 won't start anymore.

Cpuld someone please post the content of the file:
/etc/apache2/sites-enabled/000-ispconfig.vhost

So I can restore it?

thanks
Reply With Quote
Sponsored Links
  #2  
Old 7th November 2011, 14:27
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,486
Thanks: 813
Thanked 5,256 Times in 4,121 Posts
Default

Code:
######################################################
# This virtual host contains the configuration
# for the ISPConfig controlpanel
######################################################

NameVirtualHost *:8080

<VirtualHost _default_:8080>
  ServerAdmin webmaster@localhost
  
  <IfModule mod_fcgid.c>
    DocumentRoot /var/www/ispconfig/
    SuexecUserGroup ispconfig ispconfig
    <Directory /var/www/ispconfig/>
      Options Indexes FollowSymLinks MultiViews +ExecCGI
      AllowOverride AuthConfig Indexes Limit Options FileInfo
      AddHandler fcgid-script .php
      FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
      Order allow,deny
      Allow from all
    </Directory>
  </IfModule>
  
  <IfModule mod_php5.c>
    DocumentRoot /usr/local/ispconfig/interface/web/
    AddType application/x-httpd-php .php
    <Directory /usr/local/ispconfig/interface/web>
      Options FollowSymLinks
      AllowOverride None
      Order allow,deny
      Allow from all
	  php_value magic_quotes_gpc        0
    </Directory>
  </IfModule>
  
  # ErrorLog /var/log/apache2/error.log
  # CustomLog /var/log/apache2/access.log combined
  ServerSignature Off
  
  <IfModule mod_security2.c>
    SecRuleEngine Off
  </IfModule>

  # SSL Configuration
  # SSLEngine On
  # SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
  # SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key

</VirtualHost>

<Directory /var/www/php-cgi-scripts>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

<Directory /var/www/php-fcgi-scripts>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 7th November 2011, 14:46
louitz louitz is offline
Junior Member
 
Join Date: Oct 2011
Posts: 23
Thanks: 1
Thanked 3 Times in 3 Posts
Default

Thanks till, I matched your file to the file I have, and get this error:

apache2: Syntax error on line 236 of /etc/apache2/apache2.conf: Syntax error on line 10 of /etc/apache2/sites-enabled/000-ispconfig.vhost: </VirtualHost without matching <VirtualHost section

I appreciate the help
Reply With Quote
  #4  
Old 7th November 2011, 14:54
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,486
Thanks: 813
Thanked 5,256 Times in 4,121 Posts
Default

What is in line 10 of your file?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 7th November 2011, 15:06
louitz louitz is offline
Junior Member
 
Join Date: Oct 2011
Posts: 23
Thanks: 1
Thanked 3 Times in 3 Posts
Default

Hey till,
The situation changed now after moving the original file away and created an empty file and pasted your config in there.
At the moment apache2 starts, but the control panel at port 8080 is not reachable.
I did this as root, perhaps a permission issue?!
Reply With Quote
  #6  
Old 7th November 2011, 15:08
louitz louitz is offline
Junior Member
 
Join Date: Oct 2011
Posts: 23
Thanks: 1
Thanked 3 Times in 3 Posts
Default

Quote:
Originally Posted by louitz View Post
Hey till,
The situation changed now after moving the original file away and created an empty file and pasted your config in there.
At the moment apache2 starts, but the control panel at port 8080 is not reachable.
I did this as root, perhaps a permission issue?!
root@cosa2:/etc/apache2/sites-available# ls -al
total 36
drwxr-xr-x 2 root root 4096 Nov 7 12:57 .
drwxr-xr-x 7 root root 4096 Oct 18 20:23 ..
-rw-r--r-- 1 root root 1022 Nov 2 15:35 apps.vhost
-rw-r--r-- 1 root root 948 Nov 18 2010 default
-rw-r--r-- 1 root root 7467 Nov 18 2010 default-ssl
-rw-r--r-- 1 root root 1248 Nov 2 15:25 ispconfig.conf
-rw-r--r-- 1 root root 1677 Nov 7 14:40 ispconfig.vhost
-rw-r--r-- 1 root root 1701 Nov 7 12:54 ispconfig.vhost~
Reply With Quote
  #7  
Old 7th November 2011, 17:27
louitz louitz is offline
Junior Member
 
Join Date: Oct 2011
Posts: 23
Thanks: 1
Thanked 3 Times in 3 Posts
Default

Apache starts without errors now, webmail is up etc, but cannot get the admin page to pop up anymore.

removed in sites-enabled the file 000-ispconfig.vhost
then run a2ensite ispconfig.vhost (for sites available)
reloaded and restarted apache2 without errors, and no admin page at port 8080.
Then rebooted just to be sure, but no luck.

Would like some help, I have not done any config in ISPconfig so I can still reinstall or something like that if that could solve the issue of not being able to view the console panel webpage. <edit> If you could give me the right procedure for a reinstall

many thanks,

louis

Last edited by louitz; 7th November 2011 at 17:30.
Reply With Quote
  #8  
Old 7th November 2011, 17:29
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,486
Thanks: 813
Thanked 5,256 Times in 4,121 Posts
Default

Which exact error message do you get when you enter:

http://192.169.0.1:8080 in your browser. Replace 192.169.0.1 with the IP address of your server, not the hostname.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 7th November 2011, 17:34
louitz louitz is offline
Junior Member
 
Join Date: Oct 2011
Posts: 23
Thanks: 1
Thanked 3 Times in 3 Posts
Default

Unable to connect







Firefox can't establish a connection to the server at [iwilltellyoutheipinprivateifyouwantmeto]:8080.





The site could be temporarily unavailable or too busy. Try again in a few
moments.
If you are unable to load any pages, check your computer's network
connection.
If your computer or network is protected by a firewall or proxy, make sure
that Firefox is permitted to access the Web.
Reply With Quote
  #10  
Old 7th November 2011, 17:43
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,486
Thanks: 813
Thanked 5,256 Times in 4,121 Posts
 
Default

Ok. Maybe the easier way to fix this is to use the ispconfig updater.

Please follow the manual update instructions as described here:

http://www.howtoforge.com/forums/showthread.php?t=54735

and choose yes when the updater asks you if services shall be reconfigured.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel 82815 Video Card & Ubuntu 8.10 harvey527 Kernel Questions 8 5th November 2010 14:51
User creating shoevring Developers' Forum 7 25th July 2010 10:17
amavis: (!!)WARN: all primary virus scanners failed, considering ba jariasca Installation/Configuration 13 20th April 2010 17:34
Admin Program for Virtual Users and Domains Postfix courier etc...(Ubuntu 8.04)? the1rob HOWTO-Related Questions 11 4th August 2009 04:54
Exim MTA dazblade Server Operation 4 16th July 2007 18:42


All times are GMT +2. The time now is 05:03.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.