Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th November 2011, 11:47
gapa gapa is offline
Junior Member
 
Join Date: Nov 2011
Posts: 7
Thanks: 2
Thanked 0 Times in 0 Posts
Default creating new site with ispconfig kills httpd

Hello,
I am totaly new to this (linux, webserver and Ispconfig) and I just installed my first VPS server. I use centos 6 (64bit) with additional repos (http://rpms.famillecollet.com/) for newest rpm packeges. I followed this tutorial http://www.howtoforge.com/perfect-se...64-ispconfig-3. I had few problems and I solved most of them.
But now that I started Ispconfig (3.0.4 fresh install) I run into new problems. First problem that I had was that when I created new client/site/ftp user/database nothing was created outside of Ispconfig. When I restarted whole server folders, database were created. I don't know why, but this is working now. But one more severe problem occurred. When I create new site my httpd server gets killed. And if I try to start it in console I get this message:
Quote:
Starting httpd: Syntax error on line 72 of /etc/httpd/conf/sites-enabled/100-jotajomo.com.vhost:
FcgidMaxProcesses cannot occur within <VirtualHost> section
If I remove that line I can start httpd service again. I looked in master template file (/usr/local/ispconfig/server/conf/vhost.conf.master) for creating vhost files and there is this line.
I don't know if this is problem with Ispconfig or with my setting (probably regarding mod_fcgi).

If needed I can of course post any additional information.

Any ideas and solutions?

Best regards,
gapa
Reply With Quote
Sponsored Links
  #2  
Old 9th November 2011, 23:49
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Under Server Config > FastCGI, what did you select in the FastCGI config syntax field? Please try the other choice.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
gapa (11th November 2011)
  #3  
Old 10th November 2011, 14:13
gapa gapa is offline
Junior Member
 
Join Date: Nov 2011
Posts: 7
Thanks: 2
Thanked 0 Times in 0 Posts
 
Default

It was selected to "New (apache 2.2)".
When I put it to "Old (apache 2.0)" and recreated the site everything is ok.
Can you please explain why I need to select old apache 2.0. I have installed apache 2.2.15.
Otherwise thanx,

Gapa
Reply With Quote
Reply

Bookmarks

Tags
ispconfig 3, web hosting

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Version 1.3 of the ISPConfig 3 Manual is finally available! falko General 44 2nd December 2011 13:04
Control Panel - E-mail Tab is empty domi-nik General 15 14th April 2011 19:17
PHP warnings after upgrade to ISP config 3.03 stevegjacobs Installation/Configuration 5 30th October 2010 15:31
ispconfig stopped creating Maildir etc bwrob Installation/Configuration 2 7th May 2010 23:07
web site creation in ispconfig 3 (vs ispconfig 2) kterz Installation/Configuration 3 5th May 2009 15:38


All times are GMT +2. The time now is 09:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.